Authorization geht nicht

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Authorization geht nicht

Postby chriser » 04. March 2010 18:12

Hallo erstmal an alle :)
Ich hab ein Problem bei der Authentifizierungsmethode Basic...
Egal wo eine Authentifizierung kommt (zb wenn ich bei SVN was commiten will) bekomm ich zwar die Loginmaske, geben meine Daten richtig ein und schwupps... das Loginfenster kommt wieder...
der SVN-Log zeigt folgenden Fehler:
Code: Select all
[Thu Mar 04 17:36:05 2010] [error] [client 92.75.168.13] access to / failed, reason: require directives present and no Authoritative handler.
[Thu Mar 04 17:36:05 2010] [error] [client 92.75.168.13] access to /error/HTTP_UNAUTHORIZED.html.var failed, reason: require directives present and no Authoritative handler.

Das selbe passiert auch wenn ich mich im Trac einloggen will.

Hier meine vhost-config: (in der httpd.conf habe ich keine Module auskommentiert)
Code: Select all
#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
NameVirtualHost *:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for all requests that do not
# match a ServerName or ServerAlias in any <VirtualHost> block.
#

[...]

<VirtualHost *:80>
    ServerName svn.*****.de
    ErrorLog /opt/lampp/logs/svn-error.log
    CustomLog /opt/lampp/logs/svn-access.log common
    <Location />
   AuthType Basic
   AuthName "SVN Server"
   AuthUserFile /opt/lampp/etc/svn-auth-file
   Require vaild-user
        DAV svn
        SVNPath /var/svn
    </Location>
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot /opt/lampp/htdocs/svn
    ServerName trac.******.de
    <Location />
   SetHandler mod_python
   PythonInterpreter main_interpreter
   PythonHandler trac.web.modpython_frontend
   PythonOption TracEnv /var/trac
   PythonOption PYTHON_EGG_CACHE /tmp
    </Location>
    <Location /login>
   AuthType Basic
   AuthName "Trac Server"
   AuthUserFile /var/trac/trac.htpasswd
   Require vaild-user
    </Location>
</VirtualHost>


Ich hab schon fast das ganze Internet durchstöbert... Meistens fehlte nur der bindestrich zwischen valid und user oder das authz_user module war nicht geladen...
Bei mir stimmt aber beides...
Ich komm einfach nicht drauf^^
Danke schon mal für die Hilfe :)
LG chriser
chriser
 
Posts: 2
Joined: 04. March 2010 18:03

Re: Authorization geht nicht

Postby chriser » 04. March 2010 19:49

OMFG bin ich ein Idiot^^ Der Bindestrich war da... Aber ich hab statt "valid-user" "vaild-user" geschrieben!! ARGH
SVN geht jetzt aber Trac immer noch nicht...^^
chriser
 
Posts: 2
Joined: 04. March 2010 18:03


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests