Speicherzugriffsfehler | Segmentationfault

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Speicherzugriffsfehler | Segmentationfault

Postby pureskills » 09. February 2010 14:11

Hey,

ich hab PLÖTZLICH komische problem mit lampp 1.7.3a mit fedora 12 (32bit). Ich hab keine ahnung woher diese Fehlermeldung kommen vor einem Tag ging noch alles ohne Probleme:

Fehler:

Code: Select all
[root@ding1]# /opt/lampp/lampp start
Starte XAMPP fuer Linux 1.7.3a...
XAMPP: Starte Apache mit SSL (und PHP5)...
/opt/lampp/bin/apachectl: Zeile 78:  3047 Speicherzugriffsfehler  $HTTPD $ARGV
XAMPP: Fehler 139 beim Starten vom Apache!
XAMPP: Starte Diagnose...
XAMPP: Sorry, ich weiss nicht was da schief laeuft.
XAMPP: Bitte wende Dich ans Forum http://community.apachefriends.org/f/
XAMPP: Starte MySQL...
XAMPP: Starte ProFTPD...
/opt/lampp/lampp: Zeile 122:  3222 Speicherzugriffsfehler  /opt/lampp/sbin/proftpd > /opt/lampp/var/proftpd/start.err 2>&1
XAMPP:
XAMPP: Fehler 139 beim Starten von ProFTPD!
XAMPP fuer Linux gestartet.


eintrag in der var/log/messages

Code: Select all
Feb  9 14:02:14 ding1 kernel: httpd[2739]: segfault at be905084 ip 0049329b sp be905070 error 6 in libc-2.11.1.so[3d3000+16f000]
Feb  9 14:02:15 ding1 kernel: proftpd[2914]: segfault at bea26594 ip 007c629b sp bea26580 error 6 in libc-2.11.1.so[706000+16f000]
Feb  9 14:02:21 ding1 kernel: proftpd[2936]: segfault at bee041b4 ip 0049329b sp bee041a0 error 6 in libc-2.11.1.so[3d3000+16f000]


Ich hab schon bei google gesucht. Habe auch zwei drei Threads gefunden aber alle fanden keine Lösung bzw. haben das Problem auf das laufende 64bit system zugeführt.

Ich würde mich freuen wenn irgendwer eine Idee hätte. :(

cc
pureskills
 
Posts: 3
Joined: 09. February 2010 14:03

Re: Speicherzugriffsfehler | Segmentationfault

Postby Nobbie » 09. February 2010 14:29

Wenn da nur ein Fehler wäre, könnte man auf ein Problem bei Apache raten. Da aber zwei völlig verschiedene Prozesse (httpd und proftpd) gleichermaßen abstürzen, spricht vieles dafür, dass Du ein Hardware Problem hast.

Ggf. ist die CPU zu heiß (vielleicht ist ein Lüfter kaputt oder verstopft) oder der RAM hat einen Fehler. Oder die Festplatte ist defekt und die ausführbaren Programme ("images" genannt) haben vielleicht schon einen Fehler (werden fehlerhaft geladen).
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

Re: Speicherzugriffsfehler | Segmentationfault

Postby pureskills » 09. February 2010 14:47

hey,

hmm das ist mein computer zu hause, auf dem ich auch gerade diesen Post schreibe! Die Maschine läuft einwandfrei. Null Abstürze sonst irgendwelche Probleme.

Kann es vielleicht was mit meinem Kernel zu tun haben? Ich benutze den PAE anstatt des normalem. Aber irgendwie sehe ich null Verbindung.
pureskills
 
Posts: 3
Joined: 09. February 2010 14:03

Re: Speicherzugriffsfehler | Segmentationfault

Postby pureskills » 09. February 2010 21:06

SOLVED

ich hatte komischer Weise zu viele Zeilen in meiner /etc/hosts drin!

der bug wurde auch schon beschrieben unter

https://bugzilla.redhat.com/show_bug.cgi?id=475845

:)
pureskills
 
Posts: 3
Joined: 09. February 2010 14:03


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests