htdocs verschieben, error Meldung

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

htdocs verschieben, error Meldung

Postby sonya2 » 25. January 2010 18:27

Hallo,

ich hoffe, Ihr könnt mir weiter helfen.
Ein Problem mit htdocs außerhalb von /opt/lampp/.
Ich muss htdocs nach /home/sonya/xyz/htdocs verschieben.
Ab und an hat es hier im Forum Beiträge zum Thema "xampp außerhalb von /opt/ installieren" oder "htdocs verschieben". Aus diesen Beiträgen geht folgendes hervor: "htdocs verschieben, Symlink zu htdocs in /opt/lampp erstellen, Konfigurationsdaten zu docroot anpassen.
Nun habe ich htdocs nach /home/sonya/xyz/verschoben.
Alle Konfigurationsdateien innerhalb von /opt/lampp/ angepasst. Dort die Zeichenfolge /opt/lampp/htdocs zu /home/sonya/xyz/htdocs geändert.
In Firefox 127.0.0.1 aufgerufen:
Code: Select all
Zugriff verweigert!
Der Zugriff auf das angeforderte Verzeichnis ist nicht möglich. Entweder ist kein Index-Dokument vorhanden oder das Verzeichnis ist zugriffsgeschützt.
Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 403


Nun auch alle Rechte innerhalb von /home/sonya/xyz/htdocs und htdocs selbst auf 777 gestellt. Außerdem noch ein Symlink in /opt/lampp nach /home/sonya/xyz/htdocs erstellt.

error_log nach Aufruf von "sudo /opt/lampp/lampp start":
Code: Select all
[Mon Jan 25 16:16:17 2010] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jan 25 16:16:17 2010] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Mon Jan 25 16:16:17 2010] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Mon Jan 25 16:16:17 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Jan 25 16:16:17 2010] [notice] Digest: done
[Mon Jan 25 16:16:18 2010] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Mon Jan 25 16:16:18 2010] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Mon Jan 25 16:16:18 2010] [notice] Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations


Aufruf von "w3m 127.0.0.1" :
Code: Select all
Access forbidden!
You don't have permission to access the requested directory. There is either no
index document or the directory is read-protected.
If you think this is a server error, please contact the webmaster.
Error 403
127.0.0.1
Mo 25 Jan 2010 16:18:07 CET
Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1
mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1

≪ ↑ ↓ Viewing <Access forbidden!>


error_log nach Aufruf von w3m 127.0.0.1:
Code: Select all
[Mon Jan 25 16:18:07 2010] [error] [client 127.0.0.1] (13)Permission denied: access to / denied

access_log nach Aufruf von w3m 127.0.0.1 :
127.0.0.1 - - [25/Jan/2010:16:18:07 +0100] "GET / HTTP/1.0" 403 1121


access_log nach Aufruf von w3m 127.0.0.1 :
Code: Select all
127.0.0.1 - - [25/Jan/2010:16:18:07 +0100] "GET / HTTP/1.0" 403 1121

Das gleiche Verhalten hat es, wenn ich xampp gleich nach /home/sonya/xyz/ installiere, anschließend einen Symlink in /opt/ erstelle.
Das alles unter Ubuntu 9.10 mit Gnome 2.28.1
Ach so:
127.0.0.1/phpmyadmin funktioniert. Da hat es überhaupt keine Fehlermeldungen. Auch keine Einträge in das error_log.

Ein 127.0.0.1/test/test.php (mit <? phpinfo(); ?> ) ergibt ebenfalls die o.g. Meldungen wie sie unter dem Aufruf von 127.0.0.1 erscheinen, auch wenn /test/ und test.php Rechte von 777 haben.
error_log:
Code: Select all
[Mon Jan 25 16:35:10 2010] [error] [client 127.0.0.1] (13)Permission denied: access to /test/test.php denied


Es spielt in allen Fällen keine Rolle, ob ich statt 127.0.0.1 localhost angebe. Die Fehlermeldungen bleiben die Gleichen.

Wie bekomme ich ein funktionierendes XAMPP mit htdocs im Homeverzeichnis?


Ratlose Grüße
Sonya
sonya2
 
Posts: 8
Joined: 25. January 2010 17:23

Re: htdocs verschieben, error Meldung

Postby Nobbie » 25. January 2010 19:17

sonya2 wrote:Ab und an hat es hier im Forum Beiträge zum Thema "xampp außerhalb von /opt/ installieren" oder "htdocs verschieben".


Das ist aber bei weitem nicht das gleiche und ich weiß auch nicht, wer schreibt, dass das Anlegen eines anderen htdocs genauso zu behandeln wäre wie die komplette Installation von Xampp verschieden von /opt.

sonya2 wrote:Aus diesen Beiträgen geht folgendes hervor: "htdocs verschieben, Symlink zu htdocs in /opt/lampp erstellen,


Blödsinn, vergiss das und mache es rückgängig (bzw. lösche den Symbolic Link).


sonya2 wrote:Alle Konfigurationsdateien innerhalb von /opt/lampp/ angepasst. Dort die Zeichenfolge /opt/lampp/htdocs zu /home/sonya/xyz/htdocs geändert.


Welche "alle" Konfigdateien hast Du angepasst? Normalerweise reicht es vollkommen, nur httpd.conf anzupassen und den DocumentRoot inkl. den entsprechenden <Directory>-Block anzupassen. Oder Du machst selbst das nicht und läßt das wie es ist und legst einen neuen VirtualHost an, der als DocumentRoot Dein eigenes Verzeichnis hat.

sonya2 wrote:Außerdem noch ein Symlink in /opt/lampp nach /home/sonya/xyz/htdocs erstellt.


Das ist Quatsch (s.o.) - lösche den wieder.

sonya2 wrote:127.0.0.1/phpmyadmin funktioniert. Da hat es überhaupt keine Fehlermeldungen. Auch keine Einträge in das error_log.


Weil phpmyadmin nicht unter htdocs liegt sondern via ALIAS einen eigenen Ordner hat.

Also vergiss den ganzen Krempel wieder, Du mußt nur den DocumentRoot ändern und die <Directory> Anweisung (da muss insbesondere "Allow From All") drin stehen. Ich vermute, dass Du diese Zeilen nicht angepasst hast. Im Zweifel zeig uns einfach mal Deine Anpassungen.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: htdocs verschieben, error Meldung

Postby sonya2 » 25. January 2010 20:34

Hallo Nobbie,

vielen Dank für Deine Anwort.
Ich habe XAMMP noch einmal neu "installiert":
Code: Select all
sudo tar xvfz xampp-linux-1.7.3a.tar.gz -C /opt

firefox mit 127.0.0.1 aufgerufen. Funktioniert Alles.

Nun das Verzeichnis htdocs nach /home/sonya/Server/ verschoben

Nobbie wrote:Also vergiss den ganzen Krempel wieder, Du mußt nur den DocumentRoot ändern und die <Directory> Anweisung (da muss insbesondere "Allow From All") drin stehen. Ich vermute, dass Du diese Zeilen nicht angepasst hast. Im Zweifel zeig uns einfach mal Deine Anpassungen.



Die /etc/httpd.conf angepasst. Also /opt/lampp/htdocs zu /home/sonya/Server/htdocs geändert. Firefox mit 127.0.0.1 aufgerufen (gleiches Ergebnis mit localhost:
Code: Select all
Zugriff verweigert!
Der Zugriff auf das angeforderte Verzeichnis ist nicht möglich. Entweder ist kein Index-Dokument vorhanden oder das Verzeichnis ist zugriffsgeschützt.
Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
Error 403


Tja, da will noch irgendetwas anderes geändert werden.

Ach so:

Du mußt nur den DocumentRoot ändern und die <Directory> Anweisung (da muss insbesondere "Allow From All") drin stehen. Ich vermute, dass Du diese Zeilen nicht angepasst hast.


Kannst Du mir bitte verraten, wie der Eintrag genau lauten muss. Kommt das einfach so hinein:

Code: Select all
<Directory />
    Options FollowSymLinks
    AllowOverride None
    #XAMPP
    #Order deny,allow
    #Deny from all
# ---> Allow From All
Allow From All
</Directory>


Das schein ja zu fehlen (s.u.)

MFG
Sonya

PS:
Hier noch die httpd.conf (Kommentare gelöscht) und gleich hier angehangen. Hoffe der Beitrag kommt gut herüber.
#
ServerRoot "/opt/lampp"
#
Listen 80
LoadModule authn_file_module modules/mod_authn_file.so
...
...
...

<IfDefine JUSTTOMAKEAPXSHAPPY>
LoadModule php4_module modules/libphp4.so
LoadModule php5_module modules/libphp5.so
</IfDefine>

<IfModule !mpm_winnt_module>
<IfModule !mpm_netware_module>
#
#
User nobody
Group nogroup
</IfModule>
</IfModule>

# 'Main' server configuration

ServerAdmin you@example.com

# ServerName gives the name and port that the server uses to identify itself.

ServerName localhost

#
# DocumentRoot: The directory out of which you will serve your

DocumentRoot "/home/sonya/Server/htdocs"

#
# Each directory to which Apache has access can be configured with respect

<Directory />
Options FollowSymLinks
AllowOverride None
#XAMPP
#Order deny,allow
#Deny from all
</Directory>

#
# Note that from this point forward you must specifically allow

# This should be changed to whatever you set DocumentRoot to.
#
<Directory "/home/sonya/Server/htdocs">
#
# Possible values for the Options directive are "None", "All",
# or any combination of:
# Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
#
# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you.
#
# The Options directive is both complicated and important. Please see
# http://httpd.apache.org/docs/2.2/mod/core.html#options
# for more information.
#
#Options Indexes FollowSymLinks
# XAMPP
Options Indexes FollowSymLinks ExecCGI Includes


#
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
# Options FileInfo AuthConfig Limit
#
#AllowOverride None
# since XAMPP 1.4:
AllowOverride All


#
# Controls who can get stuff from this server.
#
Order allow,deny
Allow from all

</Directory>

#
# DirectoryIndex: sets the file that Apache will serve if a directory
# is requested.
#
<IfModule dir_module>
#DirectoryIndex index.html
# XAMPP
DirectoryIndex index.html index.html.var index.php index.php3 index.php4
</IfModule>

#
# The following lines prevent .htaccess and .htpasswd files from being
# viewed by Web clients.
#
<FilesMatch "^\.ht">
Order allow,deny
Deny from all
</FilesMatch>

#
# ErrorLog: The location of the error log file.

ErrorLog logs/error_log

#
# LogLevel: Control the number of messages logged to the error_log.

LogLevel warn

<IfModule log_config_module>

LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %b" common

<IfModule logio_module>
# You need to enable mod_logio.c to use %I and %O
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
</IfModule>


CustomLog logs/access_log common

</IfModule>

<IfModule alias_module>

ScriptAlias /cgi-bin/ "/opt/lampp/cgi-bin/"

</IfModule>

<IfModule cgid_module>
#
# ScriptSock: On threaded servers, designate the path to the UNIX
# socket used to communicate with the CGI daemon of mod_cgid.
#
#Scriptsock logs/cgisock
</IfModule>

#
# "/opt/lampp/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory "/opt/lampp/cgi-bin">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

#
# DefaultType: the default MIME type the server will use for a document

DefaultType text/plain

<IfModule mime_module>
#
# TypesConfig points to the file containing the list of mappings from
# filename extension to MIME-type.
#
TypesConfig etc/mime.types

# If the AddEncoding directives above are commented-out, then you
# probably should define those extensions to indicate media types:
#
AddType application/x-compress .Z
AddType application/x-gzip .gz .tgz

#AddHandler cgi-script .cgi
# XAMPP, since LAMPP 0.9.8:
AddHandler cgi-script .cgi .pl

# For files that include their own HTTP headers:
#AddHandler send-as-is asis

# For server-parsed imagemap files:
#AddHandler imap-file map

# For type maps (negotiated resources):
#AddHandler type-map var

#
# Filters allow you to process content before it is sent to the client.
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
</IfModule>

EnableMMAP off
EnableSendfile off


# Multi-language error messages
Include etc/extra/httpd-multilang-errordoc.conf

# Fancy directory listings
Include etc/extra/httpd-autoindex.conf

# Language settings
#Include

....
....

# Various default settings
Include etc/extra/httpd-default.conf

# Secure (SSL/TLS) connections
<IfModule ssl_module>
# XAMPP
<IfDefine SSL>
Include etc/extra/httpd-ssl.conf
</IfDefine>
</IfModule>
#
<IfModule ssl_module>
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
</IfModule>

# XAMPP
Include etc/extra/httpd-xampp.conf
sonya2
 
Posts: 8
Joined: 25. January 2010 17:23

Re: htdocs verschieben, error Meldung

Postby Nobbie » 25. January 2010 21:44

sonya2 wrote:Die /etc/httpd.conf angepasst.


Im Ernst? Gibt es dort so eine Datei? Du mußt die Datei /opt/lampp/etc/httdp.conf anpassen, nicht /etc/httpd.conf

sonya2 wrote:Kannst Du mir bitte verraten, wie der Eintrag genau lauten muss. Kommt das einfach so hinein:

Code: Select all
<Directory />
    Options FollowSymLinks
    AllowOverride None
    #XAMPP
    #Order deny,allow
    #Deny from all
# ---> Allow From All
Allow From All
</Directory>



Da kann das "Deny from all" drin bleiben, das "Allow from all" ist dort nicht empfehlenswert (weil das Root Verzeichnis Deines Rechners ist).

Der Rest sieht im Prinzip richtig aus, nur leider hast Du die Zeilen auskommentiert, ob ggf. httpd-vhosts.conf inkludiert wird und wenn ja, ob da ggf. eine Einstellung überschrieben wird.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: htdocs verschieben, error Meldung

Postby sonya2 » 26. January 2010 09:53

Hallo Nobbie,

Nobbie wrote:Im Ernst? Gibt es dort so eine Datei? Du mußt die Datei /opt/lampp/etc/httdp.conf anpassen, nicht /etc/httpd.conf


Natürlich meine ich die /opt/lampp/etc/httdp.conf . Entschuldige bitte den Vertipper.
sonya2 wrote:Kannst Du mir bitte verraten, wie der Eintrag genau lauten muss. Kommt das einfach so hinein:

Code: Select all
<Directory />
    Options FollowSymLinks
    AllowOverride None
    #XAMPP
    #Order deny,allow
    #Deny from all
# ---> Allow From All
Allow From All
</Directory>



Da kann das "Deny from all" drin bleiben, das "Allow from all" ist dort nicht empfehlenswert (weil das Root Verzeichnis Deines Rechners ist).

Der Rest sieht im Prinzip richtig aus, nur leider hast Du die Zeilen auskommentiert, ob ggf. httpd-vhosts.conf inkludiert wird und wenn ja, ob da ggf. eine Einstellung überschrieben wird.


Die Zeile "Include etc/etra/httpd-vhosts.conf" ist als kommentiert mit einer Raute versehen.
Auskommentiert sind:
Include etc/extra/httpd-multilang-errordoc.conf
Include etc/extra/httpd-autoindex.conf
Include etc/extra/httpd-default.conf
Include etc/extra/httpd-ssl.conf
Include etc/extra/httpd-xampp.conf

Es ist also eine httpd.conf wie sie direkt nach der "Installation" von XAMPP erzeugt wurde.
Habe wie von Dir oben beschrieben nur die DocumentRoot auf "/home/sonya/Server/htdocs" geändert und "<Directory..."wie folgt angepasst:
<Directory "/home/sonya/Server/htdocs">
Alles andere sonst beim alten belassen.

MFG
Sonya
sonya2
 
Posts: 8
Joined: 25. January 2010 17:23

Re: htdocs verschieben, error Meldung

Postby Nobbie » 26. January 2010 11:08

Wie hast Du denn die htdocs "verschoben" und ist da wirklich alles angekommen?

P.S.: Lösche auch mal den Browser Cache, vielleicht läuft es ja längst und der Browser weiß nichts davon... Ich habe das gerade mal bei mir getestet, es läuft sofort genau so wie beschrieben. Vollkommen fehlerfrei und problemlos, mit genau nur den beiden Änderungen in httpd.conf, eine funkelnagelneue Xampp Installation und den htdocs verschoben nach /home/meinuserid/Server/htdocs
Last edited by Nobbie on 26. January 2010 11:20, edited 1 time in total.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: htdocs verschieben, error Meldung

Postby Wiedmann » 26. January 2010 11:13

[Mon Jan 25 16:35:10 2010] [error] [client 127.0.0.1] (13)Permission denied: access to /test/test.php denied

Nun auch alle Rechte innerhalb von /home/sonya/xyz/htdocs und htdocs selbst auf 777 gestellt.

Der Apache (User nobody) braucht zumindest Leserechte für jedes Verzeichnis in diesem Pfad. Nicht nur für das letzte "htdocs".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: htdocs verschieben, error Meldung

Postby Nobbie » 26. January 2010 11:22

Wiedmann wrote:Der Apache (User nobody) braucht zumindest Leserechte für jedes Verzeichnis in diesem Pfad. Nicht nur für das letzte "htdocs".


Das sollte eigentlich die Default-Konfiguration sein, normalerweise haben /home und die User 755 als Berechtigungen (d.h. "world" darf lesen). Bei mir läuft es auch auf Anhieb. Aber in jedem Fall sollte Sonya das auch dennoch prüfen. Vielleicht hat "./Server" ja ungenügende Rechte.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: htdocs verschieben, error Meldung

Postby Wiedmann » 26. January 2010 11:35

Das sollte eigentlich die Default-Konfiguration sein,

Keine Ahnung was bei Linux default ist. "(13)Permission denied" bedeutet jedenfalls, dass der Apache selbst nicht auf das Verzeichnis/Datei zugreifen kann/darf (durch Dateisystemberechtigungen).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: htdocs verschieben, error Meldung

Postby Nobbie » 26. January 2010 12:47

Wiedmann wrote:Keine Ahnung was bei Linux default ist. "(13)Permission denied" bedeutet jedenfalls, dass der Apache selbst nicht auf das Verzeichnis/Datei zugreifen kann/darf (durch Dateisystemberechtigungen).


Es gibt auch keine "Linux-Default-Einstellung". Es gibt den Parameter "umask" der definiert, mit welchen Defaultrechten neue Dateien/Ordner angelegt. Bei den meisten Distributionen ist der so eingestellt, dass daraus 755 (bzw. 644 für Dateien) resultiert, wenn ein normaler User eine neue Datei anlegt.

Aber das kann natürlich jeder Anwender für sich ändern und ebenso kann man natürlich im Nachhinein alle Rechte ebenso ändern. Ich vermute auch, dass aus irgendeinem Grund der Ordner "./Server" nicht lesbar ist. Aber vielleicht existiert er auch gar nicht (Gross/Kleinschreibung, das LInux Filesystem ist case-sensitiv)?!
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: htdocs verschieben, error Meldung

Postby sonya2 » 26. January 2010 19:10

Hallo Wiedmann,

danke für Deine Antwort.
Der Apache (User nobody) braucht zumindest Leserechte für jedes Verzeichnis in diesem Pfad. Nicht nur für das letzte "htdocs".[/quote]

Rechte auf ei Verzeichnis höher. Das ist schon einmal interessant.


Zur Geschichte. Ich benutzte XAMMP (auch WAMP) schon sehr lange. Bisher auf verschiedenen Rechnern und versch. Betriebssystemen. Immer ohne Probleme. Das Ganze zum Testen von eigenen Webseiten.
Dazu habe ich unter Linx bisher immer dem Verzeichnis htdocs (unter /opt/lamp/) die Rechte mit meinem Usernamen und meiner Gruppe verpasst, nichts weiter! (unter Ubuntu ist das also Usewr: sonya Gruppe: sonya). So war und bin ich also als User in der Lage innerhalb von "htdocs" Verzeichnisse und Dateien zu erstellen und zu ändern (Bei inf, conf und anderen configdateien für PHP Anwendungen natürlich die notwendigen chmod). Das hat immer bestens funktioniert. Auch im Moment.
Kopiere ich nun zwangsläufig den Ordner htdocs samt allen Inhalten nach /home/sonya/Server/ und passe in /opt/lampp/etc die httpd.conf an (aus 2x /opt/lampp/htdocs wird /home/sonya/Server/htdocs) . Dann "sudo /opt/lampp/lampp stop" und "sudo /opt/lampp/lampp start" und gar den Rechner neu gestartet und sudo /opt/lampp/lampp start". Es erscheint beim Browseraufruf von 127.0.0.1 "Zugriff verweigert! .... Error 403 ..."

Auf ein Neues:
cd /home/sonya/Download/
sudo tar xvfz xampp-linux-1.7.3a.tar.gz -C /opt
firefox 127.0.0.1

Alles fein, alles funktioniert :)
User und Gruppe von "htdocs" auf sonya gesetzt.
Eigene Backups wieder nach "htdocs" verfrachtet. Alles Fein, alles Bestens. Funktioniert.

Ach so User nobody gab es bisher noch NIE auf dem System.

Jetzt htdocs nach /home/sonya/Server/ kopiert (als User "sonya") Alles Inhalte von "htdocs" sind kopiert. Nochmals Rechte geprüft.
Browseraufruf von 127.0.0.1 "Zugriff verweigert! .... Error 403 ..." :(

Als User "sonya" neues Verzeichnis "test" mit der Datei "test.php" erstellt (Inhalt <? phpinfo(); ?> )
Browseraufruf von 127.0.0.1/test/test.php "Zugriff verweigert! .... Error 403 ..." :(
test.html angelegt (mit bla, bla...)
Browseraufruf von 127.0.0.1/test/test.html "Zugriff verweigert! .... Error 403 ..." :(

"Server" in dem "htdocs" liegt hat "sonya/sonya" als User und Gruppe, so wie htdocs in /opt/lampp auch hatte.
Nun habe ich dem Verzeichnis "Server" und "htdocs" die Rechte 777 verpasst. Gleiches Problem. Jetzt allen Dateien und Verzeichnissen innerhalb von /home/sonya/Server/htdocs die Rechte 777 gegeben. Gleiches Problem.

Es muss doch irgendwie möglich sein, htdocs außerhalb von /opt/lampp/ zu betreiben.(?)

Ratlose Grüße von Sonya
sonya2
 
Posts: 8
Joined: 25. January 2010 17:23

Re: htdocs verschieben, error Meldung

Postby sonya2 » 26. January 2010 19:14

Nobbie wrote:
Wiedmann wrote:Der Apache (User nobody) braucht zumindest Leserechte für jedes Verzeichnis in diesem Pfad. Nicht nur für das letzte "htdocs".


Das sollte eigentlich die Default-Konfiguration sein, normalerweise haben /home und die User 755 als Berechtigungen (d.h. "world" darf lesen). Bei mir läuft es auch auf Anhieb. Aber in jedem Fall sollte Sonya das auch dennoch prüfen. Vielleicht hat "./Server" ja ungenügende Rechte.


Na ja. mehr als 777 kann ich "Server" ja nicht geben (bei User: "sonya" und Gruppe "sonya"). Denn das Verzeichnis "Server" habe ja ich als User in meinem Homeverzeichnis erstellt.

MFG
Sonja
sonya2
 
Posts: 8
Joined: 25. January 2010 17:23

Re: htdocs verschieben, error Meldung

Postby Nobbie » 26. January 2010 23:17

sonya2 wrote:Es muss doch irgendwie möglich sein, htdocs außerhalb von /opt/lampp/ zu betreiben.(?)


Wie ich oben schon schrieb, ist das supereinfach. Bei mir lief es sofort, Aufwand max. 1 Minute.

Ich weiß nicht was Du alles falsch machst, aber Du beantwortest ja schon meine Fragen nicht mehr (s.o. - wie hast Du htdocs verschoben). Außerdem erwähnst Du auf einmal irgendein Backup, während Du vorher noch behauptet hast, eine neue Xampp Installation zu verschieben. Was denn nun?

Irgendwo machst Du da etwas falsch, wenn ich an Deinem Computer säße hätte ich es wahrscheinlich in 2 Minuten raus, aber Ferndiagnosen mit halben oder gar fehlenden Antworten sind extrem mühselig.

Versuche doch mal bitte langsam und Stück für Stück zu arbeiten. Erst Xampp installieren. Dann htdocs verschieben (bitte dokumentieren, wie Du es verschiebst). Dann httpd.conf anpassen, nur die Angaben für DocumentRoot und <Directory>. Nicht User und Group anpassen (den User Nobody sollte es sehr wohl geben). Und dann Apache starten und testen. KEIN BACKUP EINSPIELEN!
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Re: htdocs verschieben, error Meldung

Postby sonya2 » 27. January 2010 09:55

Guten Morgen Nobbie,


Nobbie wrote:Ich weiß nicht was Du alles falsch machst, aber Du beantwortest ja schon meine Fragen nicht mehr (s.o. - wie hast Du htdocs verschoben). Außerdem erwähnst Du auf einmal irgendein Backup, während Du vorher noch behauptet hast, eine neue Xampp Installation zu verschieben. Was denn nun?


Wie ich oben beschrieb "Auf ein Neues".
Ein paar kleine Dinge als "Backup" (also eine kleine eigene Website die vorher unter /opt/lampp/htdocs/website1/ lief) habe ich zurückkopiert nur um zu testen ob das neue XAMPP mit htdocs in /opt/lampp/ überhaupt erst mit 127.0.0.1 funktioniert und die eigenen Dinge unter 127.0.0.1/website1 ebenfalls funktionieren. Das funktioniert auch und es sollte eigentlich kein Missverständnis hervorrufen.
Nun kann das mit dem Backup nur funktionieren wenn htdocs für User sonya und dar Gruppe sonya freigegeben ist. Sonst hätte ich das gernicht dorthin bringen können.

Irgendwo machst Du da etwas falsch, wenn ich an Deinem Computer säße hätte ich es wahrscheinlich in 2 Minuten raus, aber Ferndiagnosen mit halben oder gar fehlenden Antworten sind extrem mühselig.


Es tut mir leid wenn das so sehr nervt. Ich denke es war doch recht anschaulich mit "Auf ein Neues" beschrieben.

Versuche doch mal bitte langsam und Stück für Stück zu arbeiten. Erst Xampp installieren. Dann htdocs verschieben (bitte dokumentieren, wie Du es verschiebst). Dann httpd.conf anpassen, nur die Angaben für DocumentRoot und <Directory>. Nicht User und Group anpassen (den User Nobody sollte es sehr wohl geben). Und dann Apache starten und testen. KEIN BACKUP EINSPIELEN!



Entschuldigung "nobody" existiert natürlich.
Code: Select all
cat /etc/passwd
... ...
nobody:x: ....
... ...



Also:
Verzeichnis "Server" in /home/sonya/ auf User: nobody und Gruppe: root mit 777
cd /home/sonya/Download/
sudo tar xvfz xampp-linux-1.7.3a.tar.gz -C /opt
cd /opt/lampp
sudo mv htdocs /home/sonya/Server/
sudo geany /opt/lampp/etc/httpd.conf
angepasst:
DocumentRoot "/home/sonya/Server/htdocs"
und
<Directory "/home/sonya/Server/htdocs">

Dann sudo /opt/lampp/lampp start
firefox cache geleert. Steht per Einstellung auch auf "0"
Im Firefox 127.0.0.1 aufgerufen
"Zugriff verweigert" ... Error 403 ...

MFG
Sonya
sonya2
 
Posts: 8
Joined: 25. January 2010 17:23

Re: htdocs verschieben, error Meldung

Postby Nobbie » 27. January 2010 11:05

Dann prüfen wir jetzt die Rechte der Ordner (bitte eingeben und Ausgabe hier einstellen):

Code: Select all
ls -ld /home
ls -ld /home/sonya
ls -ld /home/sonya/Server
ls -ld /home/sonya/Server/htdocs
ls -l /home/sonya/Server/htdocs
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Next

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest