MySQL-Datenbank deaktiviert

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL-Datenbank deaktiviert

Postby hike39 » 12. January 2010 11:30

Hallo,
ich habe soeben XAMPP (Linux) 1.7.3a installiert und in Betrieb genommen. Beim ersten Status-Check waren auch bis auf die PHP-Erweiterungen alle Funktionen aktiviert. Nachdem ich allerdings das Security-Script abgearbeitet hatte, was die MySQL-Datenbank plötzlich deaktiviert. In der Beschreibung zu dem Script wird zwar eine Abfrage nach der Erreichbarkeit der DB über das Netz angesprochen, diese kam jedoch nicht. In der Datei my.cnf ist der Eintrag "skip-networking" auskommentiert.

Da ich in den diversen Foren noch keinen Hinweis gefunden habe, wie man die DB wieder aktiviert, und dies auch schon der zweite Versuch und Tag ist, den ich mit Fehlersuche verbracht habe, bitte ich hier um Hilfe.

hike39
hike39
 
Posts: 2
Joined: 12. January 2010 11:15

Re: MySQL-Datenbank deaktiviert

Postby beise » 19. January 2010 23:43

Hallo, ich darf mich bitte mal hier dranhängen:

Gleiches Problem nach Ausführung des security scripts.

Hier der Inhalt des Error Logs:
Andy1:/opt/lampp/var/mysql # cat Andy1.err
100119 23:23:30 mysqld_safe Starting mysqld daemon with databases from /opt/lampp/var/mysql
100119 23:23:30 [Note] Plugin 'FEDERATED' is disabled.
100119 23:23:30 [ERROR] Can't open shared library 'libpbxt.so' (errno: 0 API version for STORAGE ENGINE plugin is too different)
100119 23:23:30 [Warning] Couldn't load plugin named 'PBXT' with soname 'libpbxt.so'.
InnoDB: The first specified data file /opt/lampp/var/mysql/ibdata1 did not exist:
InnoDB: a new database to be created!
100119 23:23:30 InnoDB: Setting file /opt/lampp/var/mysql/ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
100119 23:23:30 InnoDB: Log file /opt/lampp/var/mysql/ib_logfile0 did not exist: new to be created
InnoDB: Setting log file /opt/lampp/var/mysql/ib_logfile0 size to 5 MB
InnoDB: Database physically writes the file full: wait...
100119 23:23:31 InnoDB: Log file /opt/lampp/var/mysql/ib_logfile1 did not exist: new to be created
InnoDB: Setting log file /opt/lampp/var/mysql/ib_logfile1 size to 5 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
100119 23:23:31 InnoDB: Started; log sequence number 0 0
100119 23:23:31 [Note] Event Scheduler: Loaded 0 events
100119 23:23:31 [Note] /opt/lampp/sbin/mysqld: ready for connections.
Version: '5.1.41' socket: '/opt/lampp/var/mysql/mysql.sock' port: 3306 Source distribution
---------------------------------------

Auch mit MySql Admin keineMöglichkeit, auf MySql zuzugreifen.


System: Opensuse 11.2

hat jemand eine Idee, wo es klemmen könnte. Meine Idee ist erst mal, mir eine ältere Xampp Version zum Gegencheck zu holen.

mfg
beise
beise
 
Posts: 1
Joined: 19. January 2010 23:32

Re: MySQL-Datenbank deaktiviert

Postby hike39 » 20. January 2010 08:39

Hallo,

ich bin währendessen wieder auf XAMPP 1.7.1. Und siehe da plötzlich konnte ich auch von JOOMLA her auf MySQL zugreifen. Ich habe allerdings nicht noch weiter untersucht, woran das Problem lag. Für mich war es das Wichtigste, dass ich mein CMS-Testsystem betreiben kann.

Ich werde diesen Thread aber verfolgen, denn man weiss ja nie, wann man wieder vor dem gleichen Problem steht.

Bis dennen
hike39
hike39
 
Posts: 2
Joined: 12. January 2010 11:15

Re: MySQL-Datenbank deaktiviert

Postby meon » 15. February 2010 12:30

Habe selbes Problem mit lampp 1.7.3 auf DSL 4.4.10 (Damn Small Linux) also Debian,
inzwischen nach 1 Woche recherche nicht beheben können.

Folgende Situation:

- Nach /opt/lampp/lampp security ist mySQL deaktiviert,
-- für CMS-Systeme wie Joomla noch verwendbar
-- eGroupware liefert jedoch ERROR 2002 (HY000:( Can't connect to local MySQL server through socket '/opt/lampp/var/mysql/mysql.sock' (2)

- Benutzerrechte der mit dem mySQL start generierten Datei mysql.sock: nobody:nogroup sollten eigentlich passen, obwohl laut hier nobody:root vorgabe ist.
-- hier hat anscheinend chmod 777 geholfen http://www.developers-guide.net/forums/6514,mysql-config, möchte ich aber nicht machen.
-- Einigemale bei manuellem mySQLserver start manuell kam auch Connection Error mit Passwort NO.....
--- Evtl. muss man in der httpd.conf oder anderer Config das Passwort für die Datenbank hinterlegen?

- alle Verwesie in my.cnf, php.ini etc. sind auf die /opt/lampp/var/mysql/mysql.sock korrekt angegeben
-- http://ubuntuforums.org/archive/index.php/t-312460.html
meon
 
Posts: 1
Joined: 15. February 2010 12:16

Install failed and corrupted DB

Postby chabbani » 20. January 2014 21:05

I have tried to install XAMPP Joomla on the top of standard CMAPP on Centos 6.5 and latest XMAPP

I get error message infall failed, error run setup-3.php

Parse Error: syntax error, unexpected 'me' (T_STRING) in setup-3.php line 8

Then the database is not usable any more.

I hope if you have a feedback.
chabbani
 
Posts: 1
Joined: 20. January 2014 20:58
Operating System: Centos 6.5

Re: Install failed and corrupted DB

Postby Nobbie » 20. January 2014 23:03

chabbani wrote:I get error message infall failed, error run setup-3.php

Parse Error: syntax error, unexpected 'me' (T_STRING) in setup-3.php line 8

Then the database is not usable any more.

I hope if you have a feedback.



Frage bei Joomla nach, das ist doch deren Installationsscript.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests