MySQL Problem

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL Problem

Postby crivi » 05. January 2004 15:24

Hallo zusammen

Ich habe das xampp auf meinem Redhat 9 Server installiert.

Jetzt wenn ich mit MySQL Front auf die Datenbank zugreifen will erscheint folgende meldung:

Connection failed:
1045 - Acces denied for User 'root'


Wo muss ich da die Berechtigungen einstellen?

Ich habe vorhin eine andere MySQL Dämon gehabt. Jetzt hatte ich da 3 Datenbanken. Wie kann ich die Datenbanken jetzt noch holen? Wo sind die standardmässig abgespeichert, und wohin muss ich se jetzt kopieren?

und anbei. wie machen ich den 'affenschwanz' att auf linux :-)

Danke
User avatar
crivi
 
Posts: 51
Joined: 21. July 2003 14:10
Location: *SCHWEIZ*

Postby DJ DHG » 05. January 2004 15:31

Moin Moin

1. steht im FAQ

http://faq.kwm-web.info/index.php?sid=1 ... 11&lang=de

2. hier im forum wurde das auch schon diskutiert!

3. du musst deine alten dantenbank als dump speichern und in den
neuen mysqlserver einfügen..

DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby crivi » 05. January 2004 15:51

so schon stosse ich wieder an.

ins PHPMYADMIN kann ich mich mit root einloggen.

Aber wenn ich dasselbe mit MySQL Front mache, geht es net.

In der MySQLAdmin config datei habe ich allerding bei der Authentifizierung http eingegeben, da jenach dem wer sich einloggt andere datenbanken zu sehen sind.

Wie mache ich so ein Dump. Ich kann ja auf die alten MySQL Sachen nicht mehr zugreifen, seit ich xampp 1.4 installiert habe.

Danke schon im Voraus
User avatar
crivi
 
Posts: 51
Joined: 21. July 2003 14:10
Location: *SCHWEIZ*

Postby DJ DHG » 05. January 2004 16:09

Lampp stopen, alten mysql server starten.

http://www.mysql.de/doc/de/mysqlhotcopy.html <--- Lesen

mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby crivi » 05. January 2004 16:19

also dankeschön.

Jetzt siehts so aus:

mysqlhotcopy crivi [/pfad/zu/neuem_verzeichnis]

Was muss ich da für ein Pfad angeben, dass die db danach im Lampp ist?

danke
User avatar
crivi
 
Posts: 51
Joined: 21. July 2003 14:10
Location: *SCHWEIZ*

Postby crivi » 05. January 2004 16:31

also im /opt/lampp/lib/mysql/mysql hab ich alle Datenbanken drin, die ich brauche.

Aber im PHPMYADMIN werden sie nicht angezeigt. was mache ich denn jetzt schon wieder falsch?
User avatar
crivi
 
Posts: 51
Joined: 21. July 2003 14:10
Location: *SCHWEIZ*

Postby crivi » 05. January 2004 16:45

also dieses problem hätte ich gelöst.

Es war der pfad: /opt/lampp/var/mysql

Es hat auch funktioniert.

Nur ist jetzt wieder das Problem mit der Berechtigung aufgetreten:

Folgende Fehlermeldung erscheit:

Warning: mysql_connect(): Access denied for user: 'root@sh3-0527.soft-solutions.ch' (Using password: YES) in /opt/lampp/htdocs/crivi/statistik.php on line 51
Der Host, Benutzername oder das Passwort stimmen nicht überein!!


was ist da falsch?

Der Benutzername und das Passwort habe ich in der PHP Datei richtig hinterlegt

//edit:

Wenn ich z.b mein counter anschaue, mit den gleichen zugangsdaten dann funktioniert er.

Ich bin am verzweifeln.
User avatar
crivi
 
Posts: 51
Joined: 21. July 2003 14:10
Location: *SCHWEIZ*

Postby crivi » 05. January 2004 17:15

kann mir denn niemand helfen?

Ich schreib da so vor mich hin und werde nicht erhört.
User avatar
crivi
 
Posts: 51
Joined: 21. July 2003 14:10
Location: *SCHWEIZ*

Postby crivi » 05. January 2004 17:56

habe den Fehler gefunden. Also close
User avatar
crivi
 
Posts: 51
Joined: 21. July 2003 14:10
Location: *SCHWEIZ*


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests