Unerwünschtes Datei-Downloadfenster

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Unerwünschtes Datei-Downloadfenster

Postby Zero Pointer » 09. November 2009 11:26

Hallo liebe Leute

Ich habe ein ziemlich merkwürdiges Problem.
Ich habe vor Kurzen Lampp 1.7.2 auf einem SuSe 11.1 (64 bit) System installiert .
Soweit ist die Installation von Lampp noch auf dem initialen Stand.
Die mitgelieferten Seiten laufen auch alle einwandfrei.
Soweit Kein Problem.

Jetzt habe ich ein kleines Script geschrieben:

Code: Select all
 <?php
if(isset($_POST['Abgeschickt'])){
   if (!mysql_connect("localhost", "root", "")) {
         die ("Verbindung zum Server fehlgeschlagen.");
    }
    if (!mysql_select_db("Hudz Dummy")) {
       die ("Datenbank nicht gefunden.");
    }
   $query="INSERT INTO Aussentermine (`Anrede`, `Vorname`, `Nachname`, `Strasse`, `Ort`, `PLZ`, `Telefon Agent`, `Aussenmitarbeiter`, `Datum`, `Uhrzeit`, `Produkt`, `Zusatzprodukte`, `Bemerkungen`)VALUES ('".$_POST['Anrede']."','". $_POST['Vorname']."','". $_POST['Nachname']."','". $_POST['Strasse']."','". $_POST['Ort']."',". $_POST['PLZ'].",'". $_POST['Telefon_Agent']."','". $_POST['Aussen_Mitarbeiter']."','". $_POST['Datum']."','". $_POST['Uhrzeit']."','". $_POST['Produkt']."','". $_POST['Zusatzprodukte']."','". $_POST['Bemerkungen']."')";
   mysql_query($query) or die('Error, insert query failed' . mysql_error());
   $query = "FLUSH PRIVILEGES";
   mysql_query($query) or die('Error, insert query failed');
   mysql_close();
}
 ?>
 

<html>
  <head>
    <title>Termine</title>
  </head>
  <body bgcolor="#BBFFFF">
      <form action="Index.php" method="POST">
<table>
<tr>
<th>Termine</th>
</tr>
<tr><td>Anrede</td></tr>
<tr>
<td>
   <select size="1" name="Anrede">
         <option></option>
      <option>Herr</option>
      <option>Frau</option>
   </select>
   </td>
</tr>
<tr>
<td>Vorname</td><td>Nachname</td>
</tr>
<tr>
   <td>
   <input type="text" size="30" name="Vorname">
   </td>
   <td>
   <input type="text" size="30" name="Nachname">
   </td>
</tr>
<tr><td>Stra&szlig;e</td><td>Ort</td><td>PLZ</td></tr>
<tr>
<td>
   <input type="text" size="30" name="Strasse">
   </td>
   <td>
   <input type="text" size="30" name="Ort">
   </td>
   <td>
   <input type="text" size="30" name="PLZ">
   </td>
</tr>
<tr><td>Telefon Agent</td><td>Au&szlig;en Mitarbeiter</td></tr>
<tr>
<td>
   <input type="text" size="30" name="Telefon_Agent">
   </td>
   <td>
   <input type="text" size="30" name="Aussen_Mitarbeiter">
   </td>
   </tr>
<tr><td>Datum</td><td>Uhrzeit</td></tr>
<tr>
<td>
   <input type="text" size="30" name="Datum">
   </td>
   <td>
   <input type="text" size="30" name="Uhrzeit">
   </td>
</tr>
<tr><td>Produkt</td><td>Zusatzprodukte</td></tr>
<tr>
<td>
   <input type="text" size="30" name="Produkt">
   </td>
   <td>
   <input type="text" size="30" name="Zusatzprodukte">
   </td>
</tr>
<tr><td>Bemerkungen</td></tr>
<tr>
<td>
   <textarea cols="30" rows="5" name="Bemerkungen"></textarea>
   </td>
</tr>
<tr>
<td>
<input type="submit" name="Abgeschickt" value="Eintragen">
</td>
</tr>
</table>
    </form>
  </body>
</html>



Dieses Script soll (Anfangs noch rudimentär) eine Eingabemaske für eine Datenbank realisieren.
Und soweit funktioniert auch alles. Nach dem Klick auf den Submit-Button wird die Verbindung zur Datenbank aufgebaut. Die Daten werden aus dem Formular übernommen und in die Datenbank geschrieben.
Nun allerdings das Problem. Nachdem das alles geschehen ist, öffnet sich ein Datei-Download Fenster um dieses Script als Datei herunter zu laden. Dies ist so nicht gewollt. Eigentlich soll die seite einfach nur neu laden um für einen weiteren Datensatz bereit zu sein.

Wenn ich das PHP Script am Anfang der Datei auskommentiere läd das Script korrekt. Kommentiere ich dann nur:
Code: Select all
 if (!mysql_connect("localhost", "root", "")) {
         die ("Verbindung zum Server fehlgeschlagen.");
      mysql_close();


wieder ein tritt der Fehler wieder auf.
Da ansonsten das Script fehlerfrei arbeitet, tippe ich darauf ,dass irgend ein Server oder PHP Einstellungs-Problem dafür verantwortlich ist. Jedoch reichen meine bisherigen Kenntnisse nicht dafür aus in irgend einer Weise das Problem zu finden. Zumal ich auch keine Fehlermeldung erhalte um diese Sache in Internet effektiv recherchieren zu können.
Ich hoffe dass ihr mir weiterhelfen könnt.
Ich danke euch schon mal im Vorraus.
mfg Zero Pointer.
Zero Pointer
 
Posts: 1
Joined: 09. November 2009 10:28

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests