umlaute nach installation als ?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

umlaute nach installation als ?

Postby eX2x » 02. November 2009 11:11

Hallo zusammen

Ich habe einen Server mit openSuse 11.1 mit minimalkonfiguration ausgestattet, mache ein "tar xvfz lampp.... /opt", danach mach ich ein "./lampp security" und setze meine Passwörter, anschliessend starte lampp bzw. xampp mit "./lampp start"...

Wenn ich mich einlogge zeigt er mir die Umlaute als ? ...Er kennt die Umlaute nicht...Wo muss ich was ändern? Sollte die Installation "out-of-the-box" nicht einfach so funktionieren? Es sind noch keinerlei Änderungen am Apache oder mySQL vorgenommen worden....

Gruß
eX2x
eX2x
 
Posts: 2
Joined: 02. November 2009 11:04

Re: umlaute nach installation als ?

Postby eX2x » 02. November 2009 12:13

Falls es wen interresiert, habe den/die Fehler gefeunden...

Systemweites setzen der locales unter suse z.B. /etc/bash.bashrc
Code: Select all
export LANG="de_DE@euro"
export LC_CTYPE="de_DE@euro"
export LC_NUMERIC="de_DE@euro"
export LC_TIME="de_DE@euro"
export LC_COLLATE="de_DE@euro"
export LC_MONETARY="de_DE@euro"
export LC_MESSAGES="de_DE@euro"
export LC_PAPER="de_DE@euro"
export LC_NAME="de_DE@euro"
export LC_ADDRESS="de_DE@euro"
export LC_TELEPHONE="de_DE@euro"
export LC_MEASUREMENT="de_DE@euro"
export LC_IDENTIFICATION="de_DE@euro"
export LC_ALL="de_DE@euro"


Setzen der Sprachen in der /opt/lampp/etc/httpd.conf
Code: Select all
# Language settings
Include etc/extra/httpd-languages.conf


Hinzufügen des default Charset für Apache /opt/lampp/etc/extra/httpd-languages.conf:
Code: Select all
AddDefaultCharset ISO-8859-1


Trotzdem Danke ;)
eX2x
 
Posts: 2
Joined: 02. November 2009 11:04


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests

cron