lampp auf einem nas-server

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

lampp auf einem nas-server

Postby Commu » 19. September 2009 13:55

hallo Zusammen,

ich wollte lampp auf einem nas-server starten.
leider bekomme ich eine Fehlermeldung:
-sh: /share/HDA_DATA/opt/lampp/lampp: /bin/bash: bad interpreter: No such file or directory
kurze erläuterung:
im root war nicht genügend platz da bin ich auf eine zusätzliche festplatte ausgewichen.

Ich habe die Umgebungsvariable angepasst bzw $PATH erweitert auf :/share/HDA_DATA/:/share/HDA_DATA/opt/lampp/

kann mir einer helfen?
Commu
 
Posts: 6
Joined: 06. September 2007 13:41
Location: Hennef

Re: lampp auf einem nas-server

Postby Nobbie » 19. September 2009 14:06

Die Fehlermeldung sagt genau das, was fehlt: /bin/bash fehlt auf Deinem System.

Entweder installierst Du die "Bash" nach (beste Lösung) oder machst einen Symbolic Link von /bin/sh nach /bin/bash (zweitbeste Lösung - kann aber sein, dass dann Folgefehler kommen, weil Unix-Shells nicht 100% kompatibel zueinander sind), oder Du editierst das lampp-Script und änderst die erste Zeile ("Shebang" genannt). Dort steht u.a. "/bin/bash" und stattdessen nimmst Du "/bin/sh". Hat aber die gleiche Problematik wie der Symbolic Link, es kann Folgefehler geben.

Unabhängig davon wird lampp nicht funktionieren, es MUSS(!!) in /opt/lampp installiert sind. Deswegen MUSST Du die andere Platte entweder dahin mounten, oder einen Symbolic Link nach /opt/lampp legen.

Der PATH muss überhaupt angepasst werden, das hast Du Dir frei ausgedacht, davon steht überhaupt nichts in der Installationsansweisung. Das nützt gar nichts.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests