LAMPP startet nicht

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

LAMPP startet nicht

Postby Visualev » 18. September 2009 16:04

Hallo,

ich habe nach bestem Wissen und Lesen versucht nach Anleitung zu installieren. Nun habe ich doch alles unter /opt/lampp untergebracht:

xxxxxxxxxx@localhost lampp]$ ls -l
insgesamt 156
drwx------. 2 root root 4096 11. Feb 2004 backup
drwxr-xr-x. 2 root root 12288 1. Aug 15:36 bin
drwxr-xr-x. 2 root root 4096 14. Jul 2004 cgi-bin
drwxr-xr-x. 3 root root 4096 13. Apr 18:38 error
drwxr-xr-x. 10 root root 4096 30. Jul 11:22 etc
drwxr-xr-x. 4 nobody root 4096 30. Jun 15:34 htdocs
drwxr-xr-x. 3 root root 4096 31. Mai 2003 icons
-rwxr-xr-x. 1 root root 15204 10. Apr 10:36 lampp
drwxr-xr-x. 14 root root 4096 1. Aug 15:36 lib
drwxr-xr-x. 2 root root 4096 26. Apr 2006 libexec
drwxr-xr-x. 37 root root 4096 14. Mär 2006 licenses
drwxr-xr-x. 2 root root 4096 31. Jul 14:50 logs
drwxr-xr-x. 2 root root 4096 1. Aug 15:36 modules
drwxr-xr-x. 10 root root 4096 7. Jul 23:18 phpmyadmin
drwxrwxrwx. 2 root root 4096 15. Jul 2007 phpsqliteadmin
-rw-rw-r--. 1 root root 60297 1. Aug 15:35 RELEASENOTES
drwxr-xr-x. 2 root root 4096 1. Aug 15:36 sbin
drwxr-xr-x. 15 root root 4096 31. Jul 14:50 share
drwxr-xr-x. 3 root root 4096 18. Jan 2005 tmp
drwxr-xr-x. 6 root root 4096 31. Jul 14:50 var
[xxxxxxxxxx@localhost lampp]$

Nur startet das Ganze nicht! Ich kann doch davon ausgehen, dass tar.gz nur entpackt und nichts installiert. Ich habe das Ganze heute nochmals heruntergeladen und MD5 passt. :roll:

Das alles soll unter Fedora 11 laufen und ich muss mich leider als Newcommer outen. :oops:

Danke schon jetzt!
Visualev
 
Posts: 8
Joined: 15. September 2009 15:45

Re: LAMPP startet nicht

Postby Wiedmann » 18. September 2009 16:05

Nur startet das Ganze nicht!

Warum nicht?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: LAMPP startet nicht

Postby Visualev » 18. September 2009 16:18

Kommando nicht gefunden.

Kann wohl nicht auf das Script zugreifen!?!
Visualev
 
Posts: 8
Joined: 15. September 2009 15:45

Re: LAMPP startet nicht

Postby Wiedmann » 18. September 2009 16:42

Kommando nicht gefunden.

Welches Kommando findet er nicht?
Und was hast du eingegeben?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: LAMPP startet nicht

Postby Visualev » 18. September 2009 17:03

lampp start, wie in der Beschreibung angegeben nach der Installation (ich bin in /opt/lampp/)!

Zum Starten von XAMPP einfach diesen Befehl eintippen:

/opt/lampp/lampp start

Auf dem Bildschirm sollten nun folgende Mitteilungen zu sehen sein:

Starte XAMPP für Linux 1.7.2...
XAMPP: Starte Apache mit SSL...
XAMPP: Starte MySQL...
XAMPP: Starte ProFTPD...
XAMPP gestartet.
Visualev
 
Posts: 8
Joined: 15. September 2009 15:45

Re: LAMPP startet nicht

Postby Visualev » 18. September 2009 17:26

Diese nutzlose Frage ist mir was wert (werde jedes mal 5€ spenden)! Ich war nicht mehr als root angemeldet und ein Hilferuf nach ROOT hätte gleich alles gelöst.

Sorry, aber auch die Anleitung mit tar xvfz xampp-linux-1.7.2.tar.gz -C /opt war nicht tauglich, ich habe das dann über den Paketmanager gelöst. Sicherlich kann auch was an meine Config leicht schief sein, da es sich um meine erste Installation von F11 handelt und ich so einiges auf meine Bedürfnisse schräg angepasst habe.

Danke
Visualev
 
Posts: 8
Joined: 15. September 2009 15:45

Re: LAMPP startet nicht

Postby Nobbie » 18. September 2009 20:49

Visualev wrote:lampp start, wie in der Beschreibung angegeben nach der Installation (ich bin in /opt/lampp/)!


Wenn Du Dir schon den Luxus leisten willst, Dich nicht an die Anleitung zu halten, mußt Du wenigstens mehr Linux Kenntnisse mitbringen. Dein Kommando ist unvollständig. Richtig wäre:

./lampp start

Und dann würdest Du auch die entsprechenden Meldungen sehen.

Visualev wrote:Sorry, aber auch die Anleitung mit tar xvfz xampp-linux-1.7.2.tar.gz -C /opt war nicht tauglich


Doch, auch die ist tauglich, läßt sich aber auch mit offensichtlich fast schon boshafter Ignoranz aushebeln. Die Anweisung muss als "root" ausgeführt werden und das Tar-Package muss im aktuellen Verzeichnis liegen. Aber in Anlehnung an den Fehler von oben gehe ich davon aus, dass Dir auch dort ein "Umgehungsfehler" eingefallen ist.
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: LAMPP startet nicht

Postby Visualev » 19. September 2009 21:25

http://www.apachefriends.org/de/xampp-linux.html

* Schritt 3: Starten

Zum Starten von XAMPP einfach diesen Befehl eintippen:

/opt/lampp/lampp start

Auf dem Bildschirm sollten nun folgende Mitteilungen zu sehen sein:

Starte XAMPP für Linux 1.7.2...
XAMPP: Starte Apache mit SSL...
XAMPP: Starte MySQL...
XAMPP: Starte ProFTPD...
XAMPP gestartet.


Sehe keinen Punkt in der Anleitung, wie ./lampp start!

Sicherlich liegt eine Fehler meiner Seite vor und mein Outing sagt ja alles (#=Root, hätte ich schon 1985 wissen sollen, im Praktikum bei SKF auf ner DEC). Ich hoffe nur in Zukunft auf weniger Kommentare postum mit rhetorischer Analyse des Thread(s).
Visualev
 
Posts: 8
Joined: 15. September 2009 15:45

Re: LAMPP startet nicht

Postby Nobbie » 19. September 2009 22:07

Visualev wrote:Sehe keinen Punkt in der Anleitung, wie ./lampp start!


Natürlich nicht. Hat ja auch keiner behauptet.

Aber wenn schon doof, dann saudoof: wo hast Du denn

lampp start

gelesen?
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: LAMPP startet nicht

Postby Visualev » 19. September 2009 23:15

Diese Art entspricht nicht meinem Niveau!

Ich hatte eine PN, darin wurde nur festgestellt: "Warum soll jemand versuchen in lampp einzusteigen, wenn der Neuling am Ende hier als doof bezeichnet wird! Ich bleibe da bei meinem SuSE Forum, hatte aber das gleiche Problem wie du"

EndOfFile
Visualev
 
Posts: 8
Joined: 15. September 2009 15:45

Re: LAMPP startet nicht

Postby Nobbie » 20. September 2009 18:54

Visualev wrote:Diese Art entspricht nicht meinem Niveau!


Das ist doch gar nicht schlimm. Gewöhn' Dich einfach an das etwas gehobene Niveau in diesem Forum.

Visualev wrote:Ich hatte eine PN, darin wurde nur festgestellt: "Warum soll jemand versuchen in lampp einzusteigen, wenn der Neuling am Ende hier als doof bezeichnet wird! Ich bleibe da bei meinem SuSE Forum, hatte aber das gleiche Problem wie du"


NIemand muss versuchen, in lampp einzusteigen. Das ist eine freiwillige Anforderung gegen sich selbst.

Aber wenn jemand eine Frage stellt, gleichzeitig die Dokumentation wie die Funktion in Frage stellt, dabei aber ganz offensichtlich die Dokumentation ignoriert, und darüber hinaus auch noch "schlaumichelig" absolut ernste Hilfen veralbert - der kann ja nicht viel mehr erwarten als ein Echo, welches seinem (ungeeignet überheblichen und dümmlichen) Niveau entspricht.

Dich zwingt überhaupt gar niemand, Xampp einzusetzen, geschweige denn, es hätte irgendjemand irgendeinen Vorteil davon.
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests