Newbie braucht Hilfe - bitte nicht lachen!

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Newbie braucht Hilfe - bitte nicht lachen!

Postby Rolfi » 21. December 2003 11:22

Hallo XAMPP-Freunde.
Ich bin asoluter Newbie und kenne mich bislang lediglich mit statischen Webseiten aus. Zum Ausprobieren dynamischer Webseiten mit PHP habe ich nun per Ethernet an meinen Windows 98 PC mein Notebook angeschlossen, auf dem Windows Me und Linux SuSE 8.1. professional installiert ist. In diesem SuSE habe ich den tollen LAMPP installiert :) - man kann ihn am Notebook aufrufen und alles funktioniert. In der hosts.sam im Widows 98 und in der /etc/hosts in SuSE habe ich entsprechend der FAQ die Einträge hinzugefügt und in der htdocs eine Test-html abgelegt. Ein beidseitig durchgeführtes ping verlief positiv. Der PC hat die IP 192.168.100.10, das Notebook die IP 192.168.100.11 und beide bekamen die Subnetmask 255.255.255.0 Wie kann ich nun mit dem Windows-PC die Test-HTML-Seite im SuSE-Notebook aufrufen? LAMPP ist gestartet. Egal, ob ich nun beim PC http://localhost oder http://linux.local (Der Name des Notebooks) oder http://192.168.100.11 in die Adresszeile des Browsers eingebe, es öffnet sich immer das DFÜ-Netzwerk und der PC möchte über meinen ISDN-Controller eine Telefonverbindung nach "draußen" herstellen :cry: . Ich möchte aber "drinnen" bleiben mit PC und Notebook. Meine Zonelab-Firewall habe ich zwar entsprechend konfiguriert aber vorsichtshalber hierzu ganz deaktiviert. Was ist das Entscheidende, das ich vergessen habe? Freue mich auf verständliche Antworten. :P
Vorweihnachtliche Grüße,
Rolf
Rolfi
 
Posts: 7
Joined: 21. December 2003 11:13
Location: Portugal

Fehler gefunden

Postby Rolfi » 21. December 2003 13:24

Hallo Leute,
ich Dussel hatte vergessen, die in die host-Dateien kopierten Zeilen anzupassen. :oops:
Ich habe also z.B. die Zeile

'interne-ip' www.'domain'' 'domain'

in

'interne-ip' www.'linux.local' 'linux.local'.

geändert. (Den Tipp mit den Zeilen hatte ich übrigens hier im Forum gefunden.) Entsprechend auch bei SuSE. Der Aufruf klappte dann mit http://192.168.100.11/. :D
Das heißt also, dass der Browser nur das DFÜ-Netzwerk anfordert, wenn er die Adresse im lokalen Netzwerk nicht findet, oder? :?

Beste Grüße, Rolf
Rolfi
 
Posts: 7
Joined: 21. December 2003 11:13
Location: Portugal


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests