update auf 1.7.2: zend framework und db/pdo machen probleme

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

update auf 1.7.2: zend framework und db/pdo machen probleme

Postby steki » 12. August 2009 10:28

Warning: PDO::__construct() [pdo.--construct]: [2002] Das Argument ist ungültig (trying to connect via unix://) in /opt/lampp/htdocs/lib/Zend/Db/Adapter/Pdo/Abstract.php on line 129

Aus irgendeinem Grund findet zend.db den sock der mysql Datenbank nicht mehr. Da sollte doch so was wie

unix:///opt/lampp/var/mysql/mysql.sock

stehen, oder? wie läßt sich das Problem beheben?

Achtung: Update auf zend framework 1.9.0 ist für php 5.3.0 nötig.

gruss
stefan
steki
 
Posts: 8
Joined: 11. November 2005 02:02
Operating System: debian linux

Re: update auf 1.7.2: zend framework und db/pdo machen probleme

Postby steki » 12. August 2009 13:50

ein

pdo_mysql.default_socket=/opt/lampp/var/mysql/mysql.sock

in der php.ini löst das Problem erst einmal

gruss
stefan
steki
 
Posts: 8
Joined: 11. November 2005 02:02
Operating System: debian linux


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests