Startprobleme

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Startprobleme

Postby pau|c » 09. December 2003 12:41

Folgendes Problem beim Starten von xampp für linux:

server:~# /opt/lampp/lampp start
Starting XAMPP for Linux 1.4...
LAMPP: Starting Apache with SSL...
LAMPP: Starting MySQL...
LAMPP: Starting ProFTPD...
XAMPP for Linux started.

das ist ja noch in Ordnung, aber wenn ich dann per Browser auf die Startseite zugreifen will bekomm ich nur eine Server nicht gefunden Seite im IE... Beim lokalen Zugriff via lynx hab ich das selbe Problem

Die Ausgabe von ps -A verrät mir das zwar mysql und proftpd laufen, ich kann jedoch nirgends einen apache prozess finden
Wie kann das sein? Beim Starten gabs ja keine Fehlermeldung...

btw, den Fehler hab ich (soweit ich mich erinnern kann) seit dem update von 1.3 auf 1.4
Ich hab jetzt alles gelöscht und 1.4 mal neu installiert jedoch -> selber Fehler :/

Hoffentlich kann mir jmd helfen ;)
User avatar
pau|c
 
Posts: 25
Joined: 17. April 2003 01:05
Location: Wels, Austria

Postby Oswald » 09. December 2003 13:11

Huhu pau|c!

Steht bisher irgendwas in der /opt/lampp/logs/error_log?

Was passiert wenn Du telnet localhost 80 aufrufst? Gibt's ne Fehlermeldung oder "hängt" der Befehl?

Im wenn er "hängt" einfach irgendwas eintippen und ein paar mal Return drücken (dann gibt's auch ne Fehlermeldung. Die aber ignorieren.)

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby pau|c » 09. December 2003 13:46

error_log:

server:/opt/lampp/logs# cat error_log
[Tue Dec 09 14:34:06 2003] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Dec 09 14:34:09 2003] [notice] Digest: generating secret for digest authentication ...
[Tue Dec 09 14:34:09 2003] [notice] Digest: done
[Tue Dec 09 14:34:10 2003] [crit] (22)Invalid argument: Unable to create scoreboard (anonymous shared memory failure)
[Tue Dec 09 14:37:29 2003] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Dec 09 14:37:32 2003] [notice] Digest: generating secret for digest authentication ...
[Tue Dec 09 14:37:32 2003] [notice] Digest: done
[Tue Dec 09 14:37:33 2003] [crit] (22)Invalid argument: Unable to create scoreboard (anonymous shared memory failure)
[Tue Dec 09 14:37:54 2003] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Dec 09 14:38:00 2003] [notice] Digest: generating secret for digest authentication ...
[Tue Dec 09 14:38:00 2003] [notice] Digest: done
[Tue Dec 09 14:38:01 2003] [crit] (22)Invalid argument: Unable to create scoreboard (anonymous shared memory failure)


Und beim telnet gibts sofort ne Fehlermeldung "Unable to connect to remote host"
User avatar
pau|c
 
Posts: 25
Joined: 17. April 2003 01:05
Location: Wels, Austria

Postby Oswald » 09. December 2003 13:48

Ahh.. siehe FAQ:
http://www.apachefriends.org/faq-lampp.html#score

In der 1.5er Version wird dann auch ein Automatismus drin sein, der das selbständig behebt.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby pau|c » 09. December 2003 13:56

Ok, hat funktioniert!

Vielen Dank für die schnelle Hilfe!

mfg pau|c
User avatar
pau|c
 
Posts: 25
Joined: 17. April 2003 01:05
Location: Wels, Austria


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests

cron