Webroot "verschieben"

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Webroot "verschieben"

Postby chzumbrunnen » 07. June 2009 16:54

Ich habe XAMPP erfolgreich unter Ubuntu 9.04 installiert und es läuft alles (fast) perfekt.

Beim Starten kommt eine Fehlermeldung "Broken Pipe" oder so was, aber das scheint nicht weiter zu stören.

Nun möchte ich aber gerne mein Webroot in meinem User Verzeichnis haben denn in opt/lampp/htdocs habe ich per default gar keine Schreibrechte und der Ordnung halber hätte ich gerne mein Webroot unter home/web oder so.

Kann ich das irgendwie hinkriegen.

Am liebsten würde ich es so lösen dass opt/lampp/htdocs normal das webroot ist, aber darunter ein Verzeichnis "customwebs" (oder was auch immer), welches auf ein Verzeichnis in meinem home Verzeichnis verweist.

Vielleicht geht das mit Symlinks? Ich habe den Begriff schon gehört, aber kann im Moment noch nicht so viel damit anfangen.

Welche Best Practice Ansätze verwendet ihr?
chzumbrunnen
 
Posts: 7
Joined: 16. December 2008 05:38
Location: Brugg AG, Switzerland
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Webroot "verschieben"

Postby Nobbie » 08. June 2009 05:18

chzumbrunnen wrote:Welche Best Practice Ansätze verwendet ihr?


Linux lernen.
Nobbie
 
Posts: 6583
Joined: 09. March 2008 13:04

Re: Webroot "verschieben"

Postby chzumbrunnen » 05. May 2010 21:21

Auch wenn ich immer noch kein Linux Guru bin.

Lösen kann man diese Anforderung durch Eintragen eines Alias in der /opt/lampp/etc/httpd.conf


Code: Select all
Alias /web /home/[username]/web
<Directory /home/[username]/web>
Order allow,deny
Allow from all
</Directory>
chzumbrunnen
 
Posts: 7
Joined: 16. December 2008 05:38
Location: Brugg AG, Switzerland
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Webroot "verschieben"

Postby chzumbrunnen » 23. October 2010 22:54

Ich bin momentan gerade wieder unter Windows (beruflich eben) aber die Lösung bleibt sich grundsätzlich gleich, ausser dass die Pfade anders sind und die Backslashes Slahes sind:

Gleich unter der Anweisung für den Document Root kommt in der D:\xampp\apache\conf\httpd.conf der Alias hin:


DocumentRoot "D:/xampp/htdocs"

Alias /web "D:/web"
<Directory "D:/web">
Options All Indexes FollowSymLinks MultiViews
Order allow,deny
Allow from all
</Directory>

Bei mir ist beginnt das auf der Zeile 188 der httpd.conf

Beachte, dass ich Anführungszeichen verwende.

Kann sein, dass dies nötig ist....

Unter Linux muss [username] natürlich durch den Benutzernamen ersetzt werden, wenn das Webroot im Benutzerverzeichnis ist.

Hoffe, das hilft.
chzumbrunnen
 
Posts: 7
Joined: 16. December 2008 05:38
Location: Brugg AG, Switzerland
XAMPP Version: 5.6.3
Operating System: Windows 7


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests