LoadModule Fehler

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

LoadModule Fehler

Postby noxx000 » 27. May 2009 07:34

Hi,
wenn es eher in das Apache-Subforum passt bitte verschieben.

Also, das Problem ist, dass ich svn installieren wollte mit Zugriff über xampp/apache.
Beim Laden der Modulzeilen:
Code: Select all
LoadModule dav_svn_module modules/mod_dav_svn.so
LoadModule authz_svn_module modules/mod_authz_svn.so

wirft er mir folgenden Fehler aus:
httpd: Syntax error on line 123 of /opt/lampp/etc/httpd.conf: Cannot load /opt/lampp/modules/mod_dav_svn.so into server: /opt/lampp/modules/mod_dav_svn.so: cannot open shared object file: No such file or directory

Nun, der Fehler wäre halb so schlimm, wenn es nicht total verwirrend wäre.
Die Datei existiert genau da, wo er sucht (also in modules/). Ich habe zusätzlich vorsichtshalber auch mal testweise +rwx für alle gegeben gehabt, jedoch auch keine Veränderung.
Der gleiche Fehler kommt auch beim zweiten Modul, wenn man die Reihenfolge verdreht.
Alle anderen Module im Verzeichnis kann er ja ohne Probleme laden...

Nun, nach mehreren FAQs, Foren und Blogs habe ich leider immer noch keine Lösung und würde mich freuen, wenn ihr mir da helfen könntet, woran es noch liegen könnte... so schwer kann es doch nicht sein da zwei Module nachzuladen o.O

Mein System: xampp 1.7.1 unter linux/debian

Grüße
noxx000
 
Posts: 5
Joined: 03. November 2008 15:37

Re: LoadModule Fehler

Postby Wiedmann » 27. May 2009 08:07

so schwer kann es doch nicht sein da zwei Module nachzuladen

Wo kommen die 2 Module her?
--> sind ja nicht Teil vom XAMPP.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: LoadModule Fehler

Postby noxx000 » 27. May 2009 17:52

ich habe diese Anleitung benutzt:
http://www.debian-resources.org/node/130

andere Seiten gehen genauso vor, jedoch scheint niemals solch ein Problem aufgetreten zu sein.

Anmerkung: ich habe es auch über den anderen Weg probiert, es automatisch über Webmin (Zusatzmodul svn 4.0 + aktiviert für virtual-server) zu installieren.
Dabei kommt dann folgender Fehler:
Code: Select all
Syntax error on line 25 of /opt/lampp/vhosts/xxxxxx.conf:
Unknown DAV provider: svn

Zurückgeführt ist es dann wieder das gleiche Problem, dass er die Module nicht laden konnte.
noxx000
 
Posts: 5
Joined: 03. November 2008 15:37

Re: LoadModule Fehler

Postby Wiedmann » 27. May 2009 18:04

ich habe diese Anleitung benutzt:

Die kann wohl nur eher mit Zufall tun...

andere Seiten gehen genauso vor,

Was dann auch für diese Seiten zutrifft.
--> Ein Apache Modul über "apt" zu installieren (und in den XAMPP zu kopieren) funktioniert nur dann richtig (und zuverlässig), wenn auch der Apache so installiert wurde (bze. eben der Apache vom System benutzt wird).

Ansonsten geht das wohl wie mit jedem Apache-Modul:
- Man installiert das XAMPP Devel-Package
- und dann kompiliert man das Modul. Da gibt man dann an, das der Apache, bzw. apxs, in /opt/lampp/ zu finden ist. Wie das beim jeweiligen Modul genau zu handhaben ist, sollte in der readme des Modules stehen.

Bei subversion muss man sich dann wohl noch entscheiden, ob man subversion selbst im System, oder auch innerhalb von /opt/lampp/ installieren will (PREFFIX anpassen).

(Sollte du jemanden kennen, der diese Module schon für den XAMPP kompiliert hat, kann man diese dann auch einfach ins Modul Verzeichnis kopieren.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: LoadModule Fehler

Postby noxx000 » 27. May 2009 18:23

ok, vielen dank für die fixe antwort, dann werd ich das mal sorum ausprobieren.
noxx000
 
Posts: 5
Joined: 03. November 2008 15:37


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests