Modul mod_proxy

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Modul mod_proxy

Postby albrecht » 04. December 2003 08:27

Hallo,
nach erfolgreicher Installation und Inbetriebnahme von XAMPP für Linux habe ich die RewriteEngine (Modul mod_proxy) konfiguriert. Für die unverschlüsselten http Protokolle funktioniert das auch wunderbar.

Es ist mir jedoch nicht gelungen, https damit umzuleiten. Es erscheint dann eine Fehlermeldung in der Art:

-----------------------------------------
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, you@your.address and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Apache/2.0.48 (Unix) mod_perl/1.99_08 Perl/v5.8.0 mod_ssl/2.0.48 OpenSSL/0.9.7c PHP/4.3.3 DAV/2 Server at linvdr.barthel.net Port 443
-----------------------------------------

In der Datei /opt/lampp/logs/error_log ist dann Folgendes zu finden:

-----------------------------------------
[Thu Dec 04 08:18:04 2003] [error] SSL Proxy requested for localhost:443 but not enabled [Hint: SSLProxyEngine]
[Thu Dec 04 08:18:04 2003] [error] proxy: failed to enable ssl support for 192.168.10.1:10000 (csab.barthel.net)
-----------------------------------------

Offenbar gibts für https ein eigenes proxy Modul? Wenn Ja, wie nehme ich es in Betrieb?

BTW: Ein großes Kompliment an die Entwickler! Ich habe selten derart "pflegeleichte" Software gesehen.

Gruß
Albrecht
albrecht
 
Posts: 5
Joined: 04. December 2003 08:09

Postby Oswald » 04. December 2003 10:02

Huhu Albrecht!

Es tut mir leid, aber die Antwort ist wirklich sehr einfach. Du hast es sogar selbst oben zitiert:

SSL Proxy requested for localhost:443 but not enabled [Hint: SSLProxyEngine]

SSLProxyEngine ist die Lösung Deines Problems. Mehr dazu findest Du unter http://httpd.apache.org/docs-2.0/mod/mo ... roxyengine

Eigentlich muss Du diese Direktive nur "einschalten".

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby albrecht » 04. December 2003 10:22

Vielen Dank für die schnelle Hilfe. Es klappt jetzt auch mit https.

Gruß
Albrecht
albrecht
 
Posts: 5
Joined: 04. December 2003 08:09


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests