Lampp startet nicht auf Debian Linux, Feher 127 bei Apache

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Lampp startet nicht auf Debian Linux, Feher 127 bei Apache

Postby wolfaus » 01. May 2009 20:39

Hallo,

ich bin ein ziemlicher Newbie was Lampp unter Linux betrifft. Auch bei Debian linux bin ich Newbie, bin aber trotzdem aus Kompatibilitätsgründen gezwungen auf einem Debian Linux System (aktuelle Version) Lampp (Version 1.6.6) zu installieren.

Beim Starten von Lampp bekomme ich folgende Meldungen:

SB0509:/# /opt/lampp/lampp start
Starte XAMPP fuer Linux 1.6.6...
/opt/lampp/share/lampp/phpstatus: line 4: /opt/lampp/bin/php: Datei oder Verzeichnis nicht gefunden
XAMPP: Starte Apache mit SSL ...
XAMPP: Fehler 127 beim Starten vom Apache!
XAMPP: Starte Diagnose...
XAMPP: Sorry, ich weiss nicht was da schief laeuft.
XAMPP: Bitte wende Dich ans Forum http://community.apachefriends.org/f/
XAMPP: Starte MySQL...
XAMPP: XAMPP-ProFTPD laeuft bereits.
XAMPP fuer Linux gestartet.

Im apachestart.log finde ich folgende Fehlermeldung:

/opt/lampp/bin/httpd: error while loading shared libraries: libldap-2.3.so.0: cannot open shared object file: No such file or directory

Mir ist klar, dass hier etwas nicht installiert ist, und er daher eine lib nicht findet. Mein Problem ist nun, dass ich trotz googeln nicht finde woher ich das nötige Package nehmen soll und wie dieses zu installieren ist.

apt-get install slapd ldap-utils
habe ich schon versucht, das behebt mein Problem nicht.

Mir ist auch klar, dass das wahrscheinlich eine Kleinigkeit ist, über die ein Linux-Fachmann lächelt aber so einer bin ich leider nicht und habe daher entsprechende Probleme damit. In der Hoffnung dass mir da einer Helfen kann, wende ich mich daher mit der Bitte um Hilfe an Euch.

Wolfaus
wolfaus
 
Posts: 1
Joined: 01. May 2009 20:09

Re: Lampp startet nicht auf Debian Linux, Feher 127 bei Apache

Postby Hansi » 02. May 2009 23:30

Bitte gib einmal

Code: Select all
uname -a

in deiner ssh konsole ein und poste die Ausgabe. danke
Hansi
 
Posts: 3
Joined: 02. May 2009 11:58

Re: Lampp startet nicht auf Debian Linux, Feher 127 bei Apache

Postby webstone » 29. March 2010 17:12

hey,

hatte eben das selbe Problem :)

Bei mir war die Lösung dank Google innerhalb von ein paar Minuten gelöst :)

Umgebung:
Host: MacBook mit 2 GHz Intel Core 2 Duo mit Virtual Box
Gast: Linux ubuntu 2.6.31-14-server #48-Ubuntu SMP Fri Oct 16 15:07:34 UTC 2009 x86_64 GNU/Linux (lt. uname -a)

Dank Google --> "xampp 64 Bit" kam ich auf folgenden Post: http://www.mizine.de/linux/xampp-164-ubuntu-64-bit/

Dann einfach folgenden Befehl ausgeführt:

Code: Select all
sudo aptitude install ia32-libs


und die Abfragen mit "y" bestätigt...


danach nur noch

Code: Select all
/opt/lampp/lampp start


ausgeführt .. und TADA! es geht :)

vielleicht hilfts ja :)


Gruss
Marcus
webstone
 
Posts: 1
Joined: 29. March 2010 17:07


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest