Lampp mysql.so fehler datenbankfunktionen laufen nicht

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Lampp mysql.so fehler datenbankfunktionen laufen nicht

Postby relic » 07. February 2009 17:46

Hi all,
habe Lampp ganz normal unter Ubunut installiert wie es auf der Startseite ist. MYSQL wurde in PHP mit eingebunden, das zeigt auch die PHP info an. Jedoch kann ich keine Mysql funktionen benutzen. Dann kommt immer die Fehlermeldung: Called to undefined function mysql_query(); ..... usw.

Habe in der PHP.ini mysql.so als extension angegeben jedoch passiert dann auch gar nix.

Wenn ich lampp starte bekomme ich diese Meldung:

Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20060613/mysql.so' - /opt/lampp/lib/php/extensions/no-debug-non-zts-20060613/mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0

mysql.so liegt nicht in diesem Verzeichnis aber die ganzen anderen Bibiotheken. Habe versucht die mysql.so dort reinzukopieren jedoch ohne erfolg und nun weis ich nicht mehr wo der fehler ist bzw wo ich suchen kann. Wäre für hilfe Dankbar grüße
relic
 
Posts: 3
Joined: 07. February 2009 17:42

Re: Lampp mysql.so fehler datenbankfunktionen laufen nicht

Postby Wiedmann » 07. February 2009 18:13

MYSQL wurde in PHP mit eingebunden, das zeigt auch die PHP info an.

Was genau zeigt phpinfo() an? (es gibt ja drei verschiedene Extensions für MySQL)

Habe in der PHP.ini mysql.so als extension angegeben ... Wenn ich lampp starte bekomme ich diese Meldung:

Die kommt aber erst, seit du in der "php.ini" rumgespielt hast?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Lampp mysql.so fehler datenbankfunktionen laufen nicht

Postby relic » 07. February 2009 18:18

also die phpinfo zeigt dies an:

MySQL Support enabled
Active Persistent Links 0
Active Links 0
Client API version 5.1.30
MYSQL_MODULE_TYPE external
MYSQL_SOCKET /opt/lampp/var/mysql/mysql.sock
MYSQL_INCLUDE -I/opt/lampp/include/mysql
MYSQL_LIBS -L/opt/lampp/lib/mysql -lmysqlclient

Directive Local Value Master Value
mysql.allow_persistent On On
mysql.connect_timeout 60 60
mysql.default_host no value no value
mysql.default_password no value no value
mysql.default_port no value no value
mysql.default_socket no value no value
mysql.default_user no value no value
mysql.max_links Unlimited Unlimited
mysql.max_persistent Unlimited Unlimited
mysql.trace_mode Off Off


ich habe seit ich lampp installiert habe keine verbindung zur Datenbank via PHP also gleich nach dem installieren bekomm ich nur beim aufruf von mysql_connect() den fehler mit called undefined function....

habe natürlich gegoogled was das zu bedeuten hat und in einigen foren wurde eben gesagt das man in der php.ini bei "extension=mysql.so" angegben soll was ich dann auch gemacht habe.
außerdem habe ich noch den extension_dir=... welcher auskommentiert war, die kommentare weggemacht und naja...hat nix gebracht ;(

edit:

; Directory in which the loadable extensions (modules) reside.
extension_dir = /opt/lampp/lib/php/extensions/no-debug-non-zts-20060613/
extension=mysql.so

so sieht das aus in der php.ini
relic
 
Posts: 3
Joined: 07. February 2009 17:42

Re: Lampp mysql.so fehler datenbankfunktionen laufen nicht

Postby Wiedmann » 07. February 2009 18:34

so sieht das aus in der php.ini

Mach erstmal alle deine Änderungen in der "php.ini" wieder rückgängig.

ich habe seit ich lampp installiert habe keine verbindung zur Datenbank

Direkt nach der Installation haben also die Demos wo beim XAMPP dabei sind (CD-Demo), bzw. der phpMyAdmin, nicht funktioniert?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Lampp mysql.so fehler datenbankfunktionen laufen nicht

Postby relic » 07. February 2009 18:56

so also habe lampp deinstalliert und nochmals neu installiert, daher die php.ini ist wie neu nun.
phpmyadmin läuft, die demos auch aber das ging vorhin auch schon, datenbanken anlegen konnte ich, löschen auch usw alles per phpmyadmin halt.

Also ich verstehe das nicht, die demos laufen phpmyadmin läuft, man kann tabellen anlegen usw, aber sobald ich mit php einen zugriff zur Datenbank starte kommt der error wieder ;( hat sich also nix geändert.
relic
 
Posts: 3
Joined: 07. February 2009 17:42

Re: Lampp mysql.so fehler datenbankfunktionen laufen nicht

Postby Wiedmann » 07. February 2009 22:59

aber sobald ich mit php einen zugriff zur Datenbank starte kommt der error wieder ;( hat sich also nix geändert.

Also phpMyAdmin, bzw die Demos im XAMPP, sind ja auch nur simple PHP Scripte.

Dann fragen wir mal andersherum:
Wie benutzt du PHP denn bei diesem Zugriff? Eine Datei in htdocs die du mit dem Browser aufrufst?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests