[erledigt]Ubuntu-Lampp-cronjob-error

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

[erledigt]Ubuntu-Lampp-cronjob-error

Postby flasherle » 04. February 2009 12:59

Hi leibe Community,

ich hoffe ihr könnt mir helfen. Da ich nicht besonders viel erfahrung mit linux hab und ich aber es unbedingt darunter machen möchte, gibt es natürlich noch einige problemchen für mich.
Übern Browser alles kein Thema.

So jetzt hab ich ein php script, welches auf eine mysql datenbank zugreifen soll, und dies soll via cronjob funktionieren...
also hab ich mir in mein ubuntu dieses sheduled tasks runtergalden.
dies funktioniert auch alles ganz gut.

Dennoch bekomme ich bei meinem script einen fehler.
aufgerufen wird es folgendermaßen (auch im terminal unter su versucht gleicher fehler):
php /opt/lampp/htdocs/cron/cronjob.php -c /opt/lampp/htdocs/etc/php.ini

(-c damit er die php.ini vom lampp nimmt und nicht die phpcli aus root/etc/php5)

jedoch bekomme ich immer folgenden Fehler, der iegentlich ja nicht sein kann, da der zugriff auf mysql übern browserzugriff ja funktioniert:

Fatal error: Call to undefined function mysql_connect() in /opt/lampp/htdocs/cron/cronjob.php


Ich hoffe Ihr könnt mir wertvolle tipps geben und mir damit helfen.
Danke schon einmal im Vorraus.

Gruß
flasherle
Last edited by flasherle on 04. February 2009 14:01, edited 1 time in total.
flasherle
 
Posts: 3
Joined: 04. February 2009 12:47

Re: Ubuntu-Lampp-cronjob-error

Postby Wiedmann » 04. February 2009 13:11

php /opt/lampp/htdocs/cron/cronjob.php -c /opt/lampp/htdocs/etc/php.ini

(-c damit er die php.ini vom lampp nimmt und nicht die phpcli aus root/etc/php5)

Ich denke dann solltest du auch das PHP vom XAMPP nehmen, und nicht nur die INI. Der -c Parameter sollte IMHO auch vor dem auszuführendem Script aufgeführt sein.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Ubuntu-Lampp-cronjob-error

Postby flasherle » 04. February 2009 14:00

danke dir! so tut es, da hab ich wohl den wald vor lauter bäumen nicht geshen.
Viel Dank für den tipp.
flasherle
 
Posts: 3
Joined: 04. February 2009 12:47


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests