Ubunto 8.10 + Xampp massive Probleme

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Ubunto 8.10 + Xampp massive Probleme

Postby gonso68 » 09. January 2009 10:43

Hallo,

ich habe irgendwie massive Probleme mit diesem Programm (Xampp).

es war bei mir ähnlich wie hier: viewtopic.php?f=3&t=32121
+ hier: viewtopic.php?f=3&t=32735

Nichts ging, alles geschützt... man durfte jedes einzelne Verzeichnis mit chmod bearbeiten.
Irgendwann die Schnau***e voll gehabt und wollte wieder auf den klassischen Apache. Dieser lief vorher für meine bescheidene Zwecke recht passabel.
Nichts ging, also alles einzeln gelöscht.

Tja was soll man sagen Apache2 draufgespielt und der Webbrowser springt naturlich gleich auf: XXX.com/xampp
anstatt auf xxx.com zu bleiben.
Versucht diesen Xampp wieder aufzuspielen und na und
fehlanzeige, mit solcher Fehlermeldung bricht schon das "entpacken" ab:
xampp kann nicht ausgeführt werden: No such file or directory
tar: Nicht behebbarer Fehler: Programmabbruch .
tar: Child returned status 2
tar: Fehler beim Beenden, verursacht durch vorhergehenden Fehler

Spitze, bin bedient. Weiß jemand wie ich das Ding zu 100% von der Platte und aus dem System bekomme?
Danke
gonso68
 
Posts: 2
Joined: 09. January 2009 10:33

Re: Ubunto 8.10 + Xampp massive Probleme

Postby Nobbie » 09. January 2009 10:55

gonso68 wrote:Nichts ging, alles geschützt... man durfte jedes einzelne Verzeichnis mit chmod bearbeiten.


Code: Select all
chmod -R 0777 /opt/lampp


hätte alles in einem einzigen Rutsch geändert.

gonso68 wrote:Nichts ging, also alles einzeln gelöscht.


Code: Select all
rm -rf /opt/lampp


hätte alles in einem einzigen Rutsch gelöscht.

gonso68 wrote:Tja was soll man sagen Apache2 draufgespielt und der Webbrowser springt naturlich gleich auf: XXX.com/xampp
anstatt auf xxx.com zu bleiben.


Weil Du vergessen hast, den Browsercache zu leeren. Hat weder mit Apache noch mit Xampp etwas zu tun.

gonso68 wrote:Versucht diesen Xampp wieder aufzuspielen und na und
fehlanzeige, mit solcher Fehlermeldung bricht schon das "entpacken" ab:
xampp kann nicht ausgeführt werden: No such file or directory
tar: Nicht behebbarer Fehler: Programmabbruch .
tar: Child returned status 2
tar: Fehler beim Beenden, verursacht durch vorhergehenden Fehler


Vielleicht beim Löschen etwas stehen lassen, oder zuviel gelöscht (/opt ist noch da?), oder vergessen als "sudo" das Kommando auszuführen?

gonso68 wrote:Spitze, bin bedient. Weiß jemand wie ich das Ding zu 100% von der Platte und aus dem System bekomme?


Beispielsweise wie oben "rm -rf /opt/lampp" bzw. genau genommen als sudo:

Code: Select all
# sudo rm -rf /opt/lampp


Und den Browsercache leeren.

Und dringend ein Linuxbuch kaufen, wo die wichtigsten Grundbegriffe erläutert werden.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Ubunto 8.10 + Xampp massive Probleme

Postby gonso68 » 09. January 2009 11:12

Nobbie wrote:
gonso68 wrote:Nichts ging, alles geschützt... man durfte jedes einzelne Verzeichnis mit chmod bearbeiten.


Code: Select all
chmod -R 0777 /opt/lampp


hätte alles in einem einzigen Rutsch geändert.


ja, die Chance ist hoch

Code: Select all
rm -rf /opt/lampp

hätte alles in einem einzigen Rutsch gelöscht.


Nein das will Ubunto absolut nicht:
please use single chracter options

gonso68 wrote:Versucht diesen Xampp wieder aufzuspielen und na und
fehlanzeige, mit solcher Fehlermeldung bricht schon das "entpacken" ab:
xampp kann nicht ausgeführt werden: No such file or directory
tar: Nicht behebbarer Fehler: Programmabbruch .
tar: Child returned status 2
tar: Fehler beim Beenden, verursacht durch vorhergehenden Fehler

Nobbie wrote:Vielleicht beim Löschen etwas stehen lassen, oder zuviel gelöscht (/opt ist noch da?), oder vergessen als "sudo" das Kommando auszuführen?
opt ist noch, sonst nichts.
Und opt lässt sich auch nicht löschen.
Sudo.... ich belege bald eine F-Taste damit.
Warum geht es dann trotzdem nicht?
gonso68
 
Posts: 2
Joined: 09. January 2009 10:33

Re: Ubunto 8.10 + Xampp massive Probleme

Postby Nobbie » 09. January 2009 12:02

Nein das will Ubunto absolut nicht:
please use single chracter options


Die Meldung kenne ich nicht, vielleicht haben die den Optionsparser geändert. Dann gib die Optionen einzeln an:

rm -r -f /opt/lampp

Oder gibt "man rm" und lerne mal ein wenig Linux.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests