file_get_contents(lang.tmp): failed to open stream

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

file_get_contents(lang.tmp): failed to open stream

Postby sisko » 16. November 2003 20:15

Nach der Installation von XAMPP 1.4 unter SUSE 9.0 und dem erfolgreichen Start von XAMPP kriege ich beim Zugriff auf http://localhost folgenden Fehler:

Warning: file_get_contents(lang.tmp): failed to open stream: Permission denied in /opt/lampp/htdocs/xampp/index.php on line 2

Warning: Cannot modify header information - headers already sent by (output started at /opt/lampp/htdocs/xampp/index.php:2) in /opt/lampp/htdocs/xampp/index.php on line 4

Was hat es damit auf sich und wie kann ich es abstellen?
sisko
 
Posts: 5
Joined: 16. November 2003 20:10

Postby Oswald » 17. November 2003 09:58

Hallo sisko!

Hast Du XAMPP frisch installiert oder geupdatet?

Ruf mal bitte ls -l /opt/lampp/htdocs/xampp/lang.tmp auf. Was gibt er auf?

Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby sisko » 17. November 2003 22:44

Hallo Kai,

ich habe neu installiert.

Der Fehler lag wohl daran, dass der httpd-Prozess als User nobody lief (wohl SUSE-Default...) und deshalb keinen Zugriff auf lang.tmp hatte, weil die Installation als root ausgeführt wurde (ergo alle Files root gehörten).

Ein chown -R nobody /opt/lampp hat das Problem gelöst...
sisko
 
Posts: 5
Joined: 16. November 2003 20:10

Postby Oswald » 18. November 2003 09:22

Huhu sisko!

Ihhh... nein, das ist eigentlich nicht gut. Die Datei lang.tmp sollte nach einer normalen Installation nobody gehören und nicht root. Hast Du die Installation genau so gemacht wie in der Anleitung beschrieben? Wenn ja und die Datei lang.tmp gehört wirklich root, dann ist da irgendwo ein Fehler.

Lieben Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby sisko » 18. November 2003 12:53

Hm, merkwürdig.

Ich habe es ein zweites Mal unter SUSE 8.2 versucht, da gab es keine Probleme...

Ich werd es die Tage nochmal unter SUSE 9.0 testen und das Ergebnis hier posten.

BTW: Ist es nicht "ungeschickt", dass alle Files root gehören und wäre es nicht "sinnvoller", wenn man einen eigenen User dafür nutzen würde...?
sisko
 
Posts: 5
Joined: 16. November 2003 20:10

Postby Kristian Marcroft » 18. November 2003 13:01

Hi,

da hast du was falsch verstanden...
Die datein SOLLEN nobody gehören und NICHT root.
Gehören sie root ist irgendwas nicht in Ordnung.
Man muss XAMPP nur mit root starten, da es Ports unter 1024 verwendet (20/21,80).
Anschliessend wird sogar der Apache mit einem "Userswitch" auf nobody gestartet.
Von diesen 2 Usern kann man ausgehen, das sie auf (fast) allen Systemen vorhanden sind. würde man erst einen User anlgen müssen und dann ein chown und chmod machen wäre das eine weitere Fehlerquelle.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby sisko » 18. November 2003 13:15

Hallo KriS,

das ist mir klar, nur ändert ein tar xvzf keine File-Owner, und die Dateien im Tar.gz-Archiv gehören alle root, ergo werden Sie auch mit root als Owner entpackt (bis auf wenige Ausnahmen, z.B. lang.tmp).
sisko
 
Posts: 5
Joined: 16. November 2003 20:10

Postby Kristian Marcroft » 18. November 2003 13:32

Hi,

doch dein tar xvzf ändert berechtigungen...
ein tar xpvzf ändert sie nicht....
aber du sollst es ja so nicht entpacken...
Auf der HP steht:
tar xvfz xampp-linux-1.4.tar.gz -C /opt

Ansonsten sollte eigentlich alles was unter htdocs ist, z.B. nobody gehören..

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Oswald » 18. November 2003 13:40

Tar-Dateien enthalten Benutzerinformationen. Und diese werden auch beim Auspacken des Archivs berücksichtigt:

Im XAMPP-Tar steht z.B. folgendes drin:

-rw------- nobody/root 0 2003-11-03 10:11:02 lampp/htdocs/xampp/lang.tmp

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Kristian Marcroft » 18. November 2003 13:43

Hi,

wozu gibt es dann die p (= Permission) option beim tar?

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests