./lampp wizard?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

./lampp wizard?

Postby Shoukri » 16. November 2003 15:19

Hoi

da ich gerade die files ansehe ist zumindest im Xampp 1.4 eine Startoption ./lampp wizard enthalten. Für was genau dient dieser "Zauberer"? oder ist das nur für Demozwecke? Wenn ja, warum lädt der dann bei euch wizard.apachefriends.org/index.sig herunter?
User avatar
Shoukri
 
Posts: 76
Joined: 29. October 2003 00:25

Postby Kristian Marcroft » 16. November 2003 20:20

Hi,

das ist dafür gedacht um die "security" option von XAMPP wieder aufzuheben....
Wenn du z.B. dein mySQL Passwort vergessen hast etc. pp...

Es ist noch nicht offiziel Dokumentiert, da es so nicht ganz an die öffentlichkeit kommen soll?
Wie gesagt, es ist für den Fall des Falles :)

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Oswald » 17. November 2003 18:10

Hallo Shoukri!

Der "Wizard" ist eine kleine Funktionalität, die es quasi mir ermöglicht bei Bedarf neuen Programmcode in eine XAMPP-Installation zu kriegen. Der Wizard holt sich von wizard.apachefriends.org ein PHP-Skript und führt es dann auf dem aufrufenden Rechner aus. Die index.sig die Du angesprochen hast ist eine Signatur des heruntergeladenen Skripts. So stellt der Wizard sicher, dass auch nur wirklich authentifizierter Code ausgeführt wird. Es soll ja kein Hacker seinen Code da einschleusen.

Ein Beispiel dieser Anwendung hat KriS schon gebracht. Ein Benutzer hier im Forum hatte mal das Problem, dass er sein MySQL-Root-Passwort vergessen hat. Nun ist es relativ umständlich zu Beschreiben (und auch selbst zu machen) dieses Passwort wieder zurückzusetzten. Und da hab ich dann den Wizard eingeschaltet. Mit dem "Zauberwort" "bluesky" konnte der Benutzer dann automatisiert sein Passwort zurücksetzten. Kannst es mal ausprobieren. Es ist noch eine Sicherheitsabfrage eingebaut. ;)

Ansonsten gab's bisher keine Verwendung für den Wizard.

Liebe Grüße
Oswald

PS: Übrigens: Du warst der erste der ihn bemerkt hat. Na ja. Bemerkt und dann hier auch nachgefragt! ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby miglo » 03. February 2004 12:55

HI das selbe problem habe ich auch :-(
Ich habe xampp-win32-1.2 drauf und es läuft einwandfrei
Nun wenn ich z.b. Mysql manager laufen hab und eine datenbank aufrufen will bekomme ich folgende meldung "Keine Zugriffsberechtigung für root@localhost (verwendetes passwort : Ja )

Nun möchte ich auch das PW zurücksetzen für eine Hilfe bin ich sehr dankbar :oops:
miglo
 
Posts: 1
Joined: 03. February 2004 12:50

Postby Oswald » 03. February 2004 12:58

Huhu Miglo!

Du bist hier im Linux-Forum gelandet. Hier wird Dir wahrscheinlich keiner helfen können.

Versuch es doch noch mal im XAMPP für Windows-Forum.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby spikis » 14. January 2005 20:39

Hallo,

ich habe über den wizard das mysql passwort zurückgesetzt. Auf was für ein Passwort wird denn zurückgesetzt?
Weil wenn ich mich mit phpmyadmin als root mit leerem passwort anmelden will kommt:
#1045 - Access denied for user 'pma'@'localhost' (using password: YES)


Gruß
spikis
spikis
 
Posts: 3
Joined: 14. January 2005 20:33

Postby Oswald » 14. January 2005 21:10

Hallo spikis!

Es wird das root- und das pma-Passwort zurückgesetzt. In Deinem Fall steht aber noch in der config.inc.php von phpMyAdmin ein Passwort für den Benutzer pma. Das musst Du noch löschen.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby spikis » 14. January 2005 21:20

ich habe jetzt in der config.inc.php folgende Zeile:
$cfg['Servers'][$i]['controluser'] = 'pma';
in
$cfg['Servers'][$i]['controluser'] = '';

geaendert. Ist das so richtig. Weil sonstige eintraege mit pma oder einem passwort fuer pma finde ich nicht.

Wenn ich mich jetzt anmelden will, bekommen ich volgende meldung:
#1045 - Access denied for user 'root'@'localhost' (using password: NO)
spikis
 
Posts: 3
Joined: 14. January 2005 20:33

Postby Oswald » 14. January 2005 21:24

Hallo spikis!

Ups.. sorry, ich hätte mich genauer ausdrücken sollen. Du hast jetzt genau in der flaschen Zeile gelöscht. Schreib dort bitte wieder pma rein und guck Dir die Zeile darunter an. Dort steht das Passwort, dass Du löschen musst.

Liebe Grüße und viel Erfolg
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby spikis » 14. January 2005 21:40

so jetzt funktioniert wieder alles.

Danke fuer die schnelle Hilfe!
spikis
 
Posts: 3
Joined: 14. January 2005 20:33


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests