Update von 1.6.8a auf 1.7 fehlgeschlagen

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Update von 1.6.8a auf 1.7 fehlgeschlagen

Postby tobi194 » 05. January 2009 10:57

Hallo,

nach dem Update von 1.6.7 auf 1.6.8a was wunderbar funktioniert hat bekam ich beim Update von 1.6.8a auf 1.7 auf SUSE 8.1 folgende Meldung:

Stopping XAMPP for Linux 1.6.8a...
XAMPP: XAMPP-Apache is not running.
XAMPP: XAMPP-MySQL is not running.
XAMPP: XAMPP-ProFTPD is not running.
XAMPP stopped.

Upgrading 1.6.8a to 1.7...
Installing new files...
Upgrading existing files...
patching file `lampp/etc/my.cnf'
Hunk #1 succeeded at 51 with fuzz 2 (offset 15 lines).
Hunk #2 succeeded at 157 (offset 31 lines).
patching file `lampp/phpmyadmin/config.inc.php'
Hunk #1 succeeded at 21 with fuzz 1 (offset 2 lines).

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Please call '/opt/lampp/bin/mysql_upgrade -p' to update MySQL databases to the new MySQL version.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


Successfully upgraded XAMPP.

Starting XAMPP for Linux 1.7...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP: /opt/lampp/sbin/proftpd: /lib/libc.so.6: version `GLIBC_2.3.4' not found (required by /opt/lampp/sbin/proftpd)
XAMPP: Error 1! Couln't start ProFTPD!
XAMPP for Linux started.


Es lässt sich aktuell nichts mehr starten.
Wie kann man das Problem lösen?
Ist ein Downgrade auf 1.6.8a möglich, wenn ja wie?

Danke

tobi194
tobi194
 
Posts: 2
Joined: 05. January 2009 10:47

Re: Update von 1.6.8a auf 1.7 fehlgeschlagen

Postby tobi194 » 05. January 2009 12:28

Als Ergänzung noch die apachestart.log:
/opt/lampp/bin/httpd: /lib/libc.so.6: version `GLIBC_2.3.3' not found (required by /opt/lampp/lib/libapr-1.so.0)

Es scheint somit an der GLIBC Version zu liegen!
tobi194
 
Posts: 2
Joined: 05. January 2009 10:47

Re: Update von 1.6.8a auf 1.7 fehlgeschlagen

Postby glitzi85 » 05. January 2009 17:30

Tja, ne veraltete glibc ist gern der Fehlergrund ;-)

Entweder wieder alte XAMPP-Version nehmen oder neue SuSE-Version aufspielen. Alternativ kannst auch versuchen nur die glibc zu aktualisieren, wird aber wahrscheinlich deinem System nicht gut tun.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 5 guests