Apache laeuft nach ?nstallation nicht

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Apache laeuft nach ?nstallation nicht

Postby insane » 11. November 2003 09:18

Es gibt zu meinem Problem zwar ein Thema aber bei mir kommt die Fehlermeldung:

An error occured while loading http://localhost:


Could not connect to host localhost

Die Ausgabe nach dem Start befehl:

Starting XAMPP for Linux 1.4...
LAMPP: Starting Apache...
LAMPP: Starting MySQL...
LAMPP: Starting ProFTPD...
XAMPP for Linux started.


?ch habe auch versucht den Apache per Startapache zu Starten aber nach einigen sekunden kehrt es ohne ergebnis zu der Eingabeaufforderung zurück.
insane
 
Posts: 14
Joined: 11. November 2003 09:08
Location: München

Postby Kristian Marcroft » 11. November 2003 10:15

Hi,

1. versuchst du über http://localhost: oder mit http://localhost drauf zuzugreifen? (einmal mit einmal ohne Doppelpunkt am ende)
Letzteres wäre richtig.


2. was sagt das Errorlog dazu?
zu finden unter:
/opt/lampp/apache/logs
wenn ich mcih nicht irre :)

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Oswald » 11. November 2003 10:58

Die Logdatei, die KriS meint, ist die /opt/lampp/logs/error_log. Steht irgendwas fehlermäßiges am Ende dieser Datei?

Lieben Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Nochmal entpakt

Postby insane » 11. November 2003 11:05

Im error_log steht n?chts.

Hab noch mal entpakt und gestartet ohne erfolg.

Alle Dienste bis auf Apache werden gestartet.

Nach dem Neustart steht jetzt folgenden im error log:


[Tue Nov 11 11:05:59 2003] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Nov 11 11:09:39 2003] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
insane
 
Posts: 14
Joined: 11. November 2003 09:08
Location: München

Dummie auf Linux

Postby insane » 11. November 2003 11:11

Habe Linux erst heute früh ?nstalliert, habe null Peilung von der ganzen Materie.


SuSe 8.2
insane
 
Posts: 14
Joined: 11. November 2003 09:08
Location: München

Postby Oswald » 11. November 2003 11:25

Hi insane!

Okay. Dann wird der Apache sehr wahrscheinlich laufen. Welchen Browser benutzt Du?

Probier auch bitte mal http://127.0.0.1 anstelle von http://localhost.

Hast Du irgendwelche Proxy-Einstellungen in Deinem Browser?

Lieben Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby insane » 11. November 2003 11:41

Hallo,

leider geht es mit 127.0.0.1 nicht.

Proxy hab ich dekaktiviert, ohne ergebniss.

Der Apache kann nicht gestartet werden.

linux:~ # /opt/lampp/lampp stopapache
LAMPP: LAMPP-Apache is not running.
linux:~ #
insane
 
Posts: 14
Joined: 11. November 2003 09:08
Location: München

Postby Oswald » 11. November 2003 11:50

Ruf bitte mal folgende Befehle hintereinander auf und schreib die Ausgabe mal hier ins Forum:

/opt/lampp/lampp startapache
ps -aux | egrep httpd
tail -5 /opt/lampp/logs/error_log


Mit SuSE8.2 sollte es eigentlich keine Probleme geben. Hab ich hier auch.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby insane » 11. November 2003 12:07

linux:~ # /opt/lampp/lampp startapache ps -aux l egrep httpd tall -5/opt/lampp/logs/error_log
LAMPP: Starting Apache with SSL...
linux:~ #


error_log

[Tue Nov 11 12:05:08 2003] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
insane
 
Posts: 14
Joined: 11. November 2003 09:08
Location: München

Postby Oswald » 11. November 2003 12:18

Sorry. Das "hintereinander" war wohl missverständlich. Ich meinte es eher in der Bedeutung "nacheinander" und nicht "in einer Zeile". ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby insane » 11. November 2003 12:31

linux:~ # /opt/lampp/lampp startapache
LAMPP: Starting Apache with SSL...
linux:~ # ps -aux l agrep httpd
ERROR: User name does not exist.
********* simple selection ********* ********* selection by list *********
-A all processes -C by command name
-N negate selection -G by real group ID (supports names)
-a all w/ tty except session leaders -U by real user ID (supports names)
-d all except session leaders -g by session leader OR by group name
-e all processes -p by process ID
T all processes on this terminal -s processes in the sessions given
a all w/ tty, including other users -t by tty
g all, even group leaders! -u by effective user ID (supports names)
r only running processes U processes for specified users
x processes w/o controlling ttys t by tty
*********** output format ********** *********** long options ***********
-o,o user-defined -f full --Group --User --pid --cols --ppid
-j,j job control s signal --group --user --sid --rows
-O,O preloaded -o v virtual memory --cumulative --format --deselect
-l,l long u user-oriented --sort --tty --forest --version
-F extra full X registers --heading --no-heading
********* misc options *********
-V,V show version L list format codes f ASCII art forest
-m,m show threads S children in sum -y change -l format
-n,N set namelist file c true command name n numeric WCHAN,UID
-w,w wide output e show environment -H process hierarchy
linux:~ # ps-aux agrep httpd
bash: ps-aux: command not found
linux:~ # ps -aux egrep httpd
ERROR: User name does not exist.
********* simple selection ********* ********* selection by list *********
-A all processes -C by command name
-N negate selection -G by real group ID (supports names)
-a all w/ tty except session leaders -U by real user ID (supports names)
-d all except session leaders -g by session leader OR by group name
-e all processes -p by process ID
T all processes on this terminal -s processes in the sessions given
a all w/ tty, including other users -t by tty
g all, even group leaders! -u by effective user ID (supports names)
r only running processes U processes for specified users
x processes w/o controlling ttys t by tty
*********** output format ********** *********** long options ***********
-o,o user-defined -f full --Group --User --pid --cols --ppid
-j,j job control s signal --group --user --sid --rows
-O,O preloaded -o v virtual memory --cumulative --format --deselect
-l,l long u user-oriented --sort --tty --forest --version
-F extra full X registers --heading --no-heading
********* misc options *********
-V,V show version L list format codes f ASCII art forest
-m,m show threads S children in sum -y change -l format
-n,N set namelist file c true command name n numeric WCHAN,UID
-w,w wide output e show environment -H process hierarchy
linux:~ #
linux:~ # tail -5 /opt/lampp/logs/error_log
[Tue Nov 11 11:05:59 2003] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Nov 11 11:09:39 2003] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Nov 11 12:05:08 2003] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Nov 11 12:25:58 2003] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
linux:~ #
insane
 
Posts: 14
Joined: 11. November 2003 09:08
Location: München

Postby Oswald » 11. November 2003 12:33

Ahh... danke.

Bitte den zweiten Befehl noch mal: egrep und nicht agrep!
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby insane » 11. November 2003 12:54

Den Fehler habe auch bemerkt und bissl weiter unten habe ich den wiederholt.

linux:~ # ps -aux egrep httpd
ERROR: User name does not exist.
********* simple selection ********* ********* selection by list *********
-A all processes -C by command name
-N negate selection -G by real group ID (supports names)
-a all w/ tty except session leaders -U by real user ID (supports names)
-d all except session leaders -g by session leader OR by group name
-e all processes -p by process ID
T all processes on this terminal -s processes in the sessions given
a all w/ tty, including other users -t by tty
g all, even group leaders! -u by effective user ID (supports names)
r only running processes U processes for specified users
x processes w/o controlling ttys t by tty
*********** output format ********** *********** long options ***********
-o,o user-defined -f full --Group --User --pid --cols --ppid
-j,j job control s signal --group --user --sid --rows
-O,O preloaded -o v virtual memory --cumulative --format --deselect
-l,l long u user-oriented --sort --tty --forest --version
-F extra full X registers --heading --no-heading
********* misc options *********
-V,V show version L list format codes f ASCII art forest
-m,m show threads S children in sum -y change -l format
-n,N set namelist file c true command name n numeric WCHAN,UID
-w,w wide output e show environment -H process hierarchy
insane
 
Posts: 14
Joined: 11. November 2003 09:08
Location: München

Postby Oswald » 11. November 2003 12:58

Bitte noch mal versuchen:

ps -aux | egrep httpd

Mit | dazwischen. ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby insane » 11. November 2003 13:00

Kai Seidler wrote:Bitte noch mal versuchen:

ps -aux | egrep httpd

Mit | dazwischen. ;)




linux:~ # ps -aux | egrep httpd
Bad syntax, perhaps a bogus '-'?
root 5020 0.0 0.1 3636 508 pts/2 S 13:02 0:00 /bin/grep -E httpd
linux:~ #
insane
 
Posts: 14
Joined: 11. November 2003 09:08
Location: München

Next

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests