update von 1.1 auf 1.4 geht nicht

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

update von 1.1 auf 1.4 geht nicht

Postby dmarx » 07. November 2003 13:20

hallo,

wollte gerade mal wieder lampp updaten habe auch alles so gemacht wie in der beschreibung steht, erst 1.1-1.2 dann 1.2-1.3 und dann 1.3-1.4 installiert es wurde auch alles ausgepacht jedenfalls sah das so auch im winscp commando terminal

aber ich habe nicht den neuen look wenn ich auf localhost gehe und wenn ich lamp starte steht auch noch lampp 1.1 da

was habe ich falsch gemacht
Linux SuSE 8.1:
200 MHz
98 MB Ram
19 GB Festplatte
Lampp 1.4

Windows XP:
1,3 GHz AMD
512 MB Ram
120 GB Festplatte
dmarx
 
Posts: 55
Joined: 09. March 2003 20:56

Postby Oswald » 07. November 2003 13:25

Hall dmarx!

Hmm.. alte Webseiten: Lösch bitte mal den Browser-Cache.

Das da aber noch 1.1 steht ist seltsam. Bist Du Dir wirklich sicher? Was zeigt folgender Befehl an:

cat /opt/lampp/lib/VERSION

Lieben Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby dmarx » 07. November 2003 13:45

der zeigt auch 1.1 an
Linux SuSE 8.1:
200 MHz
98 MB Ram
19 GB Festplatte
Lampp 1.4

Windows XP:
1,3 GHz AMD
512 MB Ram
120 GB Festplatte
dmarx
 
Posts: 55
Joined: 09. March 2003 20:56

Postby steini » 07. November 2003 13:49

hmz, vielleciht saugst du dir noch mal die 1.4 un löscht und sicherst dir vorher deine daten. un entpackst dann 1.4 das sollte dann wohl klappen .
V-Server ab 7,90€ bei simplyroot
---
Image
User avatar
steini
 
Posts: 191
Joined: 24. October 2003 00:24
Location: Helmstedt
Operating System: Windows 10 Tech Preview

Postby dmarx » 07. November 2003 13:57

ich hab aber mein lampp schon ein bischen was eingestellt und das is ja alles weg dann
Linux SuSE 8.1:
200 MHz
98 MB Ram
19 GB Festplatte
Lampp 1.4

Windows XP:
1,3 GHz AMD
512 MB Ram
120 GB Festplatte
dmarx
 
Posts: 55
Joined: 09. March 2003 20:56

Postby Pc-dummy » 07. November 2003 13:59

Da kann ich leider auch nichts besseres sagen wie alter lampp verschieben neuer installiern, dann mit "diff" die ganzen configs vergleichen und die neuen ändernungen übernehmen (zuerst orginale dann eigene dürfte besser gehen).

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby Oswald » 07. November 2003 14:00

Hallo dmarx!

Kannst Du bitte noch mal das Update von 1.1 -> 1.2 starten und hier die Ausgabe posten, die Du beim Aufruf vom xampp-upgrade/start angezeigt werden.

Es kann eigentlich nicht sein, dass "1.1" in der Datei steht. Dann würden sich nämlich nicht die Updates 1.2->1.3 und 1.3->1.4 starten lassen.

Lieben Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby dmarx » 07. November 2003 14:03

hiermit starte ich das update


tar xvfz xampp-linux-upgrade-1.1-1.2.tar.gz -C /opt

und das ist was ausgeführt wird:

$ tar xvfz xampp-linux-upgrade-1.1-1.2.tar.gz -C /opt
xampp-upgrade/
xampp-upgrade/diffs/
xampp-upgrade/diffs/1.full
xampp-upgrade/diffs/1.path
xampp-upgrade/diffs/1.patch
xampp-upgrade/start
xampp-upgrade/.fromversion
xampp-upgrade/.toversion
xampp-upgrade/COPYING
xampp-upgrade/data.tar.gz
Linux SuSE 8.1:
200 MHz
98 MB Ram
19 GB Festplatte
Lampp 1.4

Windows XP:
1,3 GHz AMD
512 MB Ram
120 GB Festplatte
dmarx
 
Posts: 55
Joined: 09. March 2003 20:56

Postby steini » 07. November 2003 14:03

darum hatte ich ja auch gesagt das du die Daten sichern sollst ;), genau aus diesem grund
V-Server ab 7,90€ bei simplyroot
---
Image
User avatar
steini
 
Posts: 191
Joined: 24. October 2003 00:24
Location: Helmstedt
Operating System: Windows 10 Tech Preview

Postby Oswald » 07. November 2003 14:05

Huhu dmarx!

So updatest Du aber nicht. ;)

Schau mal in die Anleitung: http://www.apachefriends.org/faq-lampp.html#upgrade

So sollte das dann auch funktionieren! ;)

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby esCmo » 07. November 2003 14:05

dmarx wrote:hiermit starte ich das update


tar xvfz xampp-linux-upgrade-1.1-1.2.tar.gz -C /opt

und das ist was ausgeführt wird:

$ tar xvfz xampp-linux-upgrade-1.1-1.2.tar.gz -C /opt [...]


Damit entpackst du das Upgrade!! Du musst es danach noch ausführen!!
Code: Select all
/opt/xampp-upgrade/start

Dann ist es erst installiert!
User avatar
esCmo
 
Posts: 59
Joined: 21. September 2003 22:01

Postby Oswald » 07. November 2003 14:08

Da fällt mir ein: Nach dem Updaten bitte immer wieder das xampp-upgrade Verzeichnis löschen. Nicht das Du zwei Updates in dieses Verzeichnis packst. Das könnte dann Probleme geben.
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby dmarx » 07. November 2003 14:11

danke habs schon lange nicht mehr gemacht :oops: und da vergisst man einiges leider

aber jetzt kommt noch folgende meldung

$ xampp-upgrade/start
Stopping LAMPP 1.1...
LAMPP: LAMPP-Apache is not running.
LAMPP: LAMPP-MySQL is not running.
LAMPP: LAMPP-ProFTPD is not running.
LAMPP: LAMPP-Webmin is not running.
LAMPP stopped.
Upgrading 1.1 to 1.2...
Installing new files...
Upgrading existing files...
The file /opt/lampp/phpmyadmin/config.inc.php couldn't be upgraded.
The new version of the file could be found under: /opt/lampp/phpmyadmin/config.inc.php-1.2
The file /opt/lampp/phpmyadmin/config.inc.php couldn't be upgraded.
The new version of the file could be found under: /opt/lampp/phpmyadmin/config.inc.php-1.2
There were some problems during the upgrade. But don't panic! :)
Please read http://www.apachefriends.org/faq-lampp-en.html#undnun for assistance.


warum konnte der denn manche sachen nicht upgraden???
Linux SuSE 8.1:
200 MHz
98 MB Ram
19 GB Festplatte
Lampp 1.4

Windows XP:
1,3 GHz AMD
512 MB Ram
120 GB Festplatte
dmarx
 
Posts: 55
Joined: 09. March 2003 20:56

Postby esCmo » 07. November 2003 14:13

dmarx wrote:warum konnte der denn manche sachen nicht upgraden???

Das ist ganz normal... besuch doch einfach die dort extra deswegen angegebene URL und mach, was da steht...

EDIT: bzw. vergleich einfach mal beide Dateien mit diff, du wirst sehen, dass sich nichts geändert hat ausser Username und Passwort, und evtl. die AbsoluteURL (AFAIR), du kannst also einfach die neuere Datei löschen oder diese Werte eintragen und die nuere Datei in den Namen der alten umbenennen
User avatar
esCmo
 
Posts: 59
Joined: 21. September 2003 22:01

Postby dmarx » 07. November 2003 14:37

Danke allen die mir geholfen haben Server läuft jetzt

DANKE
Linux SuSE 8.1:
200 MHz
98 MB Ram
19 GB Festplatte
Lampp 1.4

Windows XP:
1,3 GHz AMD
512 MB Ram
120 GB Festplatte
dmarx
 
Posts: 55
Joined: 09. March 2003 20:56


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests