Webserver verkonfiguriert per .htaccess

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Webserver verkonfiguriert per .htaccess

Postby strauch » 20. August 2008 21:51

Hallo,

ich teste momentan ein wenig Drupal und da ich Probleme mit dem Modul Views hatte, habe ich dort ein wenig im Forum gesucht und mir eine .htacess Datei mit dem Inhalt:

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

gebastelt, da danach die Seite immer Fehler produzierte (scheinbar funktionierten die vereinfachten Links nicht mehr also statt "index.php?=irgendwas" nur noch drupal/irgendwas)

Hab ich es mal riskiert und

RemoveType x-mapp-php5 .php
RemoveHandler x-mapp-php5 .php

eingegeben, jetzt kann ich mir immer den php Quellcode anschauen. Wie kann ich das wieder hinbiegen, kenne mich hier leider garnicht aus.

Ich habe die aktuelle Version von xampp unter xubuntu Linux installiert.

Danke für eure Hilfe

Grüße

strauch
strauch
 
Posts: 5
Joined: 20. August 2008 21:48

Postby glitzi85 » 20. August 2008 23:11

Hallo,

x-mapp-php5 wird von Providern verwendet um dem Benutzer die Möglichkeit zu geben ohne umbenennen von zahlreichen Dateien die PHP-Version einzustellen. Dass dies unter XAMPP nicht funkioniert ist klar.

Was möchtest du denn machen? Solltest du PHP4 verwenden wollen anstatt 5 kannst du ja einfach mit der Switch-Datei die PHP-Version umstellen.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby deepsurfer » 21. August 2008 04:50

Wenn ich mich recht erinnere, gab es hier ein auch schonmal ein Thread wo jemand DRUPAL benutzt und die Sichtbaren URI Angaben umändern wollte.
Soweit ich mich nun erinnere müsste es in den Configs von DRUPAL einen Einstellung geben die das Aussehen der URI Anzeige steuert.

Nun denke ich mir, bevor Du über externe Anweisungen das Aussehen der URI änderst, so wäre es doch erstmal angebracht dem DRUPAL die URI-Anzeige Einstellung definieren zu lassen.

Ansonsten bitte erklären was Du überhaupt machen willst, also Dein Konzept, denn es könnte auch sein das sich diese ganze Fragerei nur auf DRUPAL bezieht und da wäre das Forum von DRUPAL eher eine Anlaufstelle.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby strauch » 21. August 2008 07:54

Hallo,

danke für eure Beiträge, ich will eigentlich nur den Ursprungszustand wieder herstellen. Also das was ich "angewiesen" habe Rückgängig machen. Ich hatte das eingegeben, weil es bei einigen Providern Probleme gelöst hat.

Ich hatte mir gedacht, proberst du es mal aus, die .htaccess Datei kannst du ja wieder löschen, aber die ist danach auch weg :).

Ich vermute das ich einfach wieder ein addtype und addhandler machen muss, nur welchen?

Es ist richtig das mann die URL Einstellung in den drupal Settings einstellen muss. Mein Problem war, das das Modul Views nicht funktioniert (Error 500) und ich deswegen

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

ausprobiert habe, ging natürlich in die Hose, mit Remove wurde es noch schlimmer. In der Apacheanleitung kann ich leider nicht rausfinden was ich eintippen muss.

Oder könnt ihr mir sagen welche Apachedatei das beeinflusst, dann spiel ich diese aus meinem Backup zurück.

Dank euch

Grüße

strauch
strauch
 
Posts: 5
Joined: 20. August 2008 21:48

Postby deepsurfer » 21. August 2008 09:56

Auch mal den Browser CACHE leeren, wirkt in vielen fällen wunder.


Lässt du deinen Browser über einen PROXY Server laufen ?
(und für diejenigen die jetzt die Hände über den Kopf schlagen, ich weiss das es bei einer lokalen Verbindung der Proxy nicht angesprochen wird, aber bekanntlich können Pferde auch "ko..en")
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby strauch » 21. August 2008 10:08

Ich hab es schon mit verschiedenen Browsern und mit verschiedenen Rechnern probiert. Ich habe auch keinen Proxy, aber warum soll denn hier ein Problem auftreten wenn ich meinem Apache den php Typ entferne und ich jetzt immer den Quelltext sehe, den bekommt der Cache ja sonst nicht zu sehen.

Ich glaub ich werde heute Abend einfach mal Drupal sichern und dann XAMPP neu aufsetzten (bzw. mein Backup einspielen und die Änderungen in Drupal wieder einpflegen), das geht wahrscheinlich schneller, als herauszufinden, welchen AddType und Handler ich eintippen muss.
strauch
 
Posts: 5
Joined: 20. August 2008 21:48

Postby glitzi85 » 21. August 2008 12:34

Ich werd das gefühl nicht los dass du einfach mal deine erstellte .htaccess-Datei löschen solltest.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby strauch » 21. August 2008 12:54

glitzi85 wrote:Ich werd das gefühl nicht los dass du einfach mal deine erstellte .htaccess-Datei löschen solltest.

mfg glitzi


würde ich gerne, aber wie ich schon schrieb, die ist nicht mehr da. sobald ich einmal die Seite aufgerufen habe wurde die .htaccess verschlungen, ich finde sie weder über den FTP Server noch direkt übers Linux System.

Deswegen habe ich es auch einfach ausprobiert, weil ich ja dachte ich kann sie ja löschen wenn es nicht klappt. Oder werden die vielleicht umkopiert oder irgendwie versteckt und ich muss eine Option aktivieren das ich sie per FTP wiederfinde?
strauch
 
Posts: 5
Joined: 20. August 2008 21:48

Postby strauch » 21. August 2008 13:17

Jepp sie war in der Tat versteckt, ich hab ein anderes FTP Programm genutzt und mir versteckt Dateien anzeigen lassen und jetzt konnte ich sie löschen....

Die Lösung war mal wieder ganz einfach. Danke für eure Hilfe :).

Mhh wobei es immer noch nicht ganz läuft, es gibt noch Probleme mit den Untermenüs und den anderen einfachen Linknamen..... angeblich muss ich die register_globals deaktivieren.... aber da google ich jetzt erstmal.

ok langsam geht alles wieder, ich habe die Standard drupal .htaccess Datei wieder hochgeladen und jetzt funktioniert wieder alles.

Grüße

strauch
strauch
 
Posts: 5
Joined: 20. August 2008 21:48


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests