<gelöst> Xampp funktioniert nur mit Netzwerkverbindung

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

<gelöst> Xampp funktioniert nur mit Netzwerkverbindung

Postby Schmyddy » 17. August 2008 20:14

Hallo

ich habe Xampp auf meinem Ubuntu (8.04) Laptop installiert. Das funktioniert sogar wunderbar.

Zu hause hab ich das Laptop mit einem Netzwerkkabel in mein Netz eingebunden. Der Router ist auch konfiguriert, so dass ich von anderen Rechnern auf die Seiten auf dem Laptop zugreifen kann - funktioniert auch. :lol:

Ich war im Urlaub und dachte nimmst das Lapi mit :) und kannst ein bisschen an den Seiten rumbasteln.
aber denkste :x :
Xampp startet ganz normal :? - beim Aufruf einer Seite sagt es mir das ich das nicht darf :cry:.
Ich im Niemandsland und INet weit und breit nicht in Sicht :evil:, also hab ich andere Sachen gemacht.
Nun bin ich wieder zu Hause und probiere ob es mit Netzwerkverbindung geht ...
... und es geht tadellos :D

Wie bekomme ich es hin, dass auf meinem Lapi Xampp auch unterwegs funktioniert :?:

Schmyddy
Last edited by Schmyddy on 18. August 2008 06:55, edited 1 time in total.
Schmyddy
 
Posts: 6
Joined: 17. August 2008 19:43

Postby glitzi85 » 17. August 2008 21:19

Hallo,

hast du irgendwas in der Konfigurationsdatei umgestellt? Speziell die Listen-Anweisung oder irgendwas im Bezug auf vHosts.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Schmyddy » 17. August 2008 21:40

nein

habe nur den Pfad zu meinen Seiten in der httpd.conf geändert.
Schmyddy
 
Posts: 6
Joined: 17. August 2008 19:43

Postby glitzi85 » 17. August 2008 21:43

OK, seltsam. Poste mal deine httpd.conf und die Ausgabe von ifconfig.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Schmyddy » 17. August 2008 22:06

Ausgabe bei ifconfig:

Code: Select all
lifebook:~$ ifconfig
eth0      Link encap:Ethernet  Hardware Adresse 00:90:96:0c:c6:9b 
          inet Adresse:10.0.0.10  Bcast:10.0.0.255  Maske:255.255.255.0
          inet6-Adresse: fe80::290:96ff:fe0c:c69b/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:6738094 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5855347 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:435071523 (414.9 MB)  TX bytes:2080875689 (1.9 GB)

lo        Link encap:Lokale Schleife 
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:16436  Metrik:1
          RX packets:3450 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3450 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0
          RX bytes:708788 (692.1 KB)  TX bytes:708788 (692.1 KB)


Inhalt von httpd.conf

Code: Select all
[#...]
ServerRoot "/opt/lampp"
[#...]
Listen 80
[#...]
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authn_dbm_module modules/mod_authn_dbm.so
LoadModule authn_anon_module modules/mod_authn_anon.so
LoadModule authn_dbd_module modules/mod_authn_dbd.so
LoadModule authn_default_module modules/mod_authn_default.so
LoadModule authz_host_module modules/mod_authz_host.so
LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule authz_dbm_module modules/mod_authz_dbm.so
LoadModule authz_owner_module modules/mod_authz_owner.so
LoadModule authnz_ldap_module modules/mod_authnz_ldap.so
LoadModule authz_default_module modules/mod_authz_default.so
LoadModule auth_basic_module modules/mod_auth_basic.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule file_cache_module modules/mod_file_cache.so
LoadModule cache_module modules/mod_cache.so
LoadModule disk_cache_module modules/mod_disk_cache.so
LoadModule mem_cache_module modules/mod_mem_cache.so
# mod_dbd doesn't work in Apache 2.2.3: getting always heaps of "glibc detected *** corrupted double-linked list" on shutdown - oswald, 10sep06
#LoadModule dbd_module modules/mod_dbd.so
LoadModule bucketeer_module modules/mod_bucketeer.so
LoadModule dumpio_module modules/mod_dumpio.so
LoadModule echo_module modules/mod_echo.so
LoadModule case_filter_module modules/mod_case_filter.so
LoadModule case_filter_in_module modules/mod_case_filter_in.so
LoadModule ext_filter_module modules/mod_ext_filter.so
LoadModule include_module modules/mod_include.so
LoadModule filter_module modules/mod_filter.so
LoadModule charset_lite_module modules/mod_charset_lite.so
LoadModule deflate_module modules/mod_deflate.so
LoadModule ldap_module modules/mod_ldap.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule logio_module modules/mod_logio.so
LoadModule env_module modules/mod_env.so
LoadModule mime_magic_module modules/mod_mime_magic.so
LoadModule cern_meta_module modules/mod_cern_meta.so
LoadModule expires_module modules/mod_expires.so
LoadModule headers_module modules/mod_headers.so
LoadModule ident_module modules/mod_ident.so
LoadModule usertrack_module modules/mod_usertrack.so
LoadModule unique_id_module modules/mod_unique_id.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_connect_module modules/mod_proxy_connect.so
LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule proxy_ajp_module modules/mod_proxy_ajp.so
LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
LoadModule mime_module modules/mod_mime.so
LoadModule dav_module modules/mod_dav.so
LoadModule status_module modules/mod_status.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule asis_module modules/mod_asis.so
LoadModule info_module modules/mod_info.so
LoadModule suexec_module modules/mod_suexec.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule cgid_module modules/mod_cgid.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule vhost_alias_module modules/mod_vhost_alias.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule dir_module modules/mod_dir.so
LoadModule imagemap_module modules/mod_imagemap.so
LoadModule actions_module modules/mod_actions.so
LoadModule speling_module modules/mod_speling.so
LoadModule userdir_module modules/mod_userdir.so
LoadModule alias_module modules/mod_alias.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule apreq_module modules/mod_apreq2.so
LoadModule ssl_module modules/mod_ssl.so

<IfDefine JUSTTOMAKEAPXSHAPPY>
LoadModule php4_module        modules/libphp4.so
LoadModule php5_module        modules/libphp5.so
</IfDefine>

<IfModule !mpm_winnt_module>
<IfModule !mpm_netware_module>
[#...]
User nobody
Group nogroup
</IfModule>
</IfModule>
[#...]
ServerAdmin you@example.com
[#...]
ServerName localhost
[#...]
DocumentRoot "/home/schmyddy/public_html"
[#...]
<Directory />
    Options FollowSymLinks
    AllowOverride None
    #XAMPP
    #Order deny,allow
    #Deny from all
</Directory>
[#...]
<Directory "/home/schmyddy/public_html">
    [#...]
    Options Indexes FollowSymLinks ExecCGI Includes
    [#...]
    AllowOverride All
    [#...]
    Order allow,deny
    Allow from all

</Directory>
[#...]
<IfModule dir_module>
    #DirectoryIndex index.html
    # XAMPP
    DirectoryIndex index.html index.html.var index.php index.php3 index.php4
</IfModule>
[#...]
<FilesMatch "^\.ht">
    Order allow,deny
    Deny from all
</FilesMatch>
[#...]
ErrorLog logs/error_log
[#...]
LogLevel warn

<IfModule log_config_module>
    [#...]
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common

    <IfModule logio_module>
      # You need to enable mod_logio.c to use %I and %O
      LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
    </IfModule>

    [#...]
    CustomLog logs/access_log common

    [#...]
    #CustomLog logs/access_log combined
</IfModule>

<IfModule alias_module>
    [#...]
    ScriptAlias /cgi-bin/ "/opt/lampp/cgi-bin/"

</IfModule>

<IfModule cgid_module>
    [#...]
    #Scriptsock logs/cgisock
</IfModule>
[#...]
<Directory "/opt/lampp/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
</Directory>
[#...]
DefaultType text/plain

<IfModule mime_module>
    [#...]
    TypesConfig etc/mime.types

    [#...]
    #AddType application/x-gzip .tgz
    [#...]
    #AddEncoding x-compress .Z
    #AddEncoding x-gzip .gz .tgz
    [#...]
    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz

    [#...]
    #AddHandler cgi-script .cgi
    # XAMPP, since LAMPP 0.9.8:
    AddHandler cgi-script .cgi .pl

    # For files that include their own HTTP headers:
    #AddHandler send-as-is asis

    # For server-parsed imagemap files:
    #AddHandler imap-file map

    # For type maps (negotiated resources):
    #AddHandler type-map var

    [#...]
    # XAMPP
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
</IfModule>

[#...]
#MIMEMagicFile etc/magic

#
# Customizable error responses come in three flavors:
# 1) plain text 2) local redirects 3) external redirects
#
# Some examples:
#ErrorDocument 500 "The server made a boo boo."
#ErrorDocument 404 /missing.html
#ErrorDocument 404 "/cgi-bin/missing_handler.pl"
#ErrorDocument 402 http://www.example.com/subscription_info.html
#

[#...]
EnableMMAP off
EnableSendfile off

[#...]

# Server-pool management (MPM specific)
#Include etc/extra/httpd-mpm.conf

# Multi-language error messages
#Include etc/extra/httpd-multilang-errordoc.conf

# Fancy directory listings
Include etc/extra/httpd-autoindex.conf

# Language settings
#Include etc/extra/httpd-languages.conf

# User home directories
#Include etc/extra/httpd-userdir.conf

# Real-time info on requests and configuration
#Include etc/extra/httpd-info.conf

# Virtual hosts
#Include etc/extra/httpd-vhosts.conf

# Local access to the Apache HTTP Server Manual
#Include etc/extra/httpd-manual.conf

# Distributed authoring and versioning (WebDAV)
#Include etc/extra/httpd-dav.conf

# Various default settings
Include etc/extra/httpd-default.conf

# Secure (SSL/TLS) connections
<IfModule ssl_module>
# XAMPP
<IfDefine SSL>
Include etc/extra/httpd-ssl.conf
</IfDefine>
</IfModule>
[#...]
<IfModule ssl_module>
SSLRandomSeed startup builtin
SSLRandomSeed connect builtin
</IfModule>

# XAMPP
Include etc/extra/httpd-xampp.conf
Schmyddy
 
Posts: 6
Joined: 17. August 2008 19:43

Postby glitzi85 » 17. August 2008 22:17

OK, sieht gut aus.

Wie rufst du denn deine Seite auf?

Zieh mal dein Netzwerkkabel raus, starte XAMPP und gibt http://localhost in deinem Browser ein. Welche Fehlermeldung kommt dann ganz genau?

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Schmyddy » 17. August 2008 22:33

also bei http://localhost kommt sowieso ne fehlermeldung,

Code: Select all
*//
Warning: include(lang/<? $fp=fopen("lang.tmp","w"); fwrite($fp,basename($_SERVER['QUERY_STRING'])); fclose($fp); header("Location: index.php"); ?> .php) [function.include]: failed to open stream: No such file or directory in /home/schmyddy/public_html/xampp/index.php on line 12

Warning: include() [function.include]: Failed opening 'lang/<? $fp=fopen("lang.tmp","w"); fwrite($fp,basename($_SERVER['QUERY_STRING'])); fclose($fp); header("Location: index.php"); ?> .php' for inclusion (include_path='.:/opt/lampp/lib/php') in /home/schmyddy/public_html/xampp/index.php on line 12


da ist es egal ob mit oder ohne Netzwerkkabel, das hat mich nicht weiter gestört, weil ich ja auf meine Seiten über localhost kam - ich hab auch schon mal ein Update drüber gespielt, aber da hat sich nix geändert.

rufe ich eine meiner Seiten auf kommt:

Code: Select all
Offline-Modus

Firefox ist momentan im Offline-Modus und kann nicht zum Browsen im Web verwendet werden.


-> Opera sagt das selbe
Schmyddy
 
Posts: 6
Joined: 17. August 2008 19:43

Postby glitzi85 » 17. August 2008 22:45

Schmyddy wrote:rufe ich eine meiner Seiten auf kommt:

was meinst du damit?

Zu deinem eigentlichen Problem: Wenn du Firefox startest und er findet keine aktive Internetverbindung bzw. Netzwerkverbindung schaltet das Teil in Offline-Mode. Einfach im Firefox auf Datei -> Offline arbeiten wieder abschalten. Dann sollte das auch gehen.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Schmyddy » 18. August 2008 06:53

mit meinen Seite meine ich die Homepages, die ich selber erstellt habe:
z.B.
Code: Select all
Verzeichnis: /home/schmyddy/public_html/Pages/Tools/md5

-> Adresse: http://localhost/Pages/Tools/md5



Das es an diesem einfachen Häkchen hängt, ist ärgerlich. ich habe mir sonstwas gedacht.

thx
Schmyddy
 
Posts: 6
Joined: 17. August 2008 19:43

Postby glitzi85 » 18. August 2008 12:28

Hi,

das mit den Seiten ist OK, ich dachte dabei jetzt irgendwie an vHosts mit seinen unsäglich vielen Fehlermöglichkeiten ;-)

Schmyddy wrote:Das es an diesem einfachen Häkchen hängt, ist ärgerlich. ich habe mir sonstwas gedacht.

Funktioniert es denn jetzt?

Alternativ kannst dir auch ein Loopback-Device installieren. Damit hast du immer eine aktive Netzwerkverbindung, wenn auch nirgendwo hin:

Start -> Einstellungen -> Systemsteuerung -> Neue Hardware hinzufügen

Da startet dann der Suchlauf, wenn dieser beendet ist die Option "Ja, Gerät hängt schon dran" oder so ähnlich auswählen. Dann bekommst du eine Liste mit Geräten die installierbar sind. Ganz unten in der List gibt es den Punkt "Neues Gerät", diesen Auswählen. Im nächsten Fenster dann die Option mit Manueller installation. In der nächsten Liste wählst du dann einen Netzwerkadapter aus. Dann kannst du die Treiber dafür auswählen. Als Hersteller Microsoft, als Treiber den Microsoft Loopback Adapter.

Jetzt hast du unter Netzwerkverbindungen ein neues Netzwerkgerät. Diesem gibst du eine feste IP-Adresse die NICHT in deinem normalen IP-Bereich liegt (z.B. 10.0.1.1/255.255.255.0). Dazu KEINE Gateway oder DNS Adresse! Damit hast du immer eine aktive Netzwerkverbindung, die halt nirgends hinzeigt. Dadurch startet der Firefox aber nicht mehr im Offline-Modus.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests