PHP austauschen, wie?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

PHP austauschen, wie?

Postby neo67 » 11. August 2008 09:35

Hallo zusammen,

ich habe unter SuSE 10.3 XAMPP 1.6.7 installiert. Wir wollen ein PHP-Programm benutzen, welches aber zwischen PHP-Version größer 5.0 und kleiner 5.16 sein muß.
Was ist zu tun, um die aktuelle PHP-Version auszutauschen? Habe darüber leider nichts gefunden.

Vielen Dank für die Hilfe!

Edit: Ich suche jetzt mal eine Version von xampp auf sourgeforce , die mit, der von mir benötigten, PHP Version versehen ist.

Gruß
Jürgen
neo67
 
Posts: 5
Joined: 11. August 2008 09:17

Postby Nobbie » 11. August 2008 11:32

>welches aber zwischen PHP-Version größer 5.0 und kleiner 5.16 sein muß

Wozu? Wieso geht PHP 5.2.5 nicht?
Nobbie
 
Posts: 8769
Joined: 09. March 2008 13:04

Postby neo67 » 11. August 2008 11:42

Nobbie wrote:>welches aber zwischen PHP-Version größer 5.0 und kleiner 5.16 sein muß

Wozu? Wieso geht PHP 5.2.5 nicht?


Da ist eine sicherheitskritische Anwendung, und dort ist es dringend vorgeschrieben, innerhalb dieser Versionen zu bleiben. Ob es funktioniert oder nicht, steht leider nicht zur Debatte.. :(
neo67
 
Posts: 5
Joined: 11. August 2008 09:17

Postby Nobbie » 11. August 2008 11:49

>Da ist eine sicherheitskritische Anwendung, und dort ist es dringend vorgeschrieben, innerhalb dieser Versionen zu bleiben.

Hä? Im Zweifel ist aber doch eine neuere Version sicherer als eine ältere?

Sonst mußt Du Dir bei www.php.net eine alte (passende) Version im Sourcecode herunterladen, dann kopierst Du aus dem phpinfo()-Dialog die configure-Anweisung "Configure Command" und führst diese im Source Directory von PHP aus.

Dazu musst Du alle benötigten Tools, die dort angegeben werden, ebenfalls (sukzessive) als Development-Version herunterladen (und ebenfalls compilieren), bis der "configure" fehlerfrei läuft. Dann kannst Du abschließend mit "make" und "make install" (als "root") die notwendigen Module kompilieren.

Ist viel Arbeit, aber wer es so sicher braucht, der muss das in Kauf nehmen.
Nobbie
 
Posts: 8769
Joined: 09. March 2008 13:04

Postby neo67 » 11. August 2008 12:23

Nobbie wrote:>Da ist eine sicherheitskritische Anwendung, und dort ist es dringend vorgeschrieben, innerhalb dieser Versionen zu bleiben.

Hä? Im Zweifel ist aber doch eine neuere Version sicherer als eine ältere?

Sonst mußt Du Dir bei www.php.net eine alte (passende) Version im Sourcecode herunterladen, dann kopierst Du aus dem phpinfo()-Dialog die configure-Anweisung "Configure Command" und führst diese im Source Directory von PHP aus.

Dazu musst Du alle benötigten Tools, die dort angegeben werden, ebenfalls (sukzessive) als Development-Version herunterladen (und ebenfalls compilieren), bis der "configure" fehlerfrei läuft. Dann kannst Du abschließend mit "make" und "make install" (als "root") die notwendigen Module kompilieren.

Ist viel Arbeit, aber wer es so sicher braucht, der muss das in Kauf nehmen.


Nun ja, sicher wird das in 90% der Fälle stimmen, aber die geben da keine Info raus, warum die neueren Versionen nicht genommen werden sollen.
Okay. Danke für die Antwort, ich gehe erstmal den "einfachen" Weg, eine ältere Version zu nehmen. Wenn die dann ihr "OK" geben ist mir das dann egal. Sollte es zu Schwierigkeiten kommen, muß ich wohl den von Dir beschriebenen Weg gehen.
Das heisst, ich hole mir vom aktuellen PHP/XAMPP per phpinfo() Anzeige diese Anweisung und führe das im ../src von dem älteren PHP aus und das make install überschreibt dann die aktuelle Version unter Xampp, richtig?
neo67
 
Posts: 5
Joined: 11. August 2008 09:17

Postby deepsurfer » 11. August 2008 12:31

Habe keine Release Info mehr, falls nötig einfach eine Ältere XAMPP Version benutzen worin PHP <= 5.16 wäre.

Auf der Sourceforge Seite von XAMPP kann man sich die älteren Versionen auch herunterladen.

Wird diese Anwendung mit XAMPP auf einem Produktiv Server benutzt ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby neo67 » 11. August 2008 12:33

deepsurfer wrote:Habe keine Release Info mehr, falls nötig einfach eine Ältere XAMPP Version benutzen worin PHP <= 5.16 wäre.

Auf der Sourceforge Seite von XAMPP kann man sich die älteren Versionen auch herunterladen.

Wird diese Anwendung mit XAMPP auf einem Produktiv Server benutzt ?

2x ja, ich bin die ganzen Releases durch gegangen. Habe jetzt eines gefunden. Ja, dass wird dann ein Produktivserver sein, aber nur für diesen einen Zweck.
neo67
 
Posts: 5
Joined: 11. August 2008 09:17


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests