[gelöst] Probleme mit XAMPP und proftp

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

[gelöst] Probleme mit XAMPP und proftp

Postby Futuretop » 03. August 2008 15:27

Hallo Leser!


Ich versuche proftp mit mysql aufzusetzen.

Die /opt/lampp/etc/proftpd.conf sieht so aus:

ServerName "united-xxx.de"
ServerType standalone
DeferWelcome on
DefaultServer on
Port 21
Umask 002
MaxClientsPerHost 3 "Nicht mehr als %m Verbindungen"
MaxClients 10 "Leider sind schon %m Clients verbunden"
MaxLoginAttempts 3
MaxInstances 30
User wwwrun
Group nogroup
DefaultRoot ~
RequireValidShell off
LogFormat default "%h %l %u %t \"%r\" %s %b"
LogFormat auth "%v [%P] %h %t \"%r\" %s"
LogFormat write "%h %l %u %t \"%r\" %s %b"
SQLAuthTypes Plaintext
SQLDefaultHomedir /u/server
SQLAuthenticate users*
SQLConnectInfo uphftp@localhost root
SQLDefaultGID 65534
SQLDefaultUID 65534
SQLMinUserGID 100
SQLMinUserUID 500
SQLUserInfo users username password uid gid homedir shell
SQLGroupInfo groups groupname gid members
SQLLog RETR,STOR transfer1
SQLNamedQuery transfer1 INSERT "'%u', '%f', '%b', '%h', '%a', '%m','%T',now(), 'c', NULL" xfer_stat
SQLLOG ERR_RETR,ERR_STOR transfer2
SQLNamedQuery transfer2 INSERT "'%u', '%f', '%b', '%h', '%a', '%m','%T',now(), 'i', NULL" xfer_stat


Tabellen sind angelegt.

Mein FTP-Client kann keine richtige Verbindung aufbauen.

Meldungen:

Status: Auflösen der IP-Adresse für united-xxx.de
Status: Verbinde mit xxx.xxx.5.204:21...
Status: Verbindung hergestellt, warte auf Willkommensnachricht...
Fehler: Herstellen der Verbindung zum Server fehlgeschlagen
Status: Nächsten Versuch abwarten...
Status: Auflösen der IP-Adresse für united-xxx.de
Status: Verbinde mit xxx.xxx.5.204:21...
Status: Verbindung hergestellt, warte auf Willkommensnachricht...
Fehler: Herstellen der Verbindung zum Server fehlgeschlagen
Status: Nächsten Versuch abwarten...
Status: Auflösen der IP-Adresse für united-xxx.de
Status: Verbinde mit xxx.xxx.5.204:21...
Status: Verbindung hergestellt, warte auf Willkommensnachricht...
Fehler: Herstellen der Verbindung zum Server fehlgeschlagen


Kann mir jemand sagen, warum die Verbindung nicht richtig zu stande kommt?


Thomas
Last edited by Futuretop on 10. March 2010 07:17, edited 1 time in total.
Futuretop
 
Posts: 13
Joined: 03. August 2008 15:20

Postby DJ DHG » 03. August 2008 20:07

Moin Moin!

Starte ProFTPd im Debug-Modus mit
Code: Select all
/opt/lampp/sbin/proftpd -n -d5

(vorher Xampp stoppen!)
Dann versuche einen neuen Verbindungsaufbau mit deinem FTP-Client.


mfg DJ DHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Postby Futuretop » 12. August 2008 12:41

Hallo!

Danke für die Antwort.

ich habe die proftpd.tar.gz installiert.

Der Befehl proftpd -n -d5 ergibt eine Ausgabe auf dem Shell. Mit proftpd -d0 wird nur der FTP-Server gestartet ohne Log.

Ich möchte den FTP-Server jede Nacht für ein paar Stunden stoppen.

Leider funktioniert der Befehl proftpd -d0 (proftpd -n -d5 klappt auch nicht) nicht als Cronjob. Auch nicht wenn ich ein Shell-Script anlege und dann per Cronjob starten will.



Thomas
Futuretop
 
Posts: 13
Joined: 03. August 2008 15:20

Postby glitzi85 » 12. August 2008 12:52

Was zum Teufel hat jetzt dein Cronjob-Problem mit dem Debugging für die SQL-Connection zu tun?

Starte den Server wie DJ DHG es geschrieben hat und sag uns was im Logfile steht!

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Futuretop » 12. August 2008 13:15

Hallo!


Die Verbindung zum FTP-Server ist möglich, der Login über MySQL ist möglich, der Upload ist möglich. Der Start über die Konsole mit den Befehl proftpd -n -d5 ist möglich. Ich möchte aber keine ständige Ausgabe auf der Konsole haben.

Mein mein Problem besteht nur noch mit dem Cronjob. Falls das nicht mehr hier hingehört, dann ist das Thema gelöst und ich bedanke mich.



Thomas
Futuretop
 
Posts: 13
Joined: 03. August 2008 15:20

Postby deepsurfer » 12. August 2008 13:40

Mein mein Problem besteht nur noch mit dem Cronjob. Falls das nicht mehr hier hingehört, dann ist das Thema gelöst und ich bedanke mich.


Das Missverstehst Du, denn wenn Du mal Deine Texte nochmal durchliest so wirst Du feststellen das Du einen gewaltigen Sprung gemacht hast, den ich (wir) nicht nach voll ziehen konnten.

Deine Frage war wegen einem Verbindungsfehler, ~Wiedmann~ gibt dir ein Lösungsweg damit wir Informationen darüber erhalten können um weiter zu helfen, dann kam aber von Dir etwas mit CronJob und keine Angabe darüber über das Logfile was wir bräuchten um zu helfen.
Dieser Vorgang hätte im weiteren Verlauf nicht mehr mit Massen an Logfiles zutun, weil du den Debug Befehl danach nicht mehr Anwenden bräuchtest, es ging nur um diesen einen Vorgang.

Nungut, da nun Deine letzte Meldung suggeriert das deine eigentliche Frage geklärt ist können wir nun zum nächsten Thema kommen, dem CronJob.

Hier wäre eine kleine Konzept Ausführung sinnvoll, was Du gedanklich mit dem CronJob machen willst.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Futuretop » 12. August 2008 16:40

Hallo!


Nachts wird ein Backup der neuen Daten vorgenommen. Die Daten dürfen deshalb nicht verändert werden. Andere Dienste wie z.B. FTP sollen dabei nicht stören. Deshalb wird der Dienst Web und FTP von 1-3 Uhr abgestellt. Dies erledigte auf dem alten Server XAMPP. XAMPP ist wie gesagt für den FTP-Dienst ja nicht mehr zuständig. Also kommt lampp startftp nicht mehr in Frage.

Der alte Cronjob sah ungefähr so aus:

1.01 Uhr STOP Apache (lampp stopapache)
1.01 Uhr STOP ProFTPd (lampp stopftp)
1.02 Uhr BACKUP durchführen
2.59 Uhr START Apache (lampp startapache)
2.59 Uhr START ProFTPd (lampp startftp)

Der neue sieht so aus:

1.01 Uhr STOP Apache (lampp stopapache)
1.01 Uhr STOP ProFTPd (skill proftpd)
1.02 Uhr BACKUP durchführen
2.59 Uhr START Apache (lampp startapache)
2.59 Uhr START ProFTPd ??????????????


XAMPP soll ganz weg. Aber alles Schritt für Schritt. Jetzt macht der Cronjob ärger!


Thomas
Futuretop
 
Posts: 13
Joined: 03. August 2008 15:20

Postby deepsurfer » 12. August 2008 16:47

Wieso musst du ein skill durchführen, den normalen shutdown des ProFTP wie bisher auch durchführen dann Backup und alles wieder hochfahren.

Wenn Du aber meinst das Du nicht mehr den XAMPP-ProFTP benutzt sondern einen System installierten ProFTP, dann wäre der stop bzw start befehl /etc/init.d/proftpd stop ; /etc/init.d/proftpd start

Im CronJob script am besten noch vor dem Backup ein "wait 20" einsetzen, denn dann hätte das System noch zeit die Prozesse zu Schliessen bevor der Backup Angestossen wird, damit verhinderst Du auch das eventuell gerade jemand am Uploaden/Downloaden ist da dies ohne probleme für das Backup unterbrochen wird.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Futuretop » 12. August 2008 17:10

Hallo!

Es handelt bei dem ProFTPd-Paket um das tar.gz-Format. Ein rpm würde am Ende ein Start in /etc/init.d/ möglich machen. Ein rpm-Paket würde die Software auch im yast erscheinen lassen. Mir wäre ein rpm-Paket auch lieber, das habe ich schon versucht (mehere Tage). Dort fehlt das mod_sql immer.

Hier die Verzeichnisse von proftpd:

FILES
/usr/local/sbin/proftpd
/usr/local/etc/proftpd.conf
/usr/local/bin/ftpwho
/usr/local/bin/ftpcount
/usr/local/bin/ftptop
/usr/local/sbin/ftpshut
/var/log/xferlog
/usr/local/var/run/proftpd.pid
/usr/local/var/run/proftpd.scoreboard


Thomas
Futuretop
 
Posts: 13
Joined: 03. August 2008 15:20

Postby deepsurfer » 12. August 2008 17:27

/usr/local/sbin/proftpd


Kannst diesen nehmen

/usr/local/sbin/proftpd stop
/usr/local/sbin/proftpd start
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Futuretop » 12. August 2008 17:32

Hallo!

united-xxxxxx:/usr/local/sbin # ./proftpd start
- unknown parameter: 'start'

So einfach geht es leider nicht.

Die Befehlsparameter wären:

OPTIONS
-h,--help Display a short usage description, including all available
options.

-n,--nodaemon
Runs the proftpd process in standalone mode (must be conâ[m
figured as such in the configuration file), but does not
background the process or disassociate it from the controlâ[m
ling tty. Additionally, all output (log or debug messages)
are sent to stderr, rather than the syslog mechanism. Most
often used with the -d option for debugging.

-q,--quiet Quiet mode; don't send logging information to standard
error when running with the -n option.

-v,--version
Displays the version number of ProFTPD to stdout.

-D,--define parameter
Sets a configuration parameter which can be used <IfDeâ[m
fine>...</IfDefine> sections in the configuration files to
conditionally skip or process commands.

-d,--debug debuglevel
Sets proftpd's internal debug level (normally 0). The
debuglevel should be an integer value from 0 to 10, with
higher numbers producing more debug output. Normally,
debug messages are sent to syslog using the DEBUG facility,
however if the -n option is used, all such output is sent
to stderr.

-c,--config config-file
Specifies an alternate config-file to be parsed at startup,
rather than the default configuration file. The default
configuration file is /usr/local/etc/proftpd.conf

-N,--nocollision
Disables address/port collision checking.

-V,--settings
Displays various compile-time settings and exits.

-t,--configtest
Read the configuration file, report any syntax errors, and
exit.

-p,--persistent 0|1
Disables (0) or enables (1) the default persistent password
support, which is determined at configure time for each
platform. This option only affects the default support, it
can still be overridden at run-time with the Persistentâ[0m
Passwd directive.

-l,--list Lists all modules compiled into proftpd.

-4,--ipv4 Support IPv4 functionality only, regardless of whether the
--enable-ipv6 configure option was used.

-6,--ipv6 Support IPv6 connections and lookup of IPv6 addresses for
server DNS names. This is enabled by default, if the
--enable-ipv6 configure option is used.


Thomas
Futuretop
 
Posts: 13
Joined: 03. August 2008 15:20

Postby glitzi85 » 12. August 2008 17:33

Und hier noch das passende Start/Stop-Script:

Code: Select all
#! /bin/sh

set -e

case "$1" in
 start)
  /opt/proftpd/sbin/proftpd
  ;;

 stop)
  kill `ps -ef|grep proftpd|grep -v grep|awk '{print $2}'` > /dev/null 2>&1
  ;;

 *)
  echo "Usage: $0 {start|stop}"
esac


Einfach in /etc/init.d/proftpd abspeichern, chmod +x und glücklich sein.
Pfade natürlich anpassen, bei mir liegt halt alles in opt.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Postby Futuretop » 12. August 2008 17:59

Hallo!


Habe die Datei so angepasst:


#! /bin/sh

set -e

case "$1" in
start)
/usr/local/sbin/proftpd
;;

stop)
kill `ps -ef|grep proftpd|grep -v grep|awk '{print $2}'` > /dev/null 2>&1
;;

*)
echo "Usage: $0 {start|stop}"
esac


-rwxr-xr-x 1 root root 214 Aug 12 18:53 proftpd*



united-xxxxxx:/etc/init.d # proftpd start
- unknown parameter: 'start'

Klappt so nicht! Warum läßt sich ein Befehl den ich im shell ausführen kann, nicht als Cronjob ausführen?

Hier ist die Anleitung nach der ich ProFTPd eingerichtet habe:

http://www.proftpd.de/HowTo-SQL.29.0.html


Thomas
Futuretop
 
Posts: 13
Joined: 03. August 2008 15:20

Postby glitzi85 » 12. August 2008 19:40

Futuretop wrote:united-xxxxxx:/etc/init.d # proftpd start
- unknown parameter: 'start'

Na dann würd ich's doch mal mit dem richtigen Befehl probieren, was:
Code: Select all
/etc/init.d/proftpd start

oder falls du schon im Verzeichnis /etc/init.d/ bist, dann reicht auch ein simples
Code: Select all
./proftpd start


/usr/local liegt im Suchpfad, wenn du also proftpd einfach so in die Konsole eingibst, dann wird /usr/local/sbin/proftpd ausgeführt, was ja erfahrungsgemäß nicht funktioniert.

mfg glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

[gelöst] Cronjob für ProFTPd

Postby Futuretop » 12. August 2008 19:58

Hallo!

Was so ein Punkt doch ausmachen kann. Der Cronjob funktioniert jetzt.

Vielen Dank für die Lösung!


Thomas
Futuretop
 
Posts: 13
Joined: 03. August 2008 15:20


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests