Sendmail auf Rechner geht und klappt nicht!

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Sendmail auf Rechner geht und klappt nicht!

Postby brali » 29. October 2003 18:24

Hallo zusammen,

So 2.te Problem nach Upgrade auf 1.3.

Nachdem meine SQL Datenbank wieder rennt, habe ich mich wieder ans scripten begeben.

Was mir allerdings aufgefallen ist, ist das ich keine emails mehr von dem Rechner senden kann.

Ich habe einige Topics durchsucht, aber nichts gefunden. bzw, haben die meisten da aufgehört wo es für mich Interessant werden könnte.

Also was ist passiert:

echo hallo | mail xxx@xxx.de Funzt net!

meine scripte zeigen mir keine fehler.

Zur Information.

WAMPP 1.3
Debian 2.4
sonst nackt!! :)

Wo kann der Fehler liegen??


PS: Vor den Upgrade hat auch das ohne Probleme funktioniert!..


greetz for the help

brali
=:Stimmt es, daß die Arbeit am Computer dumm macht?" - "Sie haben nichts zu befürchten. Computer können einen wahnsinnig machen, aber nicht dumm. :=
User avatar
brali
 
Posts: 35
Joined: 23. June 2003 19:20
Location: Nrw / Köln

Postby Oswald » 29. October 2003 18:39

Huhu Brali!

Also mit XAMPP wird das definitiv (können wir gerne wetten ;) ) nicht zu tun haben. XAMPP liegt nur unter /opt/lampp und somit hat es überhaupt keinen Einfluss auf das Restsystem.

Grundsätzliche Fragen erstmal:
Ist der Rechner am Internet? Soll er quasi Mails richtig verschicken? Oder nur lokal?

Welchen Mailserver benutzt Du? sendmail, qmail, postfix, ...?

In /var/log/mail (sollte auch bei Debian so sein) stehen evtl. Fehlermeldungen, die mit Mail zusammenhängen. Steht da was drin?

Lieben Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby brali » 29. October 2003 18:49

Hey. hallo, so sieht man sich wieder,

okay okay, ich glaube Dir.
War für mich (will nicht wetten, denke das ich Dir das glauben kann :D ) das nahe liegenste.
also ich nutze Sendmail! der bei Debian dabei ist.

Ja ist am Router und damit Web tauglich :P und er soll wieder richtig gut verschicken.

Fehlermeldungen =
mailwarn = leer 0 kb
maillog = leer 0 kb
mailinfo = leer 0kb
mailerr = leer 0kb


greetz aus Köln
=:Stimmt es, daß die Arbeit am Computer dumm macht?" - "Sie haben nichts zu befürchten. Computer können einen wahnsinnig machen, aber nicht dumm. :=
User avatar
brali
 
Posts: 35
Joined: 23. June 2003 19:20
Location: Nrw / Köln

Postby Oswald » 29. October 2003 19:02

Okay, dann fangen wir mal an! ;)

Was gibt sendmail -bv oswald@apachefriends.org aus?
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby brali » 29. October 2003 19:07

Ich mache es kurz:

Code: Select all
root@fuchx:~# sendmail -bv oswald@apachefriends.org
oswald@apachefriends.org failed to verify:
  unrouteable mail domain "apachefriends.org"
=:Stimmt es, daß die Arbeit am Computer dumm macht?" - "Sie haben nichts zu befürchten. Computer können einen wahnsinnig machen, aber nicht dumm. :=
User avatar
brali
 
Posts: 35
Joined: 23. June 2003 19:20
Location: Nrw / Köln

Postby Oswald » 29. October 2003 19:09

Nächste Runde:

ping www.apachefriends.org

und

dig apachefriends.org mx

(Ich mach's auch kurz. ;) )
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby brali » 29. October 2003 19:12

ich sehe wir verstehen uns :wink:

Code: Select all
root@fuchx:~# ping www.apachefriends.org
PING www.apachefriends.org (80.190.233.45): 56 data bytes
64 bytes from 80.190.233.45: icmp_seq=0 ttl=55 time=302.5 ms
64 bytes from 80.190.233.45: icmp_seq=1 ttl=55 time=181.0 ms
64 bytes from 80.190.233.45: icmp_seq=2 ttl=55 time=189.5 ms
64 bytes from 80.190.233.45: icmp_seq=3 ttl=55 time=201.9 ms
64 bytes from 80.190.233.45: icmp_seq=4 ttl=55 time=352.0 ms
64 bytes from 80.190.233.45: icmp_seq=5 ttl=55 time=286.8 ms
64 bytes from 80.190.233.45: icmp_seq=6 ttl=55 time=214.3 ms
64 bytes from 80.190.233.45: icmp_seq=7 ttl=55 time=121.9 ms
64 bytes from 80.190.233.45: icmp_seq=8 ttl=55 time=208.7 ms
64 bytes from 80.190.233.45: icmp_seq=9 ttl=55 time=235.4 ms
64 bytes from 80.190.233.45: icmp_seq=10 ttl=55 time=205.3 ms
64 bytes from 80.190.233.45: icmp_seq=11 ttl=55 time=132.6 ms
64 bytes from 80.190.233.45: icmp_seq=12 ttl=55 time=213.3 ms
64 bytes from 80.190.233.45: icmp_seq=13 ttl=55 time=95.3 ms
64 bytes from 80.190.233.45: icmp_seq=14 ttl=55 time=219.1 ms
64 bytes from 80.190.233.45: icmp_seq=15 ttl=55 time=167.6 ms
64 bytes from 80.190.233.45: icmp_seq=16 ttl=55 time=161.3 ms
64 bytes from 80.190.233.45: icmp_seq=17 ttl=55 time=98.9 ms
64 bytes from 80.190.233.45: icmp_seq=18 ttl=55 time=102.3 ms
64 bytes from 80.190.233.45: icmp_seq=19 ttl=55 time=118.9 ms

--- www.apachefriends.org ping statistics ---
20 packets transmitted, 20 packets received, 0% packet loss
round-trip min/avg/max = 95.3/190.4/352.0 ms


dig apachefriends.org mx
Code: Select all
root@fuchx:~# dig apachefriends.org mx
bash: dig: command not found




Ah dig =
Diese Programmpaket zählt zu den HTTP-basierten Indizierern und arbeitet sich rekursiv
durch einen oder mehrere WWW-Server. Zur Erhöhung der Trefferquote lassen sich bei
ht://Dig [m] eigene, zusätzliche META-Tags in die HTML-Seiten integrieren, die dann entsprechend
in die Datenbank aufgenommen werden (siehe ‘Metainformationen’). ht://Dig liegt
als Quelltext vor und ist unter den Rahmenbedingungen der GNU Public License (GPL) frei
verfügbar.

Okay geschnallt, auf meinem anderen server funzt es!!! ABer das hilft nun nicht wirklich weiter. :(
=:Stimmt es, daß die Arbeit am Computer dumm macht?" - "Sie haben nichts zu befürchten. Computer können einen wahnsinnig machen, aber nicht dumm. :=
User avatar
brali
 
Posts: 35
Joined: 23. June 2003 19:20
Location: Nrw / Köln

Postby Oswald » 29. October 2003 19:40

Neee.. das ist ht://dig. dig ist was anderes. Egal. Der ping reicht auch schon.

Verleich mal die /etc/sendmail.cf oder /etc/mail/sendmail.cf (weiss jetzt nicht aus dem Kopf wo die bei Debian liegt) mit den sendmail.cf-Dateien von Deinen anderen Rechner.

Ich vermute stark das die sendmail-Konfiguration nicht richtig ist.

Zum Vergleichen der Dateien am einfachsten diff nehmen. Zumindest sieht Du damit schnell ob es Unterschiede gibt.

Ich mach mich jetzt auf den Heimweg und bin erst später wieder im Forum. Neue XAMPP-Version basteln ist angesagt. ;)

Lieben Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby brali » 29. October 2003 21:23

Hi,

also ich es kontrolliert!
habe sendmail ncohens komplett runter und neu drauf!
nichts hat es geholfen.

ich geh am stock!

ich habe keinen plan was das soll was mache ich falsch!!?
=:Stimmt es, daß die Arbeit am Computer dumm macht?" - "Sie haben nichts zu befürchten. Computer können einen wahnsinnig machen, aber nicht dumm. :=
User avatar
brali
 
Posts: 35
Joined: 23. June 2003 19:20
Location: Nrw / Köln

Postby Oswald » 30. October 2003 12:21

Hmm. sendmail zu konfigurieren ist wirklich nicht einfach. Apache ist super einfach dagegen. Gibt es für Debian da nicht irgendwelche Anleitungen?
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Shoukri » 30. October 2003 14:08

Kai Seidler wrote:Hmm. sendmail zu konfigurieren ist wirklich nicht einfach. Apache ist super einfach dagegen. Gibt es für Debian da nicht irgendwelche Anleitungen?


http://wwwhomes.uni-bielefeld.de/schopp ... howto.html <- ist sowas in der art ...
User avatar
Shoukri
 
Posts: 76
Joined: 29. October 2003 00:25

Postby Kristian Marcroft » 30. October 2003 14:35

Kai Seidler wrote:Hmm. sendmail zu konfigurieren ist wirklich nicht einfach. Apache ist super einfach dagegen. Gibt es für Debian da nicht irgendwelche Anleitungen?

Hi,

eine Sammelung an Howtos findet man mittlerweile unter:
http://www.debianhowto.de
weitere Nützliche HowTos findet man auch im www.rootforum.de
unter der Rubrik "MTA's"

Dort einfach Foren Suche verwenden.. :)
So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby brali » 30. October 2003 16:48

big Thx an euch drei,

werde mich mal das howto duchlesen und infos hier posten.

greetz brali,
der solange mal auf eine andere maschine mit funktionierendem Sendmail gestiegen ist!
=:Stimmt es, daß die Arbeit am Computer dumm macht?" - "Sie haben nichts zu befürchten. Computer können einen wahnsinnig machen, aber nicht dumm. :=
User avatar
brali
 
Posts: 35
Joined: 23. June 2003 19:20
Location: Nrw / Köln


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest