Problem mit Xampp-Umleitung

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Problem mit Xampp-Umleitung

Postby Weissbierwaldi » 14. June 2008 19:08

Hallo

stehe gerade vor einem kleinen Problem ...

Habe auf meinem Server Xampp installiert und für meine Domains eingerichtet.

Soweit funktioniert alles ...

Nur wenn ich auf die Hauptdomain zugreifen will (also domain.de), werde ich in das xampp Verzeichniss geschickt. Ich hab aber ne eigene index.html erstellt die keine Umleitung dadrauf enthält.
Wenn ich die Domain mit www.domain.de aufrufe dann geht alles ...

Ich hab schon alles durchgeschaut nur weiß ich langsam nicht mehr weiter.
Sollte doch kein allzugroßes Problem sein ... der rest läuft ja schon einwandfrei.

Danke schonmal
Weissbierwaldi
 
Posts: 17
Joined: 14. December 2005 15:15

Postby deepsurfer » 14. June 2008 22:23

- Wie hast du die Namenszuweisung in XAMPP realisiert ?

Hört sich so an das Du VHOST benutzt aber den Eintrag
"domain.de" ohne
ServerAlias www.domain.de
verwendest, denn dann werden subdomains anfragen nicht beantwortet.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Weissbierwaldi » 14. June 2008 22:45

Soll ja auch mit und ohne www erreichbar sein.
Wurde ja nicht ins normale xampp Verzeichniss geschickt, sondern das lag dann schon im Ordner der Domain. Als ich den dann angelegt hatte und ne eigene index.html angelegt hatte wurde die auch angezeigt.

Hier die Config:
Code: Select all
<VirtualHost *:80>
   ServerName   www.domain.de:80
   ServerAlias  domain.de
   UseCanonicalName Off
   DocumentRoot /opt/lampp/htdocs/domain.de/htdocs
   CustomLog  /opt/lampp/htdocs/domain.de/logs/access_log common
   ErrorLog   /opt/lampp/htdocs/domain.de/logs/error_log

   ScriptAlias  /cgi-bin/ /opt/lampp/htdocs/domain.de/cgi-bin/
   <IfModule mod_ssl.c>
      SSLEngine off
   </IfModule>
   <Directory /opt/lampp/htdocs/domain.de/htdocs>
   <IfModule mod_perl.c>
   <Files ~ (\.pl$)>
      SetHandler perl-script
      PerlHandler ModPerl::Registry
      Options ExecCGI
      allow from all
      PerlSendHeader On
   </Files>
   </IfModule>
   <IfModule sapi_apache2.c>
      php_admin_flag engine on
      php_admin_flag safe_mode on
      php_admin_value open_basedir "/opt/lampp/htdocs/domain.de/htdocs:/tmp"
   </IfModule>
   <IfModule mod_php5.c>
      php_admin_flag engine on
      php_admin_flag safe_mode on
      php_admin_value open_basedir "/opt/lampp/htdocs/domain.de/htdocs:/tmp"
   </IfModule>
      Options -Includes +ExecCGI
   </Directory>
</VirtualHost>
Weissbierwaldi
 
Posts: 17
Joined: 14. December 2005 15:15

Postby Weissbierwaldi » 16. June 2008 07:54

Keiner eine Idee warum das nicht geht???

Wo kann ich denn die normale Definition ändern, wenn man z.B. direkt die Ip eingibt.

Ich werd halt nur in das /xampp/ Verzeichniss umgeleitet, wenn ich die Domain ohne www angebe.
Eigentlich wird man ja über die index.html im root-Verzeichniss der Domain umgeleitet.
Aber auch wenn ich diese umbennene, lande ich in dem Verzeichniss ...
Weissbierwaldi
 
Posts: 17
Joined: 14. December 2005 15:15

Postby Weissbierwaldi » 16. June 2008 20:37

Wies scheint gehts jetzt ...
Hab bei meinem Domain-Provider die DNS-Einstellungen der Domain geändert.
Weissbierwaldi
 
Posts: 17
Joined: 14. December 2005 15:15


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests