Fehler Bei Update von 1.2 >> 1.3 (MySQL)

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Fehler Bei Update von 1.2 >> 1.3 (MySQL)

Postby brali » 27. October 2003 18:17

Hallo zusammen,

nach dem Upgrade meiner Linuxlisten heute habe ich ein problem auf einer Kiste.

Bei starten von Xampp sagt er mir folgende fehlermeldung bei MySQL:

Code: Select all
 /opt/lampp/bin/mysqld_safe: line 339:   535 Bus error               $NOHUP_NICENESS $ledir/$MYSQLD $defaults --
basedir=$MY_BASEDIR_VERSION --datadir=$DATADIR $USER_OPTION --pid-file=$pid_file --skip-locking >>$err_log 2>&1


WO liegt das Prob ich finde es nicht!

PS: Kein zugriff über PHPmy Admin möglich weil er keine verbindung akzeptiert.

Die anderen Maschinen laufen ohnen Probs.

Greez Brali.
=:Stimmt es, daß die Arbeit am Computer dumm macht?" - "Sie haben nichts zu befürchten. Computer können einen wahnsinnig machen, aber nicht dumm. :=
User avatar
brali
 
Posts: 35
Joined: 23. June 2003 19:20
Location: Nrw / Köln

einen fehler habe ich gefunden...

Postby brali » 27. October 2003 18:42

mir fehlt die
mysql.sock im Verzeichnis (/opt/lampp/var/mysql/ )

Warum ist sie nach dem update nicht mehr da?
und die frage, wie komme ich wieder dran!?!?!?
=:Stimmt es, daß die Arbeit am Computer dumm macht?" - "Sie haben nichts zu befürchten. Computer können einen wahnsinnig machen, aber nicht dumm. :=
User avatar
brali
 
Posts: 35
Joined: 23. June 2003 19:20
Location: Nrw / Köln

Postby Kristian Marcroft » 27. October 2003 19:10

Hi,

die mysql.sock sollte nur da sein, wenn der mysql server auch läuft.
Bekommst du sonst noch Fehlermeldungen?
Was sagt das log?
evtl. steht da genaueres drin?
Hast hoffentlich vor dem Update auch ne DB Sicherung gemacht? (wehe nicht *g*)


So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

hehe

Postby brali » 27. October 2003 19:20

Also,

an die DB's komme ich nioch ran, allerdings nur übern "MC"
Und ans Backuppen habe ich erst garnicht gedacht nachdem es auf den anderen 3 Kisten eben 100% geklappt hat.


Ich poste mal die Fehlermeldungen von Linux (putty)
Und ich poste mal die des Apachen beim webaufruf.


webserver
Code: Select all
phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in config.inc.php and make sure that they correspond to the information given by the administrator of the MySQL server.

Error

MySQL said:


#2002 - Can't connect to local MySQL server through socket '/opt/lampp/var/mysql/mysql.sock' (2)
[Documentation]



Linux
Code: Select all
 /opt/lampp/lampp start
Starting XAMPP for Linux 1.3...
LAMPP: LAMPP-Apache is already running.
LAMPP: Starting MySQL...
LAMPP: LAMPP-ProFTPD is already running.
XAMPP for Linux started.
root@fuchx:~# /opt/lampp/bin/mysqld_safe: line 339:   376 Bus error               $NOHUP_NICENESS $ledir/$MYSQLD $defaults --basedir=$MY_BASEDIR_VERSION --datadir=$DATADIR $USER_OPTION --pid-file=$pid_file --skip-locking >>$err_log 2>&1

ansonsten kann ich noch das errorlog von mysql auflisten:

mysql
Code: Select all
fuchx.err           [B---]  4 L:[148+59 207/266] *(7311/8535b)= 2  50 0x32
030921 17:12:31  /opt/lampp/sbin/mysqld: Shutdown Complete

030921 17:12:31  mysqld ended

030921 17:13:52  mysqld started
/opt/lampp/sbin/mysqld: ready for connections.
Version: '4.0.14-log'  socket: '/opt/lampp/var/mysql/mysql.sock'  port: 3306
030927 16:31:35  /opt/lampp/sbin/mysqld: Normal shutdown

030927 16:31:35  /opt/lampp/sbin/mysqld: Shutdown Complete

030927 16:31:35  mysqld ended

030927 16:33:04  mysqld started
/opt/lampp/sbin/mysqld: ready for connections.
Version: '4.0.14-log'  socket: '/opt/lampp/var/mysql/mysql.sock'  port: 3306
030927 18:44:59  /opt/lampp/sbin/mysqld: Normal shutdown

030927 18:44:59  /opt/lampp/sbin/mysqld: Shutdown Complete

030927 18:45:00  mysqld ended

030928 14:05:55  mysqld started
/opt/lampp/sbin/mysqld: ready for connections.
Version: '4.0.14-log'  socket: '/opt/lampp/var/mysql/mysql.sock'  port: 3306
030929 06:14:33  mysqld started
/opt/lampp/sbin/mysqld: ready for connections.
Version: '4.0.14-log'  socket: '/opt/lampp/var/mysql/mysql.sock'  port: 3306
031006 06:47:07  mysqld started
/opt/lampp/sbin/mysqld: ready for connections.
Version: '4.0.14-log'  socket: '/opt/lampp/var/mysql/mysql.sock'  port: 3306
031008 19:46:38  mysqld started
/opt/lampp/sbin/mysqld: ready for connections.
Version: '4.0.14-log'  socket: '/opt/lampp/var/mysql/mysql.sock'  port: 3306
031009 06:11:32  mysqld started
/opt/lampp/sbin/mysqld: ready for connections.
Version: '4.0.14-log'  socket: '/opt/lampp/var/mysql/mysql.sock'  port: 3306
031012 14:03:46  mysqld started
/opt/lampp/sbin/mysqld: ready for connections.
Version: '4.0.14-log'  socket: '/opt/lampp/var/mysql/mysql.sock'  port: 3306
031015 18:21:04  mysqld started
/opt/lampp/sbin/mysqld: ready for connections.
Version: '4.0.14-log'  socket: '/opt/lampp/var/mysql/mysql.sock'  port: 3306
031019 21:46:24  /opt/lampp/sbin/mysqld: Normal shutdown

031019 21:46:24  /opt/lampp/sbin/mysqld: Shutdown Complete

031019 21:46:24  mysqld ended

031019 21:47:49  mysqld started
/opt/lampp/sbin/mysqld: ready for connections.
Version: '4.0.14-log'  socket: '/opt/lampp/var/mysql/mysql.sock'  port: 3306
031027  9:50:39  /opt/lampp/sbin/mysqld: Normal shutdown

031027  9:50:40  /opt/lampp/sbin/mysqld: Shutdown Complete

031027 09:50:40  mysqld ended

031027 09:52:25  mysqld started


Den rest habe ich raus gelassen, ist eh schon soviel code zeuch.

hoffe es kann Dir und mir weiterhelfen
=:Stimmt es, daß die Arbeit am Computer dumm macht?" - "Sie haben nichts zu befürchten. Computer können einen wahnsinnig machen, aber nicht dumm. :=
User avatar
brali
 
Posts: 35
Joined: 23. June 2003 19:20
Location: Nrw / Köln

Postby Kristian Marcroft » 27. October 2003 20:52

Hi,

bitte prüfe mal folgendes...

gibt es diese datei?
/opt/lampp/var/mysql/<hostname>.pid ??
existiert denn nun eine mysql.sock datei?

Irgendwie sagt mir der Fehler nicht viel...
ausser, das er evtl. Probs mit ner PID oder ner Sock hat, die schon da ist, obwohl keine da sein darf?

Evtl. kann Kai dir da eher weiter helfen? Ich werde ihn mal auf diesen Thread aufmerksam machen.
So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Guten morgen

Postby brali » 28. October 2003 05:36

Guten morgen,

also ich habe keine : /opt/lampp/var/mysql/<hostname>.pid :
und es existiert keine mysql.sock datei.
einzig die proftpd.pid ist da.


wäre schön wenn Kai mir da was unter die arme greifen würde.

greetz chris
=:Stimmt es, daß die Arbeit am Computer dumm macht?" - "Sie haben nichts zu befürchten. Computer können einen wahnsinnig machen, aber nicht dumm. :=
User avatar
brali
 
Posts: 35
Joined: 23. June 2003 19:20
Location: Nrw / Köln

Postby Oswald » 28. October 2003 10:30

Hallo brali!

Okay. Also durch das Updaten können keine Daten verloren gehen. Also da schon mal keine Angst.

Mach mal bitte folgendes:

/opt/lampp/lampp stop

Dann guck mal ins /opt/lampp/var/mysql/-Verzeichnis. Was liegt alles in dem Verzeichnis? Bitte hier mal posten.

Danach:

/opt/lampp/lampp start

Wieder ins /opt/lampp/var/mysql/-Verzeichnis. Was liegt jetzt alles in dem Verzeichnis? Bitte wieder hier posten.

Dann noch die letzten 10 Zeilen (sag ich mal so) von der .err-Datei, die in dem Verzeichnis liegt.

Frage: Hast Du ein root-Passwort für die MySQL-Datenbank gesetzt? Weißt Du es noch? (Nicht hier posten, nur 'ne Frage für die nächsten Schritte!;) )

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby brali » 28. October 2003 10:56

Hi Kai,

also folgendes
in dem verzeichnis beim stop liegen folgende Dateien:

Code: Select all
/mysql
/phpmyadmin
/test
fuchx-bin.001
fuchx-bin.002
fuchx-bin.003
fuchx-bin.004
fuchx-bin.005
fuchx-bin.006
fuchx-bin.007
fuchx-bin.008
fuchx-bin.009
fuchx-bin.010
fuchx-bin.011
fuchx-bin.012
..bis       .023

fuchx-bin.index
fuchx err



und nach dem Start!
Code: Select all
/mysql
/phpmyadmin
/test
fuchx-bin.001
fuchx-bin.002
fuchx-bin.003
fuchx-bin.004
fuchx-bin.005
fuchx-bin.006
fuchx-bin.007
fuchx-bin.008
fuchx-bin.009
fuchx-bin.010
fuchx-bin.011
fuchx-bin.012
..bis       .023

fuchx-bin.index
fuchx err



Und im hier nochmal der errorlog:
Code: Select all
31027 18:18:42  mysqld ended

031027 18:18:44  mysqld started
031027 18:18:44  mysqld ended

031027 18:18:45  mysqld started
031027 18:18:45  mysqld ended

031027 18:18:47  mysqld started
031027 18:18:47  mysqld ended

031027 18:18:48  mysqld started
031027 18:18:48  mysqld ended

031027 18:19:21  mysqld started
031027 18:19:21  mysqld ended

031027 18:44:28  mysqld started
031027 18:44:28  mysqld ended

031027 19:14:26  mysqld started
031027 19:14:26  mysqld ended


Und Root PW ist nicht gesetzt!

greetz chris
=:Stimmt es, daß die Arbeit am Computer dumm macht?" - "Sie haben nichts zu befürchten. Computer können einen wahnsinnig machen, aber nicht dumm. :=
User avatar
brali
 
Posts: 35
Joined: 23. June 2003 19:20
Location: Nrw / Köln

Postby Oswald » 28. October 2003 11:03

Danke brali!

Hmm. er legt die mysql.sock tatsächlich nicht an. Das kann eigentlich nur ein Zugriffsrecht-Problem sein.

Was gibt ls -ld /opt/lampp/var/mysql aus?

Gibt der Befehl su -c "touch /opt/lampp/var/mysql/1" nobody irgendwas aus?

Lieben Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

so

Postby brali » 28. October 2003 11:10

Also,

der befehl: ls -ld /opt/lampp/var/mysql

Code: Select all
ls -lf /opt/lampp/var/mysql
.              fuchx-bin.index  buha           fuchx-bin.013  fuchx-bin.018
..             fuchx-bin.002    fuchx-bin.008  fuchx-bin.014  fuchx-bin.019
mysql          fuchx-bin.003    test           contenido      fuchx-bin.020
phpmyadmin     fuchx-bin.004    fuchx-bin.009  content        fuchx-bin.021
fuchx.err      fuchx-bin.005    fuchx-bin.010  fuchx-bin.015  fuchx-bin.022
list           fuchx-bin.006    fuchx-bin.011  fuchx-bin.016  Michel
fuchx-bin.001  fuchx-bin.007    fuchx-bin.012  fuchx-bin.017  fuchx-bin.023


und der befehl:
su -c "touch /opt/lampp/var/mysql/1" nobody
gibt garnichts aus.

Aber warum Zugriffrechte!? Die wurden doch nicht geändert!

gruß aus Köln
=:Stimmt es, daß die Arbeit am Computer dumm macht?" - "Sie haben nichts zu befürchten. Computer können einen wahnsinnig machen, aber nicht dumm. :=
User avatar
brali
 
Posts: 35
Joined: 23. June 2003 19:20
Location: Nrw / Köln

Postby Oswald » 28. October 2003 11:16

"ls -ld" bitte und nicht "ls -lf". ;)

Zuriffsrechte: Nun irgendwo muss der Fehler liegen und im Moment weiß ich noch nichts besseres. ;)

Das der su-Befehl nichts ausgibt ist richtig. Das ist schon mal ein gutes Zeichen.

Weiter geht's: Was gibt echo "show databases" | /opt/lampp/bin/mysql aus?

Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby brali » 28. October 2003 11:19

Sorry war mein fehler.
richtig ist natürlich:
Code: Select all
root@fuchx:~# ls -ld /opt/lampp/var/mysql
drwxrwxr-x   10 nobody   root         4096 Oct 27 09:50 /opt/lampp/var/mysql



Also bei der ausgabe escheint dann ganz einfach:

Code: Select all
root@fuchx:~# echo "show databases" | /opt/lampp/bin/mysql
ERROR 2002: Can't connect to local MySQL server through socket '/opt/lampp/var/mysql/mysql.sock' (2)




greetz
brali
=:Stimmt es, daß die Arbeit am Computer dumm macht?" - "Sie haben nichts zu befürchten. Computer können einen wahnsinnig machen, aber nicht dumm. :=
User avatar
brali
 
Posts: 35
Joined: 23. June 2003 19:20
Location: Nrw / Köln

Postby Oswald » 28. October 2003 11:54

Sehr seltsam! :(

Ruf bitte noch mal /opt/lampp/lampp start auf und poste noch mal die letzten Zeilen der .err-Datei. Da muss wenigstens etwas zum Starten von MySQL stehen.

Gibt der ..../lampp start irgendwas ungewöhnliches aus?
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby brali » 28. October 2003 12:13

die err. enthält diese daten:
Code: Select all
031027 18:18:47  mysqld started
031027 18:18:47  mysqld ended

031027 18:18:48  mysqld started
031027 18:18:48  mysqld ended

031027 18:19:21  mysqld started
031027 18:19:21  mysqld ended

031027 18:44:28  mysqld started
031027 18:44:28  mysqld ended

031027 19:14:26  mysqld started
031027 19:14:26  mysqld ended

031028 10:52:50  mysqld started
031028 10:52:50  mysqld ended

031028 12:09:35  mysqld started
031028 12:09:35  mysqld ended




Also beim Start von Wampp kommt folgende fehlermeldung:

Code: Select all
root@fuchx:~# /opt/lampp/lampp start
Starting XAMPP for Linux 1.3...
LAMPP: LAMPP-Apache is already running.
LAMPP: Starting MySQL...
/opt/lampp/bin/mysqld_safe: line 339:  1058 Bus error               $NOHUP_NICENESS $ledir/$MYSQLD $defaults --basedir=$MY_BASEDIR_VERSION --datadir=$DATADIR $USER_OPTION --pid-file=$pid_file --skip-locking >>$err_log 2>&1
LAMPP: LAMPP-ProFTPD is already running.
XAMPP for Linux started.


Wobei die codenummer vom Bus error sich ständig erhöht.

mehrere Angaben habe ich nicht!
=:Stimmt es, daß die Arbeit am Computer dumm macht?" - "Sie haben nichts zu befürchten. Computer können einen wahnsinnig machen, aber nicht dumm. :=
User avatar
brali
 
Posts: 35
Joined: 23. June 2003 19:20
Location: Nrw / Köln

Postby Oswald » 28. October 2003 13:00

Hm... ich bin ein bisschen ratlos.. ;)

Welche Linux-Distribution benutzt Du? Vorher lief XAMPP schon mal auf dem Rechner?

Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Next

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest