CGI-Rechte-Problem: Symlink-Aufruf geht nicht

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Postby Nobbie » 09. April 2008 15:16

>You don't have permission to access /vas-cgi/status.cgi on this server.

Was ist dann dieses komische "/vas-cgi" da in dem Pfad? Das sieht nach verkorkstem Symbol Link aus.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Postby Mufasa » 09. April 2008 15:31

nein das war mal vas-cgi.... hab jetzt die ganzen verzeichnisse und so umbenannt in xyz-cgi.....

Die Fehlermeldung jetzt ist auch so identisch nur halt eben mit xyz-cgi.....
Mufasa
 
Posts: 28
Joined: 20. February 2008 15:32

Postby Mufasa » 09. April 2008 15:49

also wie gesagt nach wie vor das Problem, das Symlinks nicht funktionieren. Über die Shell geht der Aufruf, daher nehm ich mal an, dass das ein Konfigurationsproblem in der httpd.conf ist.... wäre wirklich suuuuper wenn da jemand was sagen könnte.....
Mufasa
 
Posts: 28
Joined: 20. February 2008 15:32

Postby Mufasa » 09. April 2008 16:11

Ich bin die ganze Zeit am rumprobieren.... will jetzt hier auch nicht zuspammen.... aber wenn jemandem auch nur eine Kleinigkeit einfällt, bitte melden.... vielleicht ist es ja grad das....

hier auch mal meine vollständige httpd.conf
http://uploaded.to/?id=y0sax9
Mufasa
 
Posts: 28
Joined: 20. February 2008 15:32

Postby Mufasa » 13. April 2008 12:44

Leute probiert das bitte mal aus.... ich hab das jetzt auf einem ganz anderen Rechner ganz simpel getestet.... und es kommt wieder 403 Forbidden

Probiert mal ein in /opt/lampp/cgi-bin liegendes und funktionierendes Script in einen Unterordner zu verschieben (z.B. /opt/lampp/cgi-bin/test) und dann darauf ein Symlink in den übergeordneten Ordner cgi-bin zu setzen. Dann den Symlink aufrufen.....

Hoffe einer kriegt das so zum Laufen und kann mir sagen wie..... Würde mich über Eure Hilfe wirklich sehr freuen!
Mufasa
 
Posts: 28
Joined: 20. February 2008 15:32

Gelöst: Funktioniert!

Postby Mufasa » 15. April 2008 07:52

Für alle die später mal auf das gleiche Problem stoßen sollten:

In der httpd.conf muss

<Directory /var/www/localhost/cgi-bin>

Options +FollowSymLinks

</Directory>

geändert werden.

Da steht normalerweise nur
Options None

:-)
Mufasa
 
Posts: 28
Joined: 20. February 2008 15:32

Geht doch nur so halb...........

Postby Mufasa » 15. April 2008 10:34

JETZT werd ich richtig verrückt!!!!!!!!!!!!!!!!!! :twisted: :twisted: :twisted:

Wie oben beschrieben wenn man das so macht dann funktionierts im Apache Hauptverzeichnis /cgi-bin
Aber sobald ich noch einen anderen ScriptAlias habe und das ganze genau so dort mache gibt der mir Internal Server Error
Irgendjemand mit einem Vorschlag?
Mufasa
 
Posts: 28
Joined: 20. February 2008 15:32

Postby Mufasa » 15. April 2008 10:54

Wenn das am Ende doch noch irgendeiner lesen sollte....

schaut Euch bitte mal diese Seite an

http://archive.apache.org/gnats/indexmod_alias.html

Nummer 2753 "Don't support for symbolic links in Alias and Script Alias directives"


Genau das ist mein Problem. Ich will einen Symlink in einem Script-Alias-Verzeichnis zum Laufen bringen.

Heißt das es geht gar nicht??? Oder kann man das doch irgendwie umgehen??


Würde mich über Antwort sehr freuen!
Mufasa
 
Posts: 28
Joined: 20. February 2008 15:32

Postby Nobbie » 15. April 2008 16:20

>Heißt das es geht gar nicht???

Ja, vor 10 Jahren(!) war das mal ein Bug.
Nobbie
 
Posts: 8772
Joined: 09. March 2008 13:04

Postby Mufasa » 15. April 2008 16:40

Ok..... und heute?

Kannst Du das mal so bei Dir mal probieren ob es geht oder nicht?

Ich probiers grad auch mit dem BOA-Webserver.... da kommt aber jetzt Error 502.

Also wenn es mit einem von den beiden geht würde mir reichen..... hauptsache irgendwie.....

:-(
Mufasa
 
Posts: 28
Joined: 20. February 2008 15:32

Postby gunni49 » 12. May 2008 23:50

Hi Mufasa,
Deine httpd.conf hat wenig mit der ursprünglichen xampp apache config zu tun. Ich würd erst die original httpd.conf nehmen und dort Schritt für Schritte Deine Änderungen einfügen.

Nicht vergessen: Options Indexes FollowSymLinks ExecCGI Includes muss geändert werden zu
Options Indexes FollowSymLinks Includes ExecCGI. Dann müssen cgi-Skripte funktionieren!

Gunni
gunni49
 
Posts: 13
Joined: 09. March 2008 06:46

Previous

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests