Webalizer

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Webalizer

Postby Morpheus » 12. February 2003 16:26

Hi
Wie kann ich den Webalizer starten? Was muss ich tun, das die Logfiles ausgewertet werden?
Morph
Morpheus
 
Posts: 218
Joined: 17. January 2003 20:58

Postby Oswald » 12. February 2003 17:12

Moin Morpheus!

Einfach /opt/lampp/bin/webalizer aufrufen. Unter http://localhost/webalizer findest Du dann die aktuellen Statistiken.

Viel Spaß,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Morpheus » 12. February 2003 19:55

Das Problem ist nur, es sind nur die Daten zu erkennen, da waren als der Server zusammengebaut wurde.
Alle neueren Daten werden einfach ignoriert.
Wie kann ich es denn einstellen, das die Logfiles bearbeitet werden?
Morph
Morpheus
 
Posts: 218
Joined: 17. January 2003 20:58

Postby Oswald » 12. February 2003 20:00

Ah, hast Du die Logfdatei geändert? Ok, dann ist klar das Webalizer sie nicht findet.

Du kannst die Logdatei in etc/webalizer.conf einstellen. Sollte leicht zu finden sein.

Wenn Du mehrere Logdateien hast und mehrere Statistiken brauchst, dann musst Du in der Kommandozeile beim webalizer entsprechende Optionen angeben (Logdatei + wo sollen die Statistiken erstellt werden). Einfach mal webalizer -h aufrufen.

Viele Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Morpheus » 12. February 2003 20:10

Hi
Ich habe die webalizer.conf geändert.
Nur der Aufruf vom Webalizer funktioniert nicht, es passiert einfach gar nichts, ebenso funktioniert webalizer -h nicht. (Ist doch in /opt/lampp/bin)

Morph
Morpheus
 
Posts: 218
Joined: 17. January 2003 20:58

Postby Oswald » 12. February 2003 20:18

Du hast /opt/lampp/bin/webalizer -h aufgerufen und es passiert rein gar nicht? Versteh ich das richtig? Keine Fehlermeldung? Nichts?

Kannst Du mal bei Dir den Befehl strace aufrufen um zu sehen ob der installiert ist? (Hat jetzt nichts mit Webalizer zu tun, aber den Befehl könnte man für die Fehlersuche gebrauchen.)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Morpheus » 12. February 2003 21:40

Über den Befehl und die Konfigurationsdatei kann ich es durchführen, sollte das aber nicht irgendwie automatisch laufen?
Morph
Morpheus
 
Posts: 218
Joined: 17. January 2003 20:58


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 7 guests