Lampp mit Vhosts unter Ubuntu bitte um hilfe

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Lampp mit Vhosts unter Ubuntu bitte um hilfe

Postby Tweek » 22. February 2008 15:30

Hallo Leute!

Also ich hab folgendes Problem.

Ich versuche mich gerade mit vhosts, nur irgendwie will das nicht so recht klappen.

Ich habe 1 Domäne von dot.tk und würde die gerne einem Speziellen ordner zuweisen.

Aber am besten seht euch mal die Config an dann sollte es verständlicher sein.

Code: Select all
<VirtualHost 127.0.0.1:80>
    ServerAdmin n00by@tele2.at
    DocumentRoot /home/server/Space/
    ServerName http://eistee.no-ip.com
    ErrorLog logs/dummy-host2.example.com-error_log
    CustomLog logs/dummy-host2.example.com-access_log common
</VirtualHost>


<VirtualHost 127.0.0.1:80>
    ServerAdmin n00by@tele2.at
    DocumentRoot /home/server/Space/upload/
    ServerName www.pixx-upload.tk
    ServerAlias www.pixx-upload.tk/
    Options Indexes
    ErrorLog logs/dummy-host2.example.com-error_log
    CustomLog logs/dummy-host2.example.com-access_log common
</VirtualHost>


das ist meine vhots datei.

Das Problem ist, das ich zwar bei der zweiten Adresse in den Ordner upload komme, aber index oder dergleichen nciht funktioniert. Desweiteren kommt es auch vor das ich mit der www.pixx-upload.tk auch auf die http://eistee.no-ip.com seite komme, was ich ja eigentlich vermeinden will.

die host Einträge sehen wie folgt aus:

127.0.0.1 localhost
127.0.1.1 server
192.168.0.105 FAMILIE
127.0.0.1 eistee.no-ip.com
127.0.0.1 www.pixx-upload.tk
#192.168.1.100 eistee.no-ip.com
#192.168.1.100 www.pixx-upload.tk


# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts


das was ich eigentlich erreichen will ist, das wenn jemand bei pixx-upload ein bild uploadet, auch die domäne darin steckt beim zugriff auf das Bild.
Wenn ich es mit der eistee mache, funktioniert das ohne probleme.

Doch mit

http://www.pixx-upload.tk/getimg.php?img=Affe2.jpg

komme ich wieder auf die indexseite und das bild wird nicht angezeigt.

ich währe echt dankbar wenn mir jemand helfen könnte.

mfg
Tweek
 
Posts: 2
Joined: 18. February 2007 12:37

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests