Auf mehrere Port höhren

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Auf mehrere Port höhren

Postby Oepfel » 22. February 2008 14:57

Tach auch,

hab mal wieder ne Frage da ich nach langem suchen nix gefunden habe:

Habe hinter dem "normalen" Server noch eine Centos5 Kiste zum basteln und ausprobieren stehen. Damit ich von aussen mehrer Verzeichnisse direkt erreichen kann, lasse ich von meinem Router mehrere Ports auf den Bastelrechner routen. Dann habe ich in der httpd.conf nach

Listen: 80 - einfach noch ein:
Listen: 8080

dazugeschrieben und in der httpd-vhost.conf natürlich auch NameVistualHost *:8080 und einenen passenden Vhost eingeschrieben.

Dann Lampp restart, aber ich kann immer nur den 80er Port erreichen. den 8080 weder von aussen noch intern. Habe ich da was falsch eingetragen, oder kann Lampp nur auf einen Port höhren.

Danke für alle Ratschläge.
Oepfel
User avatar
Oepfel
 
Posts: 78
Joined: 10. October 2006 23:16
Location: Wendelstein

Postby Scory » 22. February 2008 15:00

>Habe ich da was falsch eingetragen, oder kann Lampp nur auf einen Port höhren.

Lampp kann nichts hören, weil es kein Programm ist - Du hast es ja immer noch nicht verstanden.

Das Programm, was Du meinst, heißt "Apache" und ja, es kann nur auf einem Port hören. Bzw. via SSL (Protokoll https:) noch auf einem zweiten (Standard ist 443).

Wenn Du auf 80 UND auf 8080 einen Apache haben willst, mußt Du ZWEI Instanzen davon starten. Mit jeweils einer eigenen httpd.conf
Scory
 

Postby Oepfel » 22. February 2008 15:11

Erstmal DANKE für echt schnelle Antwort

Scory wrote:Lampp kann nichts hören, weil es kein Programm ist - Du hast es ja immer noch nicht verstanden.


Verzeih mir den Fehltritt. Wollte mein Problem nur so verständlich wie möglich darstellen.

Scory wrote:Wenn Du auf 80 UND auf 8080 einen Apache haben willst, mußt Du ZWEI Instanzen davon starten. Mit jeweils einer eigenen httpd.conf


Also eine 2. Xampp Installation in ein anderes Verzeichniss mit anderen Ports, bzw. eine 2. Apache.

OK Danke erstmal soweit.
Oepfel
User avatar
Oepfel
 
Posts: 78
Joined: 10. October 2006 23:16
Location: Wendelstein

Postby Wiedmann » 22. February 2008 15:18

Listen: 8080
dazugeschrieben und in der httpd-vhost.conf natürlich auch NameVistualHost *:8080 und einenen passenden Vhost eingeschrieben.
Dann Lampp restart, aber ich kann immer nur den 80er Port erreichen.

Solange deine VHost-Konfiguration nicht falsch ist, funktioniert das. LAss doch einfach mal den VHost weg (also nur das "Listen 8080"), dann solltest du über diesen Port auch auf die normalen XAMPP-Seiten kommen.


den 8080 weder von aussen noch intern.

Könnte natürlich auch ein Firewall Problem sein. Oder steht sogar was im "error_log"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Oepfel » 22. February 2008 15:39

Wiedmann wrote:Könnte natürlich auch ein Firewall Problem sein. Oder steht sogar was im "error_log"?


Und mir fiel es wie Schuppen von den Augen !!!!

Natürlich die bescheuerte Firewall hatte ich ganz vergessen. Port freigegeben und funktioniert 1a.

ERGO: Apache kann auf mehrere Port höhren ;)

DANKE Wiedemann
Oepfel
User avatar
Oepfel
 
Posts: 78
Joined: 10. October 2006 23:16
Location: Wendelstein


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 5 guests