XAMPP "nachträglich" installieren

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP "nachträglich" installieren

Postby fOV » 14. February 2008 13:21

Hallo zusammen,

ich habe mir auf Basis SuSE 10.3 einen Homeserver in den Keller gestellt, welcher bereits
- Fileserver -> Samba
- Proxy -> Squid & SquidGuard ( Töchterchen über Whitelist :D )
- Webserver -> Apache2
- SQL -> MySQL
- "Fernwartung" -> Webmin
- ...
beinhaltet. Der Server läuft rund um die Uhr.

Nun bin ich auf der Suche nach einer Groupware über eGroupware gestolpert und bei dem Versuch diese zu installieren, hänge ich bereits bei php fest. Ich stelle jetzt nicht die Frage nach dem wieso und warum.

Jetzt kommt XAMPP ins Spiel.
XAMPP beinhaltet als Rundumsorglospaket u.a. auch php4 und php5.
Was passiert mit meinem bestehenden Apache2 und MySql, wenn ich XAMPP installiere ?


Gruß Oliver
fOV
 
Posts: 4
Joined: 14. February 2008 12:30

Postby fOV » 14. February 2008 13:55

ich habe mal die Probleme der anderen Hilfesuchenden durchgelesen und bin dabei auf die wahrscheinliche Antwort meiner Frage gestoßen:

Starting XAMPP for Linux 1.6.5a...
XAMPP: Another web server daemon is already running.
XAMPP: Another MySQL daemon is already running.
XAMPP: Another FTP daemon is already running.
XAMPP for Linux started.


Lösung:
entweder meine vorherige Installation von Apache & Co. deinstallieren oder aber zumindest den Dienst disablen.

Gruß
Oliver
fOV
 
Posts: 4
Joined: 14. February 2008 12:30

Postby wmeinhart » 14. February 2008 15:07

du bist auf dem richtigen Weg,

die von suse installierten Apache/Mysql stoppen und beim Systemstart deaktiviern, dann kannst Du die Xampp starten.
User avatar
wmeinhart
 
Posts: 36
Joined: 10. June 2003 19:45
Location: Hamburg

Postby fOV » 15. February 2008 10:35

Cheapau :idea: nach max. 10 min war XAMPP installiert und läuft ohne Fehl und Tadel.
Weitere zwei Stunden später war eGroupware einsatzbereit.

Bisher aber nur auf dem Testsystem mit Suse 11.0 Alpha2
In Webmin den Speicherort der httpd.conf angepaßt und den virtuellen Server neu eingetragen. Und schon war der Apache wieder im Netz verfügbar.

Gruß Oliver

P.S. Super Arbeit XAMPP-Team - Danke !
fOV
 
Posts: 4
Joined: 14. February 2008 12:30


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests