perl geht seit update nicht mehr

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

perl geht seit update nicht mehr

Postby steto123 » 13. February 2008 15:28

Ich habe vorhin das update eingespielt und bekomme nun bei den perl-Programmen Zugriff verweigert. Von der Kommandozeile aber funktionieren sie.

Ist da was an den Konfigurationen geändert worden?

Des Rätsels Lösung
Es war keine Execgi mehr für das CGI-bin gesetzt oder wurde nicht mehr vererbt. Jedenfalls habe ich es explizit für das cgi-bin gesetzt und nun läuft es wieder.


Steffen
steto123
 
Posts: 3
Joined: 21. December 2005 12:55

Postby gustafdd » 14. February 2008 15:43

Das Problem scheint eher an mod_perl zu liegen.
Nach Eintrag von ExecCGI liefen meine Scripte auch nur teilweise. :(
Ohne mod_perl läuft alles wieder palletti (auch ohne ExecCGI). :D
gustafdd
 
Posts: 1
Joined: 14. February 2008 11:44

Postby Gorescore » 15. February 2008 16:09

Selbes Problem hier ...

Bei mir lief Openwebmail nicht mehr.

Folgende Fehlermeldung :

Code: Select all
Software error:

[Thu Feb 14 18:04:40 2008] iconv.pl: Can't locate Text/Iconv.pm in @INC (@INC contains:
/opt/lampp/lib/perl5/5.10.0/i686-linux /opt/lampp/lib/perl5/5.10.0
/opt/lampp/lib/perl5/site_perl/5.10.0/i686-linux /opt/lampp/lib/perl5/site_perl/5.10.0
/opt/lampp/lib/perl5/site_perl/5.8.7 /opt/lampp/lib/perl5/site_perl . /opt/lampp
/opt/openwebmail/cgi-bin/openwebmail) at shares/iconv.pl line 9.


mod_perl ausgeschaltet und es geht wieder ...

btw. wissen die Admins schon "Bescheid" wegen dem bug ?

Marcus ...
Gorescore
 
Posts: 2
Joined: 15. February 2008 16:04

Postby Oswald » 19. February 2008 17:46

Hallo Gorescore!

Danke für den Hinweis! Ich hätte mod_perl nicht aktivieren sollen. (Bisher war es immer dabei, aber nie aktiviert.)

Liebe Grüße
Oswald

PS: Warscheinlich benutzt Du ohne mod_perl das Perl Deines Linux-Systems. Mit mod_perl ist es dann das Perl von XAMPP und dort treten die Probleme mit iconv (was im XAMPP-Perl nicht dabei ist) auf.
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest