apache->VHOST - php session problem - immer neue session_

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

apache->VHOST - php session problem - immer neue session_

Postby bjt » 05. February 2008 16:03

Hallo,

folgende Situation:

Debian Sarge 3.1
Apache 2
PHP 5

Ein Projekt mit session basiertem Login liegt im Verzeichnis /srv/test
ein Virtueller Host zeigt auf dieses verzeichnis http://test.****.de

Der Login bzw. allgemein die Sessions funktionieren einwandfrei.

Dann eines Tages nimmt man das Projekt und legt es auf einen Live Server (selbe konfig wie oben)
Hier richtet man das Projekt ein alles funktioniert.
Das projekt wird während der Live Phase weiterentwicklet.

Dann eines Tages nimmt man das Live Projekt und spiegelt es aufgrund der Änderungen wieder auf den anderen Server (Testumgebung)

Am Projekt selbst wurden nur kleinere Änderungen gemacht die das LoginSystem oder die session aufrufe nicht betrafen.
Man nimmt das Projekt und kopiert es einfach über das alte in der Testumgebung. Man pass wieder die Pfade in der config datei an und will dann
wieder das Projekt über den vhost der testumgebung aufrufen.
Im Firefox funktioniert der Login und die gesamte Session geschichte einwandfrei.

Doch siehe da der IE muckt rum und akzeptiert keine Logins mehr.
nach einigen Stunden grübeln und debugging haben wir festegestellt das der IE bei jedem Aufruf der seite eine neue session id vergibt. (nicht falsch verstehen
ich weiß das das nicht der IE macht)
ABER grundsätzlich ist er der übeltäter. Im Firefox funktioniert es. Jede seite, jedes Post, das nach dem session_start auf der Seite getan wird gibt im Firefox immer
die selbe session id aus, so muss das sein. Der IE zeigt immer wieder ne andere an. Somit kann die Session und somit der Login nicht funktionieren.

Der IE hat bereits auf der Login seite bei jedem aktualisieren eine andere session id.

Da dies nicht das erste mal unser Problem war haben wir jetzt also probiert bis der artzt kam :-)

Zu allerletzt waren wir der Meinung das es wohl am Apache liegt. Wir haben also die VHOST Datei von dem VHOST der Testumgebung gelöscht. Diesen haben
wir sie neu angelegt mit neuem namen und die subdomain nun http://aaaa.*****.de genannt. --> apache neugestartet. domain angabe in der config datei des projektes
angepasst und im IE aufgerufen. Und siehe das Projekt ging mit einmal wieder. Der login funktionierte und wir hatten auf jeder seite die selbe session id.
Im Firefox funktionierte es genauso.

Also dachten wir uns TOLL.
jetzt die Probe. Wir stellen als Servername wieder http://test.****.de ein. apache restart. config anpassung --> IE wieder das session id problem. Firefox weiterhin ohne probleme

Das heißt der apache oder IE sind die übeltäter.
Da wir im IE sämtliches Caching abgeschalten haben sind wir der Meinung das der Apache irgendein problem hat. caching????.

Falls jemand mal das selbe Problem hatte und weiß woran es liegt BITTE BITTE POSTEN. Wir verzweifeln hier sonst.
Auch wenn nicht. Wir sind für jeden Ratschlag dankbar.
bjt
 
Posts: 4
Joined: 05. February 2008 15:40

Postby Scory » 05. February 2008 20:29

Meine Güte, wie kann man mit so einem popeligen Problemchen so eine Welle machen

Wenn es im Firefox funktioniert, kann es ja offensichtlich nicht an Apache liegen (tut es auch nicht).

Es liegt, wie immer und ausnahmslos daran, dass im IE zu restriktive Sicherheitseinstellungen vorliegen, es muss sichergestellt werden, dass für die vorliegenden Domains ohne Einschränkungen Cookies angelegt werden dürfen.

Weil das z.Zt. nicht geht, wird natürlich jedes mal eine neue SessionID vergeben, die wird normalerweise in einem Cookie gespeichert, geht das aber nicht, wird immer wieder eine neue SessionID vergeben. Trivial - wirklich.
Scory
 

Postby bjt » 07. February 2008 09:11

ich mache keine welle sondern das problem nervt einfach.

für alle die etwas ähnliches haben haben sollten.
wir haben immer dann wenn das problem auftrat vhosts mit namen die einen "_" beinhalten angelegt.
z.B
projekt1_test.****.de

Der Fehler mit den Session ids im IE tritt nur bei Domains mit einem "_" im Namen auf. Ich habe auf verschiedenen Seiten gelesen das hier wohl der IE die Seite nicht so vertrauenswürdig findet und deshalb die session immer wieder beendet.

Weiterhin soll es wohl auch eine Beschränkung der Coockie Speicherung im IE geben (max 20 pro Domain) und der Coockie darf max. 4kb groß sein. Das war bei uns allerdings nicht das Problem sondern der Unterstrich
bjt
 
Posts: 4
Joined: 05. February 2008 15:40


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests