Apache Alias funktioniert nicht

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Apache Alias funktioniert nicht

Postby neXon » 04. February 2008 13:20

Hallo Forum!

Hab ein kleines Problemchen. Habe ein Alias in Apache gesetzt, welches auch alles problemlos funktioniert hat. Seitdem ich ein wenig an den Rechten dieses Alias Verzeichnisses rumgedoktert habe, kommt aber: Forbidden You don't have permission to access /wams/ on this server.

Gut hab ich mir gedacht, setzte ich die Rechte des Verzeichnisses halt auf 777 (chmod -R 777 /data/webserver/wams) und dann müsste dürfte es ja funktionieren. Leider erscheint trotzdem die oben genannte Fehlermeldung. An den Rechten dürfte es ja aber nicht liegen, ist besteht doch Vollzugriff für alle!

Auch wenn ich dieses Alias als Document Root setze, erscheint dieselbe Fehlermeldung. Kopiere ich den wams Ordner in den Document Root, kann ich diesen jedoch ohne Probleme aufrufen.

Hier vielleicht noch paar Code Ausschnitte, die weiterhelfen könnten:

Code: Select all
wiens@server:/opt/lampp$ ls -l /data/webserver
insgesamt 4
drwxrwxrwx 3 root root 4096 2008-01-26 13:32 wams


Ausschnitt httpd.conf:
Code: Select all
Alias /wams /data/webserver/wams


Version: [2007-02-18] XAMPP for Linux 1.6 (Apache 2.2.4)

Würde mich freuen, wenn Ihr mir weiterhelfen könntet![/code]
neXon
 
Posts: 3
Joined: 04. February 2008 13:01

Postby Scory » 04. February 2008 13:25

Schau Dir den <directory ...> Block in httpd.conf an, der für das htdocs Verzeichnis (bzw. für den DocumentRoot) die Zugriffsberechtigungen für Apache setzt.

Genau so einen brauchst Du auch für das Verzeichnis /data/webserver/wams - kopiere einfach den ganzen o.g. Block und benenne den Ordner dann um.

Anschließend muss Apache neu gestartet werden.
Scory
 

Postby neXon » 04. February 2008 13:45

Danke.

Hab ich gemacht (mit restart), leider ohne Erfolg.

Code: Select all
<Directory "/data/webserver/wams">
    Options Indexes FollowSymLinks ExecCGI Includes
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>
neXon
 
Posts: 3
Joined: 04. February 2008 13:01

Postby sari42 » 04. February 2008 20:22

hast Du mal
Code: Select all
Alias /wams "/data/webserver/wams/"
 <Directory "/data/webserver/wams">
# Du brauchst 'ne index-Datei und/oder
   Options +Indexes
#...
 </Directory>

versucht?
sari42
 
Posts: 800
Joined: 27. November 2005 18:28

Postby neXon » 09. February 2008 12:28

war auch leider erfolglos. Es hat ja mit meiner vorherigen Konfiguration schon wunderbar funktioniert, hab halt wie gesagt was an den Rechten geändert, aber die müssten ja passen... :?:
neXon
 
Posts: 3
Joined: 04. February 2008 13:01


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest