Autostart unter openSuse 10.3 (10.x)

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Autostart unter openSuse 10.3 (10.x)

Postby logout » 01. January 2008 04:45

Hi euch allen,

erstmal ein gutes neues Jahr!

Und nun zu meinem Anliegen:
Eigentlich habe ich keine Probleme mit dem Autostart!
Ich habe nur viele Einträge gefunden, die sich mit dem Thema befassen und gedacht, da sollte man mal ein Resume ziehen :D

Also, der Autostart unter openSuse 10.3 (eigentlich 10.x) geht wie folgt:
(Per Konsole am besten als root)

vi /etc/init.d/boot.local

Enter drücken und dann a betätigen um Änderungen in der Datei vorzunehmen.
In dieser Datei können nun Autostarts eingetragen werden. Für XAMPP also:

/opt/lampp/lampp start

(Funktioniert auch wenn man beispielsweise nur den proFTP laufen lassen will dann /opt/lampp/lampp startftp - andere XAMPP-Services gehn auch. Es gehen hier auch Sachen, die nix mit XAMPP zu tun haben. Nur keine Gameserver, da diese dann als root gestartet werden und dann kein normaler Benutzer was daran ändern kann)
Dann Escape drücken und :wq eingeben um zu speichern und beenden.


So, nun wenden wir uns dem "Shutdown" (System herunterfahren):

vi /etc/init.d/halt.local

Eingeben und wieder a drücken. Hier werden nun die Befehle eingegeben, um z.B. XAMPP wieder "sauber" zu beenden, wenn der Linuxrechner heruntergefahren wird.

Hier dann

/opt/lampp/lampp stop

Eingeben. Escape drücken, und dann wieder :wq eingeben.

So, das wars. Jetzt sollte bei Systemstart das XAMPP-Paket automatisch starten und beim Herunterfahren automatisch beenden.
logout
 
Posts: 34
Joined: 01. January 2008 04:13

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests

cron