Apache Mod Konfiguration

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Apache Mod Konfiguration

Postby andz » 07. December 2007 20:18

Moinsen.
Ich hab mir die aktuelle xampp Version für Linux geladen.
Da mir bei apache zuviele Module geladen werden, die ich garnicht brauche, hab ich nacheinander Einträge auskommentiert / gelöscht und getestet, ob der Server immernoch funktioniert. Irgendwie funktionierts jetzt aber nicht mehr, und ich weiß nicht welches Modul fehlt.
Die Module die geladen werden:
Code: Select all
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authn_dbm_module modules/mod_authn_dbm.so
LoadModule authn_anon_module modules/mod_authn_anon.so
LoadModule authn_dbd_module modules/mod_authn_dbd.so
LoadModule authn_default_module modules/mod_authn_default.so
LoadModule authz_host_module modules/mod_authz_host.so
LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule authz_dbm_module modules/mod_authz_dbm.so
LoadModule authz_owner_module modules/mod_authz_owner.so
LoadModule authnz_ldap_module modules/mod_authnz_ldap.so
LoadModule authz_default_module modules/mod_authz_default.so
LoadModule auth_basic_module modules/mod_auth_basic.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule file_cache_module modules/mod_file_cache.so
LoadModule cache_module modules/mod_cache.so
LoadModule disk_cache_module modules/mod_disk_cache.so
LoadModule mem_cache_module modules/mod_mem_cache.so
LoadModule include_module modules/mod_include.so
LoadModule deflate_module modules/mod_deflate.so
LoadModule ldap_module modules/mod_ldap.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule expires_module modules/mod_expires.so
LoadModule headers_module modules/mod_headers.so
LoadModule mime_module modules/mod_mime.so
LoadModule dav_module modules/mod_dav.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule dir_module modules/mod_dir.so
LoadModule alias_module modules/mod_alias.so
LoadModule rewrite_module modules/mod_rewrite.so
#LoadModule ssl_module modules/mod_ssl.so


mfg andz
[EDIT]: Falls es was bringt: der angezeigte Fehler:
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
andz
 
Posts: 6
Joined: 07. December 2007 20:15

Postby Scory » 09. December 2007 15:31

Ne, diese Meldung bringt gar nichts. Versuche herauszufinden, ob Apache wenigstens noch ein Logfile schreibt (die Pfadangaben stehen in httpd.conf), aber wenn Apache vorher schon aufgibt, ist wahrscheinlich in Fehler in der httpd.conf. Ich denke nicht, dass ein Modul fehlt.

Als letzte Möglichkeit rufe das Apache Programm nicht via "./lampp start" auf, sondern gehe ins /opt/lampp/apache/bin Verzeichnis (wenn es das gibt - ich bin gerade nicht am Linux Rechner) und starte das Modul "httpd" einfach via Eingabe von "sudo ./httpd" (es muss als root gestartet werden). Möglicherweise liegt httpd in einem anderen Ordner, Du kannst es finden mit dem folgenden Befehl (in einem Terminal):

Code: Select all
find /opt/lampp -name httpd -print


Es sollten beim Starten von httpd dann die Fehlerursachen konkret erscheinen.

Grüße
Scory
Scory
 

Postby andz » 09. December 2007 17:51

Danke schonmal! Ich hab nur Module verändert. Aber ist jetzt auch egal, weil ich mir jetzt einfach Apache normal installiert habe. ;)
andz
 
Posts: 6
Joined: 07. December 2007 20:15


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests