GELÖST! alle projekte Fatal error: Allowed memory size of .

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

GELÖST! alle projekte Fatal error: Allowed memory size of .

Postby atis » 10. November 2007 12:42

Hi!

Habe mit Xampp angefangen und als ich vor ein paar monaten auf linux-sidux umstieg, war lampp mir einfach lieber als die standartlinuxlösung.

Zu erst lief alles wie geschmiert, bis gestern.
Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 106497 bytes) in /opt/lampp/htdocs/mi/index.php on line 33
line 33:
Code: Select all
 require_once( 'includes/joomla.php' );


Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 19456 bytes) in /opt/lampp/htdocs/xoops/class/logger.php on line 144
line 144:
Code: Select all
foreach ( $trace as $step ) {   if ( isset( $step['file'] ) ) { echo $this->sanitizePath( $step['file'] );
                  echo ' (' . $step['line'] . ")\n<br />";
               }               



Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 77824 bytes) in /opt/lampp/htdocs/draugi/index.php on line 189
line 189:
Code: Select all
 $image_size = compute_img_size($picture['pwidth'], $picture['pheight'], $CONFIG['alb_list_thumb_size']);


Und so weiter... bei ungefähr 20 projekten, vorwiegend cms, joomla, elxis, xoops, typo3(habe es apt-get install/remove typo3), phpgallery, phpads.
Alles lief einwandfrei bis ich einmal den linux rechner(512 mb ram) neugestartet habe. Ab da haben alle projekte diesen fehler. Ich kann nicht mehr in phpmyadmin :
Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 116431 bytes) in /opt/lampp/phpmyadmin/index.php on line 36

Ich habe natürlich sofort die php.ini geändert, aber egal wieviel ich memory_limit setze, die fehler bleiben. Bin kurz davor lampp neu zu installieren, ich schrecke noch etwas davor zurück, da ich keine db sicherung durchführen kann und bei fünf fast beendeten projekten währe mackaber die db zu zerstören.

Ich vermute, kann es aber nicht mehr nachvollziehen, dass die typo3 install auf dem serverrechner etwas verändert hat.
Bin für Hinweise echt dankbar. Meine Weisheit ist zu ende. Ich wollte dieses WE eigentlich entspannen.
Last edited by atis on 12. November 2007 14:13, edited 1 time in total.
atis
 
Posts: 4
Joined: 10. November 2007 11:46
Location: Riga

Postby Scory » 10. November 2007 15:02

Das ist nur ein kleines Problem. Du mußt die php.ini modifizieren, die wahrscheinlich in /opt/lampp/etc liegt. Falls Du es nicht genau weißt, lass mal ein Miniscript laufen mit phpinfo()-Aufruf, dort steht sehr weit oben, welche php.ini benutzt wird.

Dort findest Du einen Eintrag memory_limit, der steht per Default auf 8M (= 8 Megabyte). Egal was dort nun steht, den kannst Du ruhig mal auf 64M oder sogar 128M erhöhen. Anschließend starte Xampp neu (wichtig!).

Wenn das nicht hilft, müssen wir schauen, ob dieser Wert ggf. von Typo3 o.ä. in einer .htaccess oder so überschrieben wird - aber erst mal versuche es so.

Grüße
Scory

P.S.: Wie es aussieht, ist bei Dir der Wert auf 240kb "geschrumpft". Wodurch auch immer.
Scory
 

Postby atis » 12. November 2007 12:00

So siehts aus und die 128 nützen auch nichts.

Code: Select all
Configuration File (php.ini) Path    /opt/lampp/etc
Loaded Configuration File    /opt/lampp/etc/php.ini
...
memory_limit   128MB   128MB


Dann gibts da noch ne frage. Habe im Verzeichniss opt/lampp/htdocs ein .DS_Store datei gefunden. Kommen die nicht vom Mac? Als ich sie umgenannt habe, hat sich nichts geändert.

Ich weiss auch nicht so genau welche infos ich euch noch posten soll? Darf ich die php.ini unzensiert hier posten?

Habe versuchsweise die db einfach deaktiviert und die fehlermeldungen bleiben die gleichen.
Wenn eine .htaccess die php.ini aushebelt, müsste die dann nicht im /opt/lampp/htdocs liegen? Die verlangt nur authentifizierung und verbietet das verzeichniss browsing.

Grüsse!
atis
 
Posts: 4
Joined: 10. November 2007 11:46
Location: Riga

Postby Scory » 12. November 2007 12:36

Da ist doch ein Ordner "draugi" - installiere mal dort eine phpinfo.php (wo nur phpinfo() drin steht), vielleicht ist da ein .htaccess oder ähnlich.

Letztendlich ist es sogar möglich, mit Hilfe der Funktion ini_set() die erlaubte Memory-Grenze zu verändern. "Irgendwer" oder "irgendwas" verbiegt bei Dir diesen Wert.

Grüße
Scory
Scory
 

Postby Scory » 12. November 2007 13:09

So, ich habe den Fehler gefunden, kam mir auch direkt seltsam vor:

die Angabe "128MB" ist falsch(!), das B ist zuviel. Dadurch verhaspelt sich PHP, richtig ist die Angabe "128M". Also so:

Code: Select all
memory_limit = 128M


Vermutlich hast Du das selbst falsch eingetragen oder ist aus einer fehlerhaften Angabe während irgendeiner Installation entstanden.

Grüße
Scory
Scory
 

Postby atis » 12. November 2007 13:21

Anmerkung: alle zwei bis drei taage spiele ich die neuesten updates für sidux auf.

Meine lampp verwaltet 20 ordner mit unterschiedlichen cms und dient mir nur als entwicklungsumgebung. "draugi" ist nur einer davon und enthält eine php gallery, die ich seit ein paar monaten nicht mehr aufgerufen und oder verändert habe.

ich habe eine datei namens setini.php mit folgendem code erstellt und im ordner /opt/lampp/htdocs/mi aufgerufen mit deaktivierter mysql

Code: Select all
<?PHP
echo 'memory_limit = ' . ini_get ( 'memory_limit' ) . "\n";

ini_set ( 'memory_limit', '128M' );

echo 'memory_limit = ' . ini_get ( 'memory_limit' ) ;
?>

ausgabe sieht so aus
Code: Select all
memory_limit = 128MB memory_limit = 128M


was die phpinfo.php in "draugi" angeht, da siehts so aus. mit deaktivierter mysql


Code: Select all
PHP Version 5.2.3

System    Linux server 2.6.22.3-rc1-slh-smp-2 #1 SMP PREEMPT Wed Aug 15 01:32:21 CEST 2007 i686
Build Date    Jun 11 2007 13:38:07
Configure Command    ./configure --prefix=/opt/lampp --with-apxs2=/opt/lampp/bin/apxs --with-config-file-path=/opt/lampp/etc --with-mysql=/opt/lampp --enable-inline-optimization --disable-debug --enable-bcmath --enable-calendar --enable-ctype --enable-dbase --enable-discard-path --enable-exif --enable-filepro --enable-force-cgi-redirect --enable-ftp --enable-gd-imgstrttf --enable-gd-native-ttf --with-ttf --enable-magic-quotes --enable-memory-limit --enable-shmop --enable-sigchild --enable-sysvsem --enable-sysvshm --enable-track-vars --enable-trans-sid --enable-wddx --enable-yp --with-ftp --with-gdbm=/opt/lampp --with-jpeg-dir=/opt/lampp --with-png-dir=/opt/lampp --with-freetype-dir=/opt/lampp --without-xpm --with-zlib=yes --with-zlib-dir=/opt/lampp --with-openssl=/opt/lampp --with-expat-dir=/opt/lampp --enable-xslt=/opt/lampp --with-xsl=/opt/lampp --with-dom=/opt/lampp --with-ldap=/opt/lampp --with-ncurses=/opt/lampp --with-gd --with-imap-dir=/opt/lampp --with-imap-ssl --with-imap=/opt/lampp --with-gettext=/opt/lampp --with-mssql=/opt/lampp --with-sybase=/opt/lampp --with-interbase=shared,/opt/interbase --with-mysql-sock=/opt/lampp/var/mysql/mysql.sock --with-oci8=shared --with-mcrypt=/opt/lampp --with-mhash=/opt/lampp --enable-sockets --enable-mbstring=all --with-curl=/opt/lampp --enable-mbregex --enable-zend-multibyte --enable-exif --with-bz2=/opt/lampp --with-sqlite=shared,/opt/lampp --with-libxml-dir=/opt/lampp --enable-soap --enable-pcntl --with-mysqli=/opt/lampp/bin/mysql_config --with-mime-magic --with-pgsql=shared,/opt/lampp/postgresql --with-iconv --enable-dio --with-pdo-mysql=/opt/lampp --with-pdo-pgsql=/opt/lampp/postgresql --with-pdo-sqlite --with-ming=shared,/opt/lampp
Server API    Apache 2.0 Handler
Virtual Directory Support    disabled
Configuration File (php.ini) Path    /opt/lampp/etc
Loaded Configuration File    /opt/lampp/etc/php.ini
PHP API    20041225
PHP Extension    20060613
Zend Extension    220060519
Debug Build    no
Thread Safety    disabled
Zend Memory Manager    enabled
IPv6 Support    enabled
Registered PHP Streams    php, file, data, http, ftp, compress.bzip2, compress.zlib, https, ftps, zip
Registered Stream Socket Transports    tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
Registered Stream Filters    string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, convert.iconv.*, bzip2.*, zlib.*


Configuration
PHP Core

Code: Select all
Directive   Local Value   Master Value
allow_call_time_pass_reference   On   On
allow_url_fopen   On   On
allow_url_include   Off   Off
always_populate_raw_post_data   Off   Off
arg_separator.input   &   &
arg_separator.output   &   &
asp_tags   Off   Off
auto_append_file   no value   no value
auto_globals_jit   On   On
auto_prepend_file   no value   no value
browscap   no value   no value
default_charset   no value   no value
default_mimetype   text/html   text/html
define_syslog_variables   Off   Off
detect_unicode   On   On
disable_classes   no value   no value
disable_functions   no value   no value
display_errors   On   On
display_startup_errors   Off   Off
doc_root   no value   no value
docref_ext   no value   no value
docref_root   no value   no value
enable_dl   On   On
error_append_string   no value   no value
error_log   no value   no value
error_prepend_string   no value   no value
error_reporting   6135   6135
expose_php   On   On
extension_dir   /opt/lampp/lib/php/extensions/no-debug-non-zts-20060613   /opt/lampp/lib/php/extensions/no-debug-non-zts-20060613
file_uploads   On   On
highlight.bg   #FFFFFF   #FFFFFF
highlight.comment   #FF9900   #FF9900
highlight.default   #0000CC   #0000CC
highlight.html   #000000   #000000
highlight.keyword   #006600   #006600
highlight.string   #CC0000   #CC0000
html_errors   On   On
ignore_repeated_errors   Off   Off
ignore_repeated_source   Off   Off
ignore_user_abort   Off   Off
implicit_flush   Off   Off
include_path   .:/opt/lampp/lib/php   .:/opt/lampp/lib/php
log_errors   Off   Off
log_errors_max_len   1024   1024
magic_quotes_gpc   On   On
magic_quotes_runtime   Off   Off
magic_quotes_sybase   Off   Off
mail.force_extra_parameters   no value   no value
max_execution_time   60   60
max_input_nesting_level   64   64
max_input_time   -1   -1
memory_limit   128MB   128MB
open_basedir   no value   no value
output_buffering   no value   no value
output_handler   no value   no value
post_max_size   8M   8M
precision   12   12
realpath_cache_size   16K   16K
realpath_cache_ttl   120   120
register_argc_argv   On   On
register_globals   Off   Off
register_long_arrays   On   On
report_memleaks   On   On
report_zend_debug   On   On
safe_mode   Off   Off
safe_mode_exec_dir   no value   no value
safe_mode_gid   On   On
safe_mode_include_dir   no value   no value
sendmail_from   no value   no value
sendmail_path   /usr/sbin/sendmail -t -i    /usr/sbin/sendmail -t -i
serialize_precision   100   100
short_open_tag   On   On
SMTP   localhost   localhost
smtp_port   25   25
sql.safe_mode   Off   Off
track_errors   Off   Off
unserialize_callback_func   no value   no value
upload_max_filesize   2M   2M
upload_tmp_dir   no value   no value
user_dir   no value   no value
variables_order   EGPCS   EGPCS
xmlrpc_error_number   0   0
xmlrpc_errors   Off   Off
y2k_compliance   Off   Off
zend.ze1_compatibility_mode   Off   Off
atis
 
Posts: 4
Joined: 10. November 2007 11:46
Location: Riga

Postby Scory » 12. November 2007 13:30

In der php.ini steht es immer noch falsch drin (memory_limit = 128MB), das B muss weg!

Grüße
Scory
Scory
 

Postby atis » 12. November 2007 14:12

Seltsam! hab es einmal aufgemacht, sah es so aus 128M wollte schon hier poosten und machte nochmal auf. Tatsächlich 128MB

Jetzt gehts. Mi**t, das ganze Problem muss bereits mein Fehler gewesen vor ein paar taagen. Da hatte ich tatsächlich 128MB geschrieben. Aber den Apache nicht neu gestartet. Beim rebooten des systems hat apache den fehler bemerkt. Mann Scory, ich rauche nichts! Ich habe doch diese php.ini jetzt seit dem auftauchen des problems, mehrmals geändert. Jedesmal habe ich drauf geachtet, dass nur M da steht. Scheint ein paradoxon zu sein. Problem dass sich selbst ausgelöst hat. Gut das ich so ein profi bin! :roll: nja, windoof war anders als linux. Ich muss noch verdammt viel lernen. :lol:

Daanke Scory! Problem gelöst!
atis
 
Posts: 4
Joined: 10. November 2007 11:46
Location: Riga


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests