SSI Staus OK! abers tut net

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

SSI Staus OK! abers tut net

Postby backbone » 04. October 2003 01:10

hiho mädels und bubens,

Hab den XAMPP 4 für linux *freu*

nun hb ich folgendes Prob. der XAMPP SATUS für SSI zeigt mir ein OK! an wenn ich aber nu die seite *.shtml starte in der <!--#include virtual="/layout/menue.htm"--> steht. wird mir die menue.htm nicht eingefügt.

Hat jemand ne idee?
backbone
 
Posts: 7
Joined: 04. October 2003 00:43

Postby Oswald » 04. October 2003 09:31

Ahoi backbone!

Sicher, dass die menue.htm existiert? Kannst Du mal in die error_log schauen, ob da irgendeine Fehlermeldung protokolliert wurde?

Hast Du irgendwas an der httpd.conf geändert?

Lieben Gruß
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby backbone » 04. October 2003 10:44

moinsen Herr Oswald ;)

Die menue.htm existiert.
In der error_log stehen leider kein fehler drinn.

In der httpd.conf sind auch die einträge:

- AddType text/html .shtml
- AddOutputFilter INCLUDES .shtml

- XBitHack on

drin.
backbone
 
Posts: 7
Joined: 04. October 2003 00:43

Postby Oswald » 04. October 2003 10:51

Moin backbone!

Jau, das sieht gut aus. ;)

Aber trotzdem noch mal meine Frage: Hast Du was an der httpd.conf geändert? Ich frage deshalb, weil ich SSI grad bei mir ausprobiert habe und bei mir funktioniert es wunderbestens. Normale XAMPP-Installation. Wenn jetzt nicht mal in der error_log irgendwas steht, dann kann es nur eine andere Konfiguration bedeuten....

Denk ich mir jedenfalls so... ;)

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby backbone » 05. October 2003 13:17

hiho,

hmmm soweit ich mich errinern kann ;( hab ich nur das document root geändert. Kann das an dem liegen?

greez backbone
backbone
 
Posts: 7
Joined: 04. October 2003 00:43

Postby Oswald » 05. October 2003 16:11

Servus Backbone!

Bingo!! Das is' es! Zumindest kann es das wirklich sein. Etwa 25 Zeilen unter der DocumentRoot-Direktive (die wirst Du ja geändert haben) findest Du noch mal die Erwähnung des DocumentRoot-Verzeichnisses. Dort muss Du noch mal das gleiche wie bei DocumentRoot eintragen.

Also so sieht's in der normalen httpd.conf aus:

DocumentRoot "/opt/lampp/htdocs"

Und 25 Zeilen weiter unten:

<Directory "/opt/lampp/htdocs">

Immer beide ändern!

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby backbone » 05. October 2003 17:51

JIHHHHHHHHHHAAAAAAA

es funktioniert.

!TECHNIK DIE BEGAISTERT!

kurz damit ich nicht doof sterbe- was macht der eintrag <Directory "desWasImInternetAnzuschauenIst/HaTeÄmEll">


mfg backbone
backbone
 
Posts: 7
Joined: 04. October 2003 00:43

Postby Oswald » 05. October 2003 18:05

Supi!!! :)

Sorry, hätt ich ja auch gleich erklären können: In der Zeile unter dem Directory wird definiert welche Features für dieses Verzeichnis (das was Du da angegeben hast) aktiviert sind. Zum Beispiel: Options ... Includes aktiviert SSI für dieses Verzeichnis.

Darum ging bei Dir auch SSI zunächst nicht. Weil Deine shtml-Datei in einem Verzeichnis lag für welches SSI nicht aktiviert war.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby backbone » 05. October 2003 18:56

Vielen Dank ich hoffe ich hab hir net rumgenervt.
backbone
 
Posts: 7
Joined: 04. October 2003 00:43

Postby Oswald » 05. October 2003 19:06

Null problemo! Sehr gerne! Und Du hast definitiv nicht rumgenervt!! ;)

Noch einen schönen Restsonntag!
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests