SSL problem

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

SSL problem

Postby timmy » 02. October 2003 18:34

Hallo,

Ich habe ein problem mit SSL.
hab schoen in ssl.conf verschiedene sagen probiert
aber bis jetzt noch kein gluck gehabt.

was ich shon probiert habe:
<VirtualHost _default_:443>
#<VirtualHost [ip]:443>
#<VirtualHost *:443>
#<VirtualHost>

# General setup for the virtual host
# DocumentRoot "/opt/lampp/htdocs"
DocumentRoot "/home/sites/site43/web"
#ServerName domain.nl:443
ServerName [ip]:443
ServerAdmin you@test.test
ErrorLog logs/error_log
TransferLog logs/access_log

wie kann mich helfen?

Timmy
aus Holland ;-)
timmy
 
Posts: 6
Joined: 02. October 2003 18:26

Postby Oswald » 02. October 2003 23:51

Hallo Timmy!

Im XAMPP ist schon eine prima funktionierende SSL-Konfiguration enthalten. Am besten Du benutzt die und änderst erst mal gar nichts.

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby timmy » 03. October 2003 10:55

Kai Seidler wrote:Hallo Timmy!

Im XAMPP ist schon eine prima funktionierende SSL-Konfiguration enthalten. Am besten Du benutzt die und änderst erst mal gar nichts.

Liebe Grüße,
Oswald


Denn brauch ich schon..
wenn ich xampp starte dann, sagt es... "apache start mit ssl"
SLL fur Webmin lauft.
port 433 ist offen

aber das problem is wenn ich ein domain fur http UND https brauchen mochte.. dann functionieren alle andere virtual domains nicht mehr / Oder
nur denn domain nicht..

bis jetzt ist es mir nicht gelungen ein virtual server mit http UND https ...

etwas ist noch nicht korrekt im httpd.conf oder ssl.conf... aber was?

Timmy
timmy
 
Posts: 6
Joined: 02. October 2003 18:26

Postby Oswald » 03. October 2003 11:09

Hi timmy!

Vielleicht hilft Dir das hier:

Code: Select all
<VirtualHost 1.2.3.4:443>

DocumentRoot "/opt/lampp/htdocs"
ServerName localhost:443
ServerAdmin you@your.address
ErrorLog logs/error_log
TransferLog logs/access_log

SSLEngine on

SSLCertificateFile /opt/lampp/etc/ssl.crt/server.crt
SSLCertificateKeyFile /opt/lampp/etc/ssl.key/server.key


Das ist die minimale Konfiguration für einen SSL-Virtual Host. Weitere Einstellungen findest Du in der ssl.conf.

1.2.3.4 ist in dem Beispiel die IP-Adresse von Deinem SSL-Virtual Host. Jeder SSL-Virtual Host brauchst seine eigene IP-Adresse! Name-based Virtual Hosts sind mit SSL nicht möglich!

Liebe Grüße und viel Erfolg
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby timmy » 03. October 2003 12:45

Code: Select all
<VirtualHost 1.2.3.4:443>

DocumentRoot "/opt/lampp/htdocs"
ServerName localhost:443
ServerAdmin you@your.address
ErrorLog logs/error_log
TransferLog logs/access_log

SSLEngine on

SSLCertificateFile /opt/lampp/etc/ssl.crt/server.crt
SSLCertificateKeyFile /opt/lampp/etc/ssl.key/server.key


Das ist die minimale Konfiguration für einen SSL-Virtual Host. Weitere Einstellungen findest Du in der ssl.conf.

1.2.3.4 ist in dem Beispiel die IP-Adresse von Deinem SSL-Virtual Host. Jeder SSL-Virtual Host brauchst seine eigene IP-Adresse! Name-based Virtual Hosts sind mit SSL nicht möglich!



das hier ab ich schone probiert
wenn ich das hier mache:
Code: Select all
<VirtualHost [meine IP adresse]:443>

DocumentRoot "/opt/lampp/htdocs"
ServerName localhost:443
ServerAdmin you@your.address
ErrorLog logs/error_log
TransferLog logs/access_log

SSLEngine on

SSLCertificateFile /opt/lampp/etc/ssl.crt/server.crt
SSLCertificateKeyFile /opt/lampp/etc/ssl.key/server.key


(server.crt und server.key sind die richtige paths)
(nur dir [meine IP adresse] andere ich
lauft https ! aber http lauft nicht mehr.
ich bekomme dann ein blanco seite.
in den Source code finde ich:
Code: Select all
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META content="text/html; charset=windows-1252" http-equiv=Content-Type></HEAD>
<BODY></BODY></HTML>


was gibs dann noch?
soll ich fur Servername und DocumentRoot nicht etwas anderes
herein fuhren?


in httpd.conf habe die einstellungen gemacht:
DocumentRoot "/home/sites/site41/web"
#DocumentRoot "/opt/lampp/htdocs"

<IfModule mod_ssl.c>
Include etc/ssl.conf
</IfModule>

und, brauche ich nicht dieses hier:
LoadModule modssl_module modules/mod_ssl.so

oder so etwas ahnliches??

Timmy
timmy
 
Posts: 6
Joined: 02. October 2003 18:26

Postby Guest » 04. October 2003 10:46

anyone?
Guest
 

Postby Guest » 06. October 2003 13:58

kann mall sagen ob meine einstellungen richtig sind???

Timmy
Guest
 

Postby Guest » 08. October 2003 22:40

Hello,
i have the same problems with SSL
When u have a domain and other domains in your virtualhost SSL runs only when you put SSL before virtualhost.
If you do that then works SSL good and the rest NOT
I send this problem with my .conf to Oswald for 8 weeks ago and he promise te checkit, no answer!
SSL is running 100% ok on localhost but not in a real server.
Believe me i work 8 years with Linux and Apache and i'm not stupid

I believe in XAMPP it is a good product and i hope this will not stop!
Only what i have to say: Oswald fix this BUG

Herbert
Guest
 

Postby Oswald » 09. October 2003 09:58

Dear Herbert!

I answered your E-Mail serveral times and I always showed that it's a misconfiguration by yourself. And your problem was (at least at the time you emailed me) another one. As far I remember you're running a normal HTTP-virtual host on port 443 and not a HTTPS-virtual host.

But that's not the problem this time... ;)

Again: I've several webservers running with HTTP virtual hosts and HTTPS virtual hosts. On the same host and without any problems. It not a bug of the Apache.

Dear timmy!

Ich hab es grad noch mal selbst ausprobiert. Es geht wirklich wunderbar. Hier noch mal ein virtual host Auszug aus der httpd.conf mit dem ich es gerad probiert habe:

Code: Select all
Listen 127.0.0.2:443

<VirtualHost 127.0.0.2:443>

DocumentRoot "/tmp"
ServerName 127.0.0.2:443
ServerAdmin you@your.address
ErrorLog logs/ssl-error_log
TransferLog logs/ssl-access_log

<Directory /tmp>
        Options Indexes
</Directory>

SSLEngine on

SSLCertificateFile /opt/lampp/etc/ssl.crt/server.crt
SSLCertificateKeyFile /opt/lampp/etc/ssl.key/server.key
</VirtualHost>


Wenn Du nun https://127.0.0.2 aufrufst, siehst Du Dein /tmp-Verzeichnis. Rufst Du http://127.0.0.1 auf, siehst Du den normalen Websserver. Klappt prima.

Was allerdings wichtig ist - und das hab oben eigentlich auch schon weiter oben geschrieben: Es darf pro IP-Adresse (bzw. genaugenommen pro IP-Adresse/Port) nur ein SSL-Virtual Host definiert werden. In der normalen httpd.conf von XAMPP wird auch ein SSL-Virtual Host mitgeliefert. Der muss dann ausgeschaltet werden, wenn Du Deine eigenen definierst. Am einfachsten Zeile 1080 auskommentieren:

Code: Select all
<IfModule mod_ssl.c>
    Include etc/ssl.conf
</IfModule>


zu:

Code: Select all
<IfModule mod_ssl.c>
    #Include etc/ssl.conf
</IfModule>


Es muss genau so funktionieren. ;)

Viel Erfolg
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Ich bekomms nicht hin …

Postby Sebastian » 19. October 2003 07:16

Kai Seidler wrote:Wenn Du nun https://127.0.0.2 aufrufst, siehst Du Dein /tmp-Verzeichnis. Rufst Du http://127.0.0.1 auf, siehst Du den normalen Websserver. Klappt prima.

Was allerdings wichtig ist - und das hab oben eigentlich auch schon weiter oben geschrieben: Es darf pro IP-Adresse (bzw. genaugenommen pro IP-Adresse/Port) nur ein SSL-Virtual Host definiert werden.


Hallo!

Ich habe genau das gleiche Problem: entweder geht http oder https - in deinem Beispiel nutzt du zwei IPs. Ich habe aber nur eine. Was ich machen möchte ist einfach zusätzlich zu den laufenden Virtual Hosts einen zu haben, den ich für https nutzen kann. (Ein SSL Virtual Host würde mir also reichen)
Wie mache ich das mit einer IP?

Viele Grüße

Sebastian
Sebastian
 

Postby Oswald » 19. October 2003 16:11

Hallo Sebastian!

Deinem Wunsch enstpricht die normale XAMPP f. Linux Konfiguration. Dort gibt es einen normalen HTTP (virtual) host und einen HTTPS (virtual) host. Ich hab das (virtual) in Klammern weil in diesem Fall ja eigentlich nicht von virtual host die Rede sein kann. Ist ja quasi nur einer.

Schau also einfach in die normale Konfiguration vom XAMPP und da hast Du schon das Beispiel, dass Du haben möchtest.

Lieben Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Guest » 19. October 2003 22:32

Kai Seidler wrote:Hallo Sebastian!

Dort gibt es einen normalen HTTP (virtual) host und einen HTTPS (virtual) host.
Lieben Gruß,
Oswald


Hi!

Danke für die schnelle Antwort, aber da habe ich mich wohl nicht so klar ausgedrückt: Ich brauche mehrere HTTP und einen HTTPS Host auf einer IP Adresse - und gerade habe ich auch rausgefunden, was der Fehler war: Alle Virtual http hosts müssen auf :80 stehen, sonst wird das nix mit dem einen :431.

Viele Grüße

Sebastian

PS: Ist es korrekt, das mod_dav schon installiert ist (Linux Version)? Und ich nur noch den Anleitungen auf webdav.org/mod_dav folgen müsste um es zu aktivieren? (Config in httpd)
Das habe ich auch versucht nur irgendwie bekomme ich mit nem Client keine Verbindung, kann man da irgendwo den Status sehen, oder gibt es noch ne bessere Anleitung? Im Forum wurde auf drei Seiten verwiesen doch bin ich leider noch nicht schlau geworden.
Guest
 

Postby orko » 08. July 2005 08:56

habe ich das wirklich richtig verstanden, dass ich bei meinem Apache2 nur einen VirtualHost anlegen kann, also mit SSL ?
orko
 
Posts: 1
Joined: 08. July 2005 08:48


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest