(gelöst) Lampp und Wordpress

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

(gelöst) Lampp und Wordpress

Postby .:andre:. » 26. September 2007 12:58

Erst mal ein Hallo an Alle :wink: !

Ich habe Lampp bei mir unter Zenwalk ohne größere Probleme zum laufen gebracht. Allerdings scheiter ich jetzt an der Installation von "Wordpress". Ich habe mich an diese Anleitunggehalten und eine Datenbank "wordpress" erstellt. Beim Punkt Passwort ändern, habe ich "Kein Passwort" gesetzt. Allerdings habe ich den Ordner "wordpress" nicht per ftp:/ sondern mit dem Dateimanager nach /opt/lampp/htdocs/wp verschoben (es ist ein virtuelles Netzwerk). Ich komme bis ftp://localhost/wp/ wo mir der Ordner "wordpress" auch angezeigt wird. Beim öffnen erhalte ich ein
Code: Select all
550/wp/wordpress: Permission denied



Meine wp-config.php
Code: Select all
// ** MySQL settings ** //

define('DB_NAME', 'wordpress');    // Der Name der Datenbank, die du benutzt.

define('DB_USER', 'root');     // Dein MySQL-Datenbank-Benutzername.

define('DB_PASSWORD', ''); // Dein MySQL-Passwort

define('DB_HOST', 'localhost');    // 99% Chance, dass du hier nichts ändern musst.

define('DB_CHARSET', 'utf8');

define('DB_COLLATE', '');


$table_prefix  = 'wp_';   // Nur Zahlen, Buchstaben und Unterstriche bitte!


define ('WPLANG', 'de_DE');


define('ABSPATH', dirname(__FILE__).'/');

require_once(ABSPATH.'wp-settings.php');


Und ein Aufruf von http://localhost/wp/wordpress brint natürlich
Code: Select all
You don't have permission to access /wp/wordpress on this server.

Neugestartet habe ich Lampp natürlich auch. Der Scherheitscheck von Lampp wurde auch noch nicht ausgeführt. Also alles Orginal gelassen.

Was mache ich falsch? Schon mal Danke für die Antworten!
Last edited by .:andre:. on 26. September 2007 16:07, edited 1 time in total.
.:andre:.
 
Posts: 3
Joined: 26. September 2007 12:24

Postby Wiedmann » 26. September 2007 14:30

sondern mit dem Dateimanager nach /opt/lampp/htdocs/wp verschoben

Dann solltest du dir mal die Rechte dieses Ordners (und Dateien) anschauen. (Stichwort: chmod/chown).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby .:andre:. » 26. September 2007 15:57

Dann solltest du dir mal die Rechte dieses Ordners (und Dateien) anschauen. (Stichwort: chmod/chown).

Da war ich kurz nach schreiben der Frage auch schon alleine drauf gekommen. :oops: thx

Gut, damit sich jemand später die Zeit spart (nur als Ergänzung zu hier, als Bsp für eine lokale Installation):
1. Die Datenbank ist angelegt (hier als Bsp "wordpress"), lampp läuft
2. Wordpress herunterladen. Die runtergeladene "latest.zip" habe ich in "wordpress.zip" umbenannt.
3. Konsole öffnen und zum Verzeichniss mit der .zip-Datei wechseln.
4. Befehl: unzip wordpress.zip
5. Jetzt als root in der Konsole: mkdir /opt/lampp/htdocs/wp
6. Immer noch als root: mv /Pfad/zumOrdner/wordpress/ /opt/lampp/htdocs/wp/ . Das verschiebt jetzt den entpackten Ordner nach .../wp/wordpress. Ich hatte das mit einem Dateimanager gemacht, was leider nicht funktioniert :cry:
7. Die Datei wp-config.php im Ordner wordpress mit dem Editor deine Wahl (als root) wie oben geschehen anpassen.
8. Ich habe jetzt lampp noch mal neu gestartet (notwendig?) und dann http://localhost/wp/wordpress aufgerufen... und es lief sofort.
.:andre:.
 
Posts: 3
Joined: 26. September 2007 12:24


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests