Apache startet nicht neu!

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nicht neu!

Postby DocJoe » 12. September 2007 16:24

Hallo Allerseits,

ich habe folgednes Problem. ich betreibe auf einem virtuellen Server eine SQL-Datenbank. Ab und an musste ich bei Zugriffsproblem über das Web das System neu starten. Heute bekomme ich aber nur diese Fehlermeldung zurück. Ich habe bereits versucht die entsprechenden Dateien per Hand zu entfernen, hat aber nicht geklappt.

Hat jemand eine rettende Idee? Ich habe die Fehlermeldung unten angehängt.

Erstmal vielen Dank.

diag lampp # ./lampp restart
Stopping XAMPP for Linux 1.4.15...
XAMPP: Stopping Apache with SSL...
XAMPP: Stopping MySQL...
rm: cannot remove `/opt/lampp/var/mysql/diag.pid': Read-only file system
./lampp: line 398: kill: (6114) - No such process
XAMPP: Stopping ProFTPD...
XAMPP stopped.
Starting XAMPP for Linux 1.4.15...
rm: cannot remove `/opt/lampp/logs/httpd.pid': Read-only file system
XAMPP: Starting Apache with SSL (and PHP5)...
./lampp: line 184: /opt/lampp/logs/apachestart.log: Read-only file system
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
rm: cannot remove `/opt/lampp/var/mysql/diag.pid': Read-only file system
XAMPP: Starting MySQL...
touch: cannot touch `/var/lock/subsys/mysql': Read-only file system
rm: cannot remove `/opt/lampp/var/proftpd.pid': Read-only file system
XAMPP: Starting ProFTPD...
./lampp: line 290: /opt/lampp/var/proftpd/start.err: Read-only file system
XAMPP:
XAMPP: Error 1! Couln't start ProFTPD!
touch: cannot touch `/opt/lampp/var/mysql/diag.err': Read-only file system
XAMPP for Linux started.
diag lampp # rm: cannot remove `/opt/lampp/var/mysql/diag.pid': Read-only file system
/opt/lampp/bin/mysqld_safe: line 284: /opt/lampp/var/mysql/diag.err: Read-only file system
DocJoe
 
Posts: 2
Joined: 12. September 2007 16:12

Problem gelöst!

Postby DocJoe » 13. September 2007 16:30

Anscheinend gab es Probleme bei meinem Provider. Ich konnte trotz das ich als root angemeldet war keine Dateiänderungen vornehmen. Daher war ein Neustart mit den dazu erforderlichen Dateizugriffen nicht möglich.

Was im Einzelnen dort gemacht wurde, haben die Kollegen mir leider nicht mitgeteilt.
DocJoe
 
Posts: 2
Joined: 12. September 2007 16:12


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests