DocumentRoot unter Ubuntu verändern - AccessDenied

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

DocumentRoot unter Ubuntu verändern - AccessDenied

Postby the57erprowler » 01. August 2007 14:36

Hallo,

bin neu unter Linux, habe mir ein Dualbootsystem mit Ubuntu und Xp eingerichtet. Es gibt eine gemeinsame vFat Datenpartition auf die ich das DocumentRoot des XAMPP verlegen möchte.

Unter Xp reicht es in der httpd.conf das Document Root und das Verzeichnis für die Direktive zu verändern und es funzt.

Unter Ubuntu produziert die Änderung von:
#DocumentRoot "/opt/lampp/htdocs"
nach:
DocumentRoot "/home/computerverwaltung/DATABASE/xampp/htdocs"

und von:
#<Directory "/opt/lampp/htdocs">
nach:
<Directory "/home/computerverwaltung/DATABASE/xampp/htdocs">

einen "Access Denied" error des apache :(

DATABASE ist der Mountpoint der vFat Datenpartition

Im default htdocs Verzeichnis ist das Webroot des XAMPP zugreifbar, die Installation läuft also.
Der aktuelle Benutzer hat auch die Zugriffsrechte für die Datenpartition.

Ich find nix darüber wie man das lösen kann, hat irgend jemand ne Idee? :?

Ps. Ich brauch den Zugriff von beiden Systemen weil Xp noch das Produktionssystem ist.
the57erprowler
 
Posts: 1
Joined: 01. August 2007 14:06

htdocs auf anderer Partition

Postby plhh2 » 09. September 2007 22:56

Hallo, also mir geht es genauso, ich kann (leider) nicht auf XP verzichten, habe sowohl lampp als auch xampp installiert, möchte aber nur ein htdocsVerz. auf XP Partition haben. ALLE Versuche in den conf sind bisher gescheitert. Ein Problem sind auch Scripts (wie meine Galerie oder mein Board), die eine mysql installation verlangen. Da ich auch noch einen Webcam-Server betreibe, kann ich leider - immer noch nicht - alles über Linux ablaufen lassen und muss das oft unliebsame XP nutzen. Vielleicht hat ja hier noch jemand eine Idee.
Gruss aus Neuss, Peter
plhh2
 
Posts: 2
Joined: 16. December 2005 11:48
Location: Neuss

Zugriff auf WinPartition

Postby PatKing » 07. October 2007 11:24

Bei mir musste ich für den Zugriff auf das NTFS-Laufwerk den Parameter 'umask=007' auf 'umask=002' in der '/etc/fstab' ändern damit der Zugriff klappt.
Habe so Zugriff von Windows und Linux auf die gleichen Daten.

Dies ist mein geänderter Eintrag in der fstab

# /dev/hda1
UUID=84FC2DC7FC2DB478 /media/hda1 ntfs defaults,umask=002,gid=46 0 1
PatKing
 
Posts: 1
Joined: 07. October 2007 11:16

XAMPP für Linux

Postby plhh2 » 07. October 2007 14:50

hatte gar nicht mehr mit einer Antwort gerechnet :shock: , dennoch vielen Dank, werde das mal so ausprobieren. Wollte mir sowieso das neue feisty noch aufspielen, da kann ich es gleich mal testen.
nach jedem Erfolg denke ich, ich sei schlauer, und dann kommt da schon das nächste Problem :-)
plhh2
 
Posts: 2
Joined: 16. December 2005 11:48
Location: Neuss


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests