Neues von der LDAP Front ???

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Neues von der LDAP Front ???

Postby TomCat » 18. September 2003 11:19

Hallo alle zusammen,

ich habe gerade XAMPP 1.2 für Linux installiert und etwas enttäuscht das es nicht sofort funktionierte :(

Hier im Forum habe ich dann schnell einen passenden Thread von Febuar diesen Jahres gefunden der besagt das PHP nicht mit der LDAP Gruppenverwaltung zurechtkommt ....

Nach schnellem Test hat dies auch bei mir geholfen :-)

Nun kann ich zwar damit leben das die GroupID nur noch als Zahl angezeigt wird, aber ich wollte mal nachhören ob es mitlerweile einen Ansatz für eine Lösung für dieses Problem gibt.

Kann es vielleicht sein das nur eine LDAP V2 erwartet wird und nicht V3 wie bei openldap2-2.1.12-74 die bei der SuSE 8.2 enthalten ist ?

Hier die entsprechenden Zeilen aus der error_log :
[Thu Sep 18 11:55:36 2003] [notice] child pid 4641 exit signal Aborted (6)
httpd: options.c:342: ldap_set_option: Zusicherung »( (ld)->ld_options.ldo_valid == 0x2 )« nicht erfüllt.

diese Einträge schreiben jeweils im wechsel sehr schnell die Log-Datei voll :(

Viele Grüße

Thomas
TomCat
 

Postby Oswald » 18. September 2003 11:50

Huhu Thomas!

Danke für die Erinnerung! Mir war das schon ganz entfallen und ich leb seit dem schon mehr oder weniger gut mit der numerischen GID.

Eine Idee hätt ich noch und die kann ich auch noch mal ausprobieren: Im Moment verwende ich die LDAP-Client-Bibliothek der University of Michigan (ldap-3.3). Vielleicht tritt der Fehler ja mit OpenLDAP nicht auf!?

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby TomCat » 18. September 2003 12:30

Hi Oswald,

das mit der Client-Libery hört sich nach einer guten Idee an !!!

Ich habe hier ein wenig experimentiert und mir ist aufgefallen das, wenn ich in der /etc/openldap/ldap.conf die Verwendung von LDAP V2 erzwinge, xampp problemlos läuft.

Hehe, dann funktioniert die Kommunikation mit dem LDAP-Server zwar nicht mehr, da dieser ja auch LDAP V3 benutzt, aber es scheint doch wirklich an der Version zu liegen ..... ?!?

ich habe mir mal die phpinfo Ausgabe von einer SuSE 8.2 angeschaut :

LDAP Support enabled
RCS Version $Id: ldap.c,v 1.130 2002/11/05 14:18:20 edink Exp $
Total Links 0/unlimited
API Version 2004
Vendor Name OpenLDAP
Vendor Version 20111

die ldap.c Version scheint zumindest die gleiche zu sein *wunder*

Aber merkwürdig ist es schon, das es nur die Gruppenverwaltung betrift ...

Vor allem wenn man unter xampp ein LDAP Administrations_Tool
unter PHP betreiben möchte :-(

Jedenfalls danke ich Dir für die schnelle Antwort und wünsche Dir viel Erfolg bei der Suche.

Viele Grüße

Thomas
TomCat
 

Postby Oswald » 02. October 2003 09:26

Hallo Thomas!

Ich hab jetzt grad eine neue XAMPP-Version zusammengestellt: Diesmal mit OpenLDAP. Und tatsächlich: Das Problem tritt nicht mehr auf!! :)

Wenn sich nicht noch größere Problem ergeben werd ich die neue Version von XAMPP morgen abend veröffentlichen.

Wenn Du magst kann ich Dir auch schon den Release-Candiate mal zukommenlassen? Ein Betatester mehr ist immer gut! ;) Wenn ja, dann Mail mir bitte.

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests