Virtual Hosts

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Virtual Hosts

Postby Hendricius » 27. April 2007 13:57

Hallo,

ich wollte jetzt mal Virtual-Hosts zu meiner Xamp Installation hinzufügen. Hab jetzt www.hackwiki.net fest auf meine Server IP umgeleitet via A-Record:88.198.57.239

Leider kriege ich das nicht hin :(. Krieg immer 500er Errors.

Sieht wie folgt aus:
www.hackwiki.net soll in den Ordner /opt/lampp/htdocs/hackwiki weiterleiten.
Mein Apacheserver root müsste /opt/lampp sein.

Also hab ich das hier fabriziert und in die httpd.conf eingefügt.

Code: Select all
<VirtualHost *:80>
    ServerAdmin webmaster@d3scene.com
    DocumentRoot /opt/lampp/htdocs/hackwiki
    ServerName hackwiki.net
    ErrorLog logs/hackwiki.net-error_log
    CustomLog logs/hackwiki.net-access_log common
</VirtualHost>

Dann krieg ich leider immer 500 Errors. Ich denke mal irgendwas an
Code: Select all
<VirtualHost *:80>
ist falsch.

Reicht das an Informationen? Wäre nett wenn ihr euch das mal angucken könntet. Bin mit meinem Latein am ende.

Meine httpd.conf

Der Error den ich immer bekomme:
[Fri Apr 27 16:19:35 2007] [error] [client 81.169.145.11] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
Den Error bekomme ich auf allen meinen Domains, wenn ich die httpd.conf so wie oben beschrieben editiere.

Danke für die Hilfe!

MFG Susi.
Hendricius
 
Posts: 15
Joined: 04. April 2007 13:50

Postby martinpre » 27. April 2007 19:03

10 internal redirects

Da wird irgendwas falsch weitergeleitet

Use 'LogLevel debug' to get a backtrace.

Steht ja da was su machen sollst für mehr Infos.

PS: ich hab keine Ahnung von Vhosts!
martinpre
 
Posts: 405
Joined: 22. May 2006 16:14
Location: Nähe Tulln / Österreich

Postby SyncMaster72 » 27. April 2007 20:10

Das ganze sollte in die datei /opt/lampp/etc/extras/httpd-vhosts.conf
Und da ist dann auch schon das entscheidende drin:

NameVirtualHost *:80

Damit ermöglichst du dem Apache, Vhosts auf Port 80 zu machen

Damit die vhosts.conf genutzt wird, musst du in der Zeile

Include etc/extra/httpd-vhosts.conf

das Kommentarzeichen # löschen

Grüße
JC
SyncMaster72
 
Posts: 6
Joined: 21. November 2006 15:51
Location: Hamburg

Postby Hendricius » 29. April 2007 23:14

Hallo, vielen Dank. Scheint so als hätte ich es fast hinbekommen.

Einige Leute erhalten die folgenden Errors:

The requested resource
/forum/
is no longer available on this server and there is no forwarding address. Please remove all references to this resource.


Bei einigen funktionierts, bei einigen nicht. Error Code: 410
#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
NameVirtualHost *:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for all requests that do not
# match a ServerName or ServerAlias in any <VirtualHost> block.
#
<VirtualHost *:80>
ServerAdmin webmaster@d3scene.com
DocumentRoot /opt/lampp/htdocs/hackwiki
ServerName hackwiki.net
ServerAlias www.hackwiki.net
ErrorLog logs/hackwiki.net-error_log
CustomLog logs/hackwiki.net-access_log common
</VirtualHost>
<VirtualHost *:80>
ServerAdmin webmaster@d3scene.com
DocumentRoot /opt/lampp/htdocs/directory
ServerName submiturl123.com
ServerAlias www.submiturl123.com
ErrorLog logs/submiturl123.com-error_log
CustomLog logs/submiturl123.com-access_log common
</VirtualHost>
<VirtualHost *:80>
ServerAdmin webmaster@d3scene.com
DocumentRoot /opt/lampp/htdocs/d3scene
ServerAlias www.d3scene.com
ErrorLog logs/d3scene.com-error_log
CustomLog logs/d3scene.com-access_log common
</VirtualHost>
<VirtualHost *:80>
ServerAdmin alexwaschi@msn.com
DocumentRoot /opt/lampp/htdocs/erotic123
ServerName erotic123.com
ServerAlias www.erotic123.com
ErrorLog logs/erotic123.com-error_log
CustomLog logs/erotic123.com-access_log common
</VirtualHost>
<VirtualHost *:80>
ServerAdmin alexwaschi@msn.com
DocumentRoot /opt/lampp/htdocs/mathe123
ServerName mathe123.net
ServerAlias www.mathe123.net
ErrorLog logs/mathe123.net-error_log
CustomLog logs/mathe123.net-access_log common
</VirtualHost>


Kriege auch einen Fehler bei den Google-Webmastertools:
Beim Versuch, Ihre Kontrolldatei aufzurufen, konnten wir aufgrund eines DNS-Fehlers nicht auf Ihre Domain zugreifen. Dies kann daran liegen, dass Ihr Server inaktiv ist oder ein Problem mit der DNS-Umleitung zu Ihrer Domain vorliegt. Stellen Sie sicher, dass Ihre Domain korrekt aufgelöst wird, und versuchen Sie es erneut.


Danke für eure Hilfe!
Hendricius
 
Posts: 15
Joined: 04. April 2007 13:50


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests