Komische fehlermeldung

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Komische fehlermeldung

Postby Botox84 » 06. April 2007 13:13

Ich habe eine root server für games und wollte meine hp jetzt auch darauf legen.

Linux Debian 3.1 (sarge) server

hab die installation geschafft, alles lief super, bis ich passwörtes vergeben habe. mit folgeden befehl:/opt/lampp/lampp security

dies hat er auch durchgeführt, doch danach war meine datenbank nicht mehr zu erreichen fehlermeldung:Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/opt/lampp/var/mysql/mysql.sock' (2) in /opt/lampp/htdocs/xampp/cds.php on line 64

mhhh okay, habe ich mir gedacht, deinstallier ich die ganze geschichte noch einmal und machs neu drauf, so gedacht, so getan, doch die datenbank war jetzt trotzdem nicht mehr zu erreichen.

dann habe ich mir gedacht das ich in die console folgenden befehl eingebe um die passwörter raus zu nehmen: /opt/lampp/lampp security

habe dann alles das was gefragt wurde mit j beantwortet und anstatt ein passwort einzugeben, einfach enter gedrückt, also kein pw.

doch wenn ich jetzt auf status schaue kommt das:

MySQL-Datenbank DEAKTIVIERT

PHP DEAKTIVIERT

Perl DEAKTIVIERT

Common Gateway Interface (CGI) DEAKTIVIERT

Server Side Includes (SSI) DEAKTIVIERT

PHP-Erweiterung »eAccelerator« DEAKTIVIERT siehe FAQ

PHP-Erweiterung »OCI8/Oracle«

was nun? gibt es evtl. einen befehl mit dem ich alles reseten kann? oder was kann ich jetzt machen?
Botox84
 
Posts: 10
Joined: 06. April 2007 13:04
Location: Rostock

Postby Wiedmann » 06. April 2007 13:40

dies hat er auch durchgeführt, doch danach war meine datenbank nicht mehr zu erreichen fehlermeldung:
Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/opt/lampp/var/mysql/mysql.sock' (2) in /opt/lampp/htdocs/xampp/cds.php on line 64

Dann wäre ja alles in Ordung gewesen:
In diesem Script wird für den Zugriff auf MySQL der User "root" ohne Passwort benutzt. Da dieser User durch die "Security" jetzt ein Passwort im MySQL-Server hat, kommt diese Fehlermeldung im Script (Das Script kennt das neue Passwort ja nicht).

was nun? gibt es evtl. einen befehl mit dem ich alles reseten kann? oder was kann ich jetzt machen?

Lösch das Verzeichnis "/opt/lampp" (rm) und installiere den XAMPP neu (tar). Vor dem Löschen natürlich dafür sorgen, dass nichts vom XAMPP mehr läuft (ps und kill).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Botox84 » 06. April 2007 13:45

danke für die schnelle antwort, habs schon alles gelöscht und neu installiert, aber die selbe fehlermeldung kommt dann trotzdem, hab ich vielleicht falsch gelöscht? Ich habe /opt/lampp/lampp stop und dann rm -rf /opt/lampp ausgeführt.dann den kompletten ordner opt gelöscht und dann einfach einen neuen ordner mit cmod 777 drauf gemacht, dann die installation mit tar xvfz xampp-linux-1.6.tar.gz -C /opt wieder ausgeführt, danach dann /opt/lampp/lampp start
doch es kam die selbe fehlermeldung :(

was habe ich falsch gemacht oder was muss ich jetzt machen damit es geht?
Botox84
 
Posts: 10
Joined: 06. April 2007 13:04
Location: Rostock

Postby Botox84 » 06. April 2007 13:56

Botox84 wrote:danke für die schnelle antwort, habs schon alles gelöscht und neu installiert, aber die selbe fehlermeldung kommt dann trotzdem, hab ich vielleicht falsch gelöscht? Ich habe /opt/lampp/lampp stop und dann rm -rf /opt/lampp ausgeführt.dann den kompletten ordner opt gelöscht und dann einfach einen neuen ordner mit cmod 777 drauf gemacht, dann die installation mit tar xvfz xampp-linux-1.6.tar.gz -C /opt wieder ausgeführt, danach dann /opt/lampp/lampp start
doch es kam die selbe fehlermeldung :(

was habe ich falsch gemacht oder was muss ich jetzt machen damit es geht?


so jetzt habe ich es noch einmal gemacht. so wie oben beschrieben.

aber:MySQL-Datenbank DEAKTIVIERT
PHP AKTIVIERT

Perl AKTIVIERT

Common Gateway Interface (CGI) AKTIVIERT

Server Side Includes (SSI) AKTIVIERT

PHP-Erweiterung »eAccelerator« DEAKTIVIERT

PHP-Erweiterung »OCI8/Oracle« DEAKTIVIERT

die datenbank geht immer nocht nicht, obwohl das hier steht:

R14879:~# /opt/lampp/lampp start
Starting XAMPP for Linux 1.6...
XAMPP: Another web server daemon is already running.
XAMPP: Another MySQL daemon is already running.
XAMPP: Another FTP daemon is already running.
XAMPP for Linux started.
R14879:~#

und wie gesagt. bevor ich den security befehl ausgeführt habe, ging alles, ich habe sogar schon 2 datenbanken eingerichtet, was nun?
Botox84
 
Posts: 10
Joined: 06. April 2007 13:04
Location: Rostock

Postby Wiedmann » 06. April 2007 14:05

so jetzt habe ich es noch einmal gemacht. so wie oben beschrieben.


Botox84 wrote:Ich habe /opt/lampp/lampp stop

Wiedmann wrote:Vor dem Löschen natürlich dafür sorgen, dass nichts vom XAMPP mehr läuft (ps und kill).

Natürlich darf zudem auch kein sonstiger Web-/Datenbankserver von deinem System selbst laufen.

Botox84 wrote:und dann rm -rf /opt/lampp ausgeführt.

Ob das dann funktioniert hat, kannst du ja einfach testen, indem du schaust, ob es das Verzeichnis "/opt/lampp" noch gibt oder nicht.

Botox84 wrote:dann den kompletten ordner opt gelöscht

Na hoffentlich war da nichts wichtiges drin für irgendein Programm auf deinem System...

Botox84 wrote:und dann einfach einen neuen ordner mit cmod 777 drauf gemacht,

Ist die Standardberechtigung für Ordner normal nicht 755?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Botox84 » 06. April 2007 14:13

Botox84 wrote:Ich habe /opt/lampp/lampp stop

Wiedmann wrote:Vor dem Löschen natürlich dafür sorgen, dass nichts vom XAMPP mehr läuft (ps und kill).

Natürlich darf zudem auch kein sonstiger Web-/Datenbankserver von deinem System selbst laufen.


wie ps und kill? das versteh ich nicht?
ehm ja, er hat den ordner lampp wieder angelegt, aber datanbank imme noch dawn. mhhhh web-/datenbankserver? habe da nur cod2 spiele drauf, also server ;-) ist doch okay oder?
sry bin nen echter noob, mach das alles zum ersten mal.
Botox84
 
Posts: 10
Joined: 06. April 2007 13:04
Location: Rostock

Postby Wiedmann » 06. April 2007 14:52

wie ps und kill? das versteh ich nicht?

Mit "ps" sieht man, welche Programme (Prozesse) gerade laufen, und mit "kill" kann man diese beenden. Mir dazu mit "man ps" und "man kill" oder einer sonstigen Doku zu deinem Betriebsystem.

er hat den ordner lampp wieder angelegt,

"Wer" hat den Ordner wieder angelegt?

mhhhh web-/datenbankserver?

Naja, wenn schon ein Datenbankserver (MySQL) in deinem System läuft, kannst du nicht einen 2. (den vom XAMPP) starten.

habe da nur cod2 spiele drauf, also server ist doch okay oder?

Keine Ahnung, kenn und sagt mir nichts.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Botox84 » 06. April 2007 14:54

wie soll ich jetzt weiter vorgehen, seh da wirklich nicht so ganz durch?

befehl man ps:

R14879:~# man ps
Reformatting ps(1), please wait...
PS(1) Linux User's Manual PS(1)

NAME
ps - report a snapshot of the current processes.

SYNOPSIS
ps [options]

DESCRIPTION
ps gives a snapshot of the current processes. If you want a repetitive update of this status, use top. This man
page documents the /proc-based version of ps, or tries to.

COMMAND-LINE OPTIONS
This version of ps accepts several kinds of options.

Unix options may be grouped and must be preceeded by a dash. BSD options may be grouped and must not be used with
a dash. Gnu long options are preceeded by two dashes.

Options of different types may be freely mixed.

Set the I_WANT_A_BROKEN_PS environment variable to force BSD syntax even when options are preceeded by a dash. The
PS_PERSONALITY environment variable (described below) provides more detailed control of ps behavior.

SIMPLE PROCESS SELECTION
-A select all processes
-N negate selection
-a select all with a tty except session leaders
-d select all, but omit session leaders
-e select all processes
T select all processes on this terminal
a select all processes on a terminal, including those of other users
g really all, even group leaders (does nothing w/o SunOS settings)
r restrict output to running processes
x select processes without controlling ttys
--deselect negate selection

PROCESS SELECTION BY LIST
-C select by command name
-G select by RGID (supports names)
-U select by RUID (supports names)
-g select by session leader OR by group name
-p select by PID
-s select processes belonging to the sessions given
Manual page ps(1) line 1

ist da alles okay? wie weiter?
Botox84
 
Posts: 10
Joined: 06. April 2007 13:04
Location: Rostock

Postby Botox84 » 06. April 2007 15:34

habs hinbekommen, danke....die lösung, den anbieter vom root anrufen und er sollte einfach den eintrag löschen, fertig
Botox84
 
Posts: 10
Joined: 06. April 2007 13:04
Location: Rostock


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests